2

I think I have the connection with Google established. At least, Mailings/Googlegroup Settings confirms that I am connected. When I go to Manage Groups and select a group so I can set the Google Group to sync with, the Google Group box is blank. No groups to select.

Would appreciate it if anyone had any ideas for solving this.

Thanks!

Drupal 7.4 CiviCRM 4.6.11

1
2

I am on Wordpress, but I had the same problem. I saw the group, but could not see the field. The reason was that my connection to Google API was not properly setup.

  1. If you use Google Apps, pay attention, that on the Google Dev Console you create the Keys with a user which is a Google Domain Admin.

  2. You also need to enable the Advanced API for Admin SDK. Search in Googles Developer Console for the Admin SDK and click on enable API.

When that was done, it took me a couple of hours of searching/debugging, the dropdown to select the groups appeared.

regards, Alain

4
  • I think I've done this correctly. When I go here: admin.google.com The account I'm using is marked as a Super Admin. THen I went here: console.developers.google.com and made a project. Then I went here: console.developers.google.com/apis/… and clicked on New Credentials. Jan 23 '16 at 22:39
  • Selected OAuth Client ID. I selected Web application. left Authorized Javascript origins blank and entered mydomain.com/civicrm/googlegroup/settings?reset=1 as the authorized redirect uri. I turned on every API I could find. Admin SDK is turned on. I copied the Client ID and Client secret and added them to the Google Groups setting page in CiviCRM and to googlegroup.php. Do you see anything I've missed or done incorrectly? Thanks so much for your response. Jan 23 '16 at 22:39
  • In CiviCRM Googlegroups Settings, what did you put down for domain? Just the domain of your website? Any particular format? www.domain.com? domain.com? domain.com? Jan 23 '16 at 22:40
  • I have used just domain.org in the settings. if you have access to your webhost you could try to debug, Try to edit the file api/v3/Googlegroups.php. What I had done, i have added error_log($e) in the exception handling in getgroups or getmembers function. Then check your webservers errorlog and you will see googles errorsmessage which gives you a hint what is missing. Jan 25 '16 at 0:22
1

I got some help to look into this. Turns out that when I first set it up, I didn't have things set up correctly on the Google side of things. Which I realized pretty early on and fixed. The problem was that the googlegroups extension creates and stores the access token in the database and then never refreshes it. So it had an incorrect value stored from when I first tried setting it up that Google was rejecting. It continued to not work even after I had gotten everything set up correctly since it never refreshed it. We forced it to refresh and then it worked :) –

4
  • How did you force it to refresh? Jan 26 '16 at 3:42
  • 1
    added this around line 26 in the googlegroup\api\v3\Googlegroup.php file just before $accessToken=CRM_Core_BAO_Setting... CRM_Core_BAO_Setting::setItem($client->getRefreshToken(), CRM_Googlegroup_Form_Setting::GG_SETTING_GROUP, 'access_token' ); reload the Googlegroups setting page in CiviCRM once with the line in, then comment it back out. Jan 28 '16 at 0:43
  • We tried following these steps for our site, and we still can't get any groups to appear. There doesn't seem to be any verification of the API link with Google, in fact, it almost appears as though the plugin isn't being called at all. May 20 '16 at 2:42
  • @CynthiaWoodard is this plugin still working for you?
    – themak
    Feb 24 '20 at 23:18
0

I'm almost too embarrassed to post this: The solution for me was, on Mailings > Googlegroup Settings, to enter my google domain not my database domain. Why did I think of putting my database's URL there in the first place? It makes no sense to even consider it. Such an obvious mistake, I'm going to go crawl in a hole now. But I hope this confession helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.