2

During creation of a mailing with 10k contacts, frequently, getting black pop-up alerting "DB error" with no other information. Please advise.

mysql> SHOW VARIABLES LIKE 'max_connections';  
+-----------------+-------+  
| Variable_name   | Value |  
+-----------------+-------+  
| max_connections | 200   |  
+-----------------+-------+  
1 row in set (0.00 sec)

PHP Built On: Linux host.alcoholjustice.org 2.6.32-042stab094.8 #1 SMP Tue Dec 16 20:36:56 MSK 2014 i686
Database Version: 5.5.42-cll
Database Collation: latin1_swedish_ci
PHP Version: 5.3.27
Web Server: LiteSpeed
WebServer to PHP Interface: litespeed
Joomla! Version: Joomla! 3.4.1 Stable [ Ember ] 21-March-2015 20:30 GMT
Joomla! Platform Version: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

  • Do you get any additional info when you enable debugging (Administer menu > System Settings > Debugging and Error Handling)? Could you post (or link to) a screenshot of the error? – Jon G - Megaphone Tech May 1 '15 at 15:56
  • Today, on the Joomla Demo site, I have uploaded a list of ~2000 fake email addresses, placed them in a group and proceeded to start a bulk email and receiving the same db error pop-up message. – BruceW May 19 '15 at 19:34
  • And, I am not able to get debugging to work in this view. I've turned it on and used the Smarty extension. The AJAX guts do not appear. – BruceW May 19 '15 at 21:50
  • Here is backtrace from ConfigAndLogs showing timing out: – BruceW May 19 '15 at 23:28
  • Backtrace: pastebin.com/gns2Wkfd – BruceW May 19 '15 at 23:35
2

Looks like this could be the same as or related to issue CRM-16277, which has been fixed for 4.6.3.

|improve this answer|||||
  • Yes, this is exactly it. I will wait for 4.6.3 and test again. – BruceW May 7 '15 at 4:35
  • Applied patch pre-4.6.3 that fixed problem but now it continues to send bulk mailing despite full job showing completion in report. – BruceW May 20 '15 at 20:57
  • If you applied the patch and are experiencing this, to stop the process: `1. Open command line (CLI) terminal (SSH, console, etc.) 2. Type "ps aux |grep cli" (or whatever script you call in the cronjob) 3. Note the ProcessID (PID) number and confirm this is for the exact process that applies to the mailing or running cronjob 4. Type "kill (PID)" 5. Go back to the CiviMail report and keep refreshing browser to confirm it stops sending. – BruceW May 20 '15 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.