2

I am attempting to add a From email address with a .club domain. Civi is stating, "Please follow the proper format for From Email Address" when I try to save the email address. I looked for the error in all of my civicrm plug files and found one line in CRM\Admin\Form\Options.php that has text below. I thought perhaps the "3" was the length of the domain name having to be 3. I changed to 4 and still the same error. Has any one had experience in Civi with "non-normal" domains other than the usual suspects (e.g., .org, .com, etc.)?

  $formName = explode('"', $fields['label']);
  if (empty($formName[1]) || count($formName) != 3) {
    $errors['label'] = ts('Please follow the proper format for From Email Address');
  }
}
  • Forgot to mention -- using Civi 4.6.11 on WordPress platform – Drew Jan 29 '16 at 3:13
  • This may be ignored. It has been resolved. – Drew Jan 30 '16 at 2:22
  • For issues with "special characters" in domain names (eg افغانستا.icom.museum), see also CRM-15975 and CRM-16313. Since you asked re "non-normal" domains :) – Chris Burgess Jan 30 '16 at 20:42
1

The most likely cause of this error is that the email was entered in the format myname@example.org rather than a name and email in the format My Name <myname@example.org>.

While the field label at civicrm/admin/options/from_email_address?reset=1 says From Email Address, the field actually requires you to enter a sender name and email address.

The field help says,

Include double-quotes (") around the name and angle-brackets (< >) around the email address. EXAMPLE: "Client Services"

  • Thanks much! It was a formatting issue. The .club domain has caused issues with some providers, so I just presumed it was one of the newer 4-letter domains causing an issue, but it was that. I'm set now – Drew Jan 30 '16 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.