Since upgrading to 4.7.0 I've noticed a problem with my custom fields (multiple-record, tab with table, and I have 4 multiple-record custom field sets per).

When I click on the custom field tabs for a contact, sometimes the data table does not display correctly. Some of the columns display as "[object Object]" for the entire column (except the heading row) instead of displaying proper data. I have a "Date" column that usually displays correctly, but in one of the custom field sets its data appears in the wrong column.

I also noticed that if I click in the data table's heading row to sort on a column I get an error in Firefox: "DataTables warning: table id=records - Invalid JSON response..."

I run CiviCRM on Joomla 3.4.8 and this issue did not occur for me on 4.6.11 (or earlier versions).

Is anybody else experiencing this issue after upgrading to 4.7.0, or have any ideas?

Edit: this is somewhat intermittent, but happens at least half of the time. Refreshing the page in the browser often fixes it, until next time.

(I tried to reproduce it on the online demo site (Drupal, since the Joomla demo is an older version) but I could not get "tab with table" custom field records to display at all there: after creating a custom field set and some test records, "No records of type '' found." is always displayed.)

  • I don't normally use Drupal but set up a local Drupal 7 server with CiviCRM 4.7.0 to test and found this occurs on Drupal also. I've created a JIRA issue: issues.civicrm.org/jira/browse/CRM-17918 Commented Feb 1, 2016 at 9:19
  • I can confirm that this occurs on 4.7 for WP and Joomla. Commented Feb 2, 2016 at 1:09

1 Answer 1


PR submitted here resolves the issue encountered https://github.com/civicrm/civicrm-core/pull/7720

  • Confirming that "[object Object]" is fixed by the PR (and the fix is in 4.7.1). I'm still getting "DataTables warning: table id=records - Invalid JSON response..." when sorting some columns (particularly date columns). I'll look at this when I have some time again. Commented Feb 7, 2016 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.