1

(Site information/versions at the bottom) I have only used CiviCRM for event registration and entering other events in the calendar. More recently in anticipation of implementing membership capabilities, I had updated to the most recent version 4.6.11 and everything appeared fine. I received a message about running the update on the database and I did that. Everything was fine. But then when I logged on yesterday, I saw that 4.7 was out, so I went ahead and attempted to update to that version. I first just got the white screen. I went ahead and tried to reinstall the 4.6.11 version and got the following message:

Warning: require_once(/home/hobbits8/public_html/administrator/components/com_civicrm/civicrm.settings.php): failed to open stream: No such file or directory in /home/hobbits8/public_html/tmp/com_civicrm/admin/configure.php on line 115

Fatal error: require_once(): Failed opening required '/home/hobbits8/public_html/administrator/components/com_civicrm/civicrm.settings.php' (include_path='.:/opt/alt/php54/usr/share/pear:/opt/alt/php54/usr/share/php') in /home/hobbits8/public_html/tmp/com_civicrm/admin/configure.php on line 115

I tried uninstalling the component and reinstalling again, but once I uninstalled the component, I no longer had the menu entry for CiviCRM. I also followed the instructions for modifying the php (global settings off--already off, max upload--already at recommended level, time --I modified from 30 to 600). I've tried installing both the old (4.6.11) and the new (4.7) from a file upload and also from the tmp folder on the server and get the same result. I saw something about needing to compare settings with the old backup, and of course (dummy that I am), I do not have a backup.

I see someone asked a similar question, but the response to him did not fit either his or my scenario (not upgrading from an old version of Joomla or even an old version of CiviCRM).

  • Joomla 3.4.8
  • PHP 5.3.29
  • mySQL 5.5.45 (innoDB enabled)

Thank you. Patti

1

It sounds like the civicrm.settings.php file may have been removed when the upgrade/downgrade was applied to your site? See Upgrading CiviCRM for Joomla in the section "Back up your CiviCRM database and settings file". Hopefully you have a copy of the file in your backup, and can restore it to the appropriate location.

CiviCRM recommends PHP 5.4 or greater, which might have caused the white screens when you tried 4.7. PHP 5.6 is the oldest supported PHP version at time of writing; as versions 5.3, 5.4 and 5.5 are no longer supported versions of PHP, I'd recommend updating your PHP if at all possible.

  • Thank you for responding. Even though somewhere it said I had PHP 5.3.29, when I went into the area where I can change it, it was already at 5.4. I was able to get a restore from the hosting service, so I'm back where I was before. I'm going to test the update off the main site before proceeding. Patti – Patricia Hobbs Feb 6 '16 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.