2

I am working with CiviCRM 4.6.11 integrated in Drupal 7.4.1 I installed "Relationship Permissions as ACLs" 1.2 (compatible 4.6): https://civicrm.org/extensions/relationship-permissions-acls It is also necessary: "CiviCRM Entity Settings": https://civicrm.org/extensions/civicrm-entity-settings but this extensions is compatible ultil CiviCrm version 4.5 . Can you help ? Thank'you

1
  • I have then installed on 4.6 and so far everything works fine
    – Yossi
    Feb 2, 2016 at 19:10

2 Answers 2

1

I have both of those extensions working on 4.6 without any issues.

4
  • Can you please , post a picture of the options that will enable "Relationship Permissions as ACLs" ? thank'you
    – Andrea
    Feb 2, 2016 at 19:17
  • I'm not sure I understand what it is you want a photo of. I simply enabled both extensions and it does what I expected it to do
    – Yossi
    Feb 2, 2016 at 19:23
  • ok good! I just want to understand where is the section that enables ? thank'you
    – Andrea
    Feb 2, 2016 at 19:36
  • It works ! Setting: administer > customise data and screens > relationship types
    – Andrea
    Feb 2, 2016 at 22:08
2

When the above extensions are enabled, on any Relationship Type you should now see a new field saying Always Permission A to B (and vv). And at civicrm/admin/setting/misc?reset=1 you should see an option for 'Allow second-degree relationship permissions'.

I have added above to the extension page and will ask it be added to the readme if that helps.

4
  • ok I have enable "'Allow second-degree relationship permissions'". but in which menu I find these relationships a/b? thank'you
    – Andrea
    Feb 2, 2016 at 20:12
  • administer > customise data and screens > relationship types.
    – petednz - fuzion
    Feb 2, 2016 at 21:26
  • Great - can you pls 'accept' this answer then as it indicates to others what the solution is.
    – petednz - fuzion
    Feb 2, 2016 at 22:15
  • Ok "Entity Settings Helper Extension" work also with version 4.6.11 of CiviCrm.
    – Andrea
    Feb 2, 2016 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.