2

I recently upgraded our site to 4.7.0. The upgrade seemed to go well, but now there is a problem when starting it up fresh.

The first time I try to start it, the initialisation seems to get lost in an infinite loop in the routine .../civicrm/civicrm/CRM/Utils/File.php on line 680. Using a debugging statement, it seems to be looking for the file pattern "info.xml".

The weird thing though is, that it starts OK if one tries for a second time without closing the browser.

What could the issue be? I have done no special customisations to my installation (as far as I know)

  • I've just tried installing 4.7.1 on top. And I get the message that the database was not fully updated. So – back to the backup and try again... – David Christie Feb 4 '16 at 19:38
1

David, I've seen a few things with the 4.7 upgrades on WordPress that made me double-check the clearing CiviCRM cache's and the browser caches. It hasn't always been apparent that it's been vital in the past, and I'm sure I've been sloppy with it. Is that what you are experiencing?

  • I've now gone through the pain of the database reset and the upgrade fails as follows: [Error: Disable flexible jobs extension] Error 1: Maximum execution time of 20 seconds exceeded in /nhldata/631/106631/data/web/predigerforum/htdocs/wordpress/wp-content/plugins/civicrm/civicrm/CRM/Utils/File.php, line 685 – David Christie Feb 4 '16 at 21:17
  • This File.php seems to get into an infinite loop for some reason... wah! – David Christie Feb 4 '16 at 21:18
  • Thanks for the hint. It helped me believe that all was not lost! – David Christie Feb 4 '16 at 21:39
1

I reloaded the full database yet again. Cleared the caches ultra carefully. Then I set the maximum time limit on my server up to 60 seconds, and the error did not recur.

This time it worked. Hurrah!

BUT - see the various comments. The most important is that I missed the instruction to set up the settings_location.php file because the bootstrap cannot find the settings file in the STANDARD Wordpress set up! Can't that be corrected?

  • Except it didn't: trying to add a new contact... Sorry but we are not able to provide this at the moment. Unsupported html-element – David Christie Feb 4 '16 at 22:39
  • This is solved by following the instructions in: issues.civicrm.org/jira/browse/CRM-17831 – David Christie Feb 4 '16 at 22:45
  • There was also a new issue with cron jobs. grr... >Fatal error</b>: Uncaught exception 'Exception' with message 'Failed to locate civicrm.settings.php. Please boot with settingsFile, search, or CIVICRM_SETTINGS; or normalize your directory structure.' – David Christie Feb 4 '16 at 22:55
  • Uggghh! I'm not using Drupal, but rather WordPress. I'm also having problems with cron, though mine seem to be authentication issues due to a third-party LDAP authentication plugin. It's a long shot, but maybe? – G H Feb 5 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.