2

I am using CiviCRM with Drupal 7 (latest version). After upgrading to CiviCRM 4.7, the Track Click Through links in my mailings have stopped redirecting. They just go to the custom CiviCRM URL's, but don't redirect, leaving simply a white page. Everything worked fine before the upgrade.

As instructed in this post, I have added this code to the .htaccess file in the appropriate block area:

php_value date.timezone "America/New_York"

I also tried using the ini_set command for civicm.setting.php mentioned in the same post.

Help please!

  • Per that post, did you make sure that the php_value line is surrounded by the <IfModule mod_php5.c> if you didn't have it already? – Allen Hutchison Feb 3 '16 at 23:22
  • Yes, I did it exactly as in that post. – The Doctor Feb 3 '16 at 23:25
  • Looks like this: # PHP 5, Apache 1 and 2. <IfModule mod_php5.c> php_flag magic_quotes_gpc off php_flag magic_quotes_sybase off php_flag register_globals off php_flag session.auto_start off php_value mbstring.http_input pass php_value mbstring.http_output pass php_flag mbstring.encoding_translation off php_value date.timezone "America/New_York" </IfModule> – The Doctor Feb 3 '16 at 23:26
  • Roger that. Just checking. – Allen Hutchison Feb 3 '16 at 23:46
  • 1
    Sure thing - from the main menu, Administer > System Settings > Debugging and Error Handling. You will want to enable debugging and backtrace. Then click a tracked link from your mailing and see if it produces any more information. – Allen Hutchison Feb 7 '16 at 16:08
2

This is a known bug in CiviCRM 4.7.1, and it's been fixed in 4.7.2 - which hasn't been released as of this writing. However, if you're comfortable applying the patch, the fix has been released. See https://issues.civicrm.org/jira/browse/CRM-17953 for details.

  • Thanks Jon. I don't really know how to do a patch (I'm not a real doctor. I just play one online), so I will wait for 4.7.2 unless someone is able to spell it out for me how to do this. Thanks. – The Doctor Feb 16 '16 at 0:07
0

If you have access to the server's php.ini file you could try adding the directive there:

date.timezone="America/New_York"

With our host Media Temple, you can include additional directives for the php.ini from within the server UI rather than the command line (in our domain's PHP settings).

  • No such access. :-( – The Doctor Feb 3 '16 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.