**UPDATE #5: See new answer at bottom. It's a fix!

**UPDATE #4: Decided do a clean install of 4.7.1 and see if I can point it to a working 4.7.1 backup database. I suppose I need to follow Kurund's wisdom on this, eh? https://wiki.civicrm.org/confluence/display/CRMDOC/Moving+the+database+using+phpMyAdmin


**UPDATE #3: Well, it's been a nasty Mercury in retrograde these past couple of weeks. Or Murphy's Law has been acting like a troll. Had a power outage last night that exceeded the UPS runtime and this sandbox didn't gracefully shutdown. Ugh! Got it back up except...

4.7.1 gave me a blank screen again. Cleared the cache, checked all settings. All was intact except now missing a few files and folders. Ugh! Tried to reinstall it from Joomla Install-from-Folder function but that now gives me a blank page (500 error). I then decided to uninstall 4.7.1 and reinstall a fresh package but same results. It stopping after 30% of the folder/files are being installed.

I checked the database again, too. Noticed that in table


field is gone

Any ideas?


**UPDATE #2: I was finally able to upgrade after starting with a good 4.6.10 database backup. Then again in table


marked that field column to NULL, and made sure the version number was set back to 4.6.10.

Then reading through the documentation again, deleted




I then performed the 4.7.1 install again and it worked.


**UPDATE #1: Seems there is an error of corrupted table creation in the log files. http://pastebin.com/KajmZuC1

There is an old bug by core developers on this supposedly fixed but here it is again. https://issues.civicrm.org/jira/browse/CRM-9493**

I actually have a dead upgrade now from 4.6.10 to 4.7.1 on Joomla 3.4.8. I am still running PHP 5.4 if that makes a difference considering the warnings during the upgrade.

After initial upgrade, I got a system error message on pop-up and where the notice is at the bottom of the container next to the CiviCRM version number. The error was that no Crons were recorded. I opened Scheduled Events and it showed all active Crons having just been run.

enter image description here

Next, I Cleared Caches but on this settings page the paths were missing from the HTML. I decided to hit the Reset Paths button and then everything went blank.

Front and backends are completely blank now. All paths in civicrm.settings.php and civicrm.config.php are correct including MySQL settings.

Here is the latest entries in the ConfigAndLogs log file. http://pastebin.com/KajmZuC1

Also, "No mailboxes have been configured for Email to Activity Processing" but this shouldn't break the upgrade.

Please advise.

  • Check civicrm log file you will get more information about this error. Also there is php out of date warning, Update your php to latest version.
    – Prem Patel
    Feb 5, 2016 at 4:05
  • Which logfile? Under /media/civicrm/ConfigAndLogs? If so, what I posted above is the last entry. After breakage, it doesn't report. Do you think reinstalling the same CiviCRM version again may help? Current PHP version is 5.4.42. Upgrade says 4.7.1 is last version before v5.5.x is required. Many reports of scripts breaking under 5.5. I won't update PHP until there is some consistency of success.
    – BruceW
    Feb 5, 2016 at 5:06
  • Also, what is this file in /templates_c never seen it before: CachedCiviContainer.29db5e5e478c1b5dfc98274daac8fcbe.php
    – BruceW
    Feb 5, 2016 at 5:09
  • Current PHP version is 5.4.42. Upgrade says 4.7.1 is last version before v5.5.x is required. Many reports of scripts breaking under 5.5. I won't update PHP until there is some consistency of success.
    – BruceW
    Feb 5, 2016 at 5:18
  • I added it in the original posting but here are the current errors in the log file. pastebin.com/KajmZuC1 There seems to be a busted DB table. But, I can't see how this would break the upgrade. "No mailboxes have been configured for Email to Activity Processing"
    – BruceW
    Feb 5, 2016 at 5:47

3 Answers 3


I got CiviCRM to come back by manually entering the paths manually into the CiviCRM Settings Overrides in civicrm.settings.php file. There were some more error but at least CiviCRM came back for me. It is obvious that the Reset Paths is causing problem and it might have to do with the way UpdateConfigBackend is calling a URL for GettingStarted.php. I am not a developer but they all seem to be linked. I shared what I actually did in this posting at the bottom: 4.6.12 to 4.7.1 upgrade causes problems with directories, update paths and clear cache 4.6.12 to 4.7.1 upgrade causes problems with directories, update paths and clear cache


I'm going to add this as an answer because it is what fixed my site after many days of troubleshooting, several sandboxes and multiples of restores.

First off, I use Joomla so Akeeba Backup extension is a savior. Totally worth the subscription to use the Pro version but the free one works just as well.

Now, what became obvious to me was that if hitting the Reset Paths button broke CiviCRM then where are those paths stored. Initially we all thought in the files, right? Hudson Essex Terraplane Club chose to use the override in


which works but is not a fix. It's a workaround.

So, I started to dig deeper after Catorghans (above) suggested a table was corrupt and repair may work. Of course, this was the culprit. Everything in a CiviCRM web form gets stored somewhere, right? But, repairing the table wasn't the issue.

NOTE: At this point I'm thinking this is not platform specific thus is a bug. So this should apply no matter what CMS you are using.

Here is my thought process: As Hudson and I reported, the Resource Paths broke when clicking on the Reset Resource Paths button in Administration Settings=>Clear Cache area. Then Catorghans suggested a broken table. Then the error message that


table error of "not found". So, let's look in the table. Ah-Ha! All the fields that would contain these setting were flagged NULL! This means they were empty. Of course! If the place CiviCRM looks for its Resource URL Paths, no less, it's settings is empty then it has to be an obvious sign.

I then opened up one of the working sandboxes. It doesn't matter which version because for this table the developers probably wouldn't change it that drastically. But, even if they did it would be pretty standard database development to stick with more or less the same convention. At least, that is what intuition tells me.

So, I began to enter in copies of data from a working instance. Viola! It Works! Just in time to leave for CiviDay with Neil Planchon and friends in Oakland, CA.

Immediately do a backup!


A corrupt table could explain this. I would repair it. First repair and see if it works already. If not, restore the backup, make sure table is still fixed (or repair again) and upgrade again.

If you have access to phpMyAdmin, you can select all tables at the bottom and then choose "repair tables".

If you do not have phpMyAdmin, but you have access to ssh then you can use mysqlrepair (or mysqlcheck -r), see more at http://linuxcommand.org/man_pages/mysqlcheck1.html

If you have neither you should ask your hoster to do a repair for all tables.

Good luck.

  • Thanks. Actually, I removed the last update because I was working on a sandbox version and it appeared to have an older db that didn't have that module_data field updated to it. I am rolling this back again with a fresh restore. Will provide an update.
    – BruceW
    Feb 8, 2016 at 11:18
  • I am having the same problem in my test region. When I went to clear cache/set paths, my civicrm pages went blank in the front and backend. I have tried repairing all the tables in my test region, with no change. i will not upgrade to 4.7.1 until I know what is causing this. Feb 9, 2016 at 3:56
  • Hudson, I just did a clean restore did the upgrade. It worked but when I went into the admin settings for Clear Cache and paths nothing was listed. So I clicked on that button AGAIN and it AGAIN left me with blank pages. Checked all the config files again and nothing has changed. I just can't figure out what is being affected here. BUMP!
    – BruceW
    Feb 16, 2016 at 10:50
  • Catorghans, you mention a table could explain this. Which table do you think it is?
    – BruceW
    Feb 16, 2016 at 10:51
  • I did find that in table civicrm_domain the field config_backend went missing. I replaced it but to no avail.
    – BruceW
    Feb 16, 2016 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.