1

Running WordPress 4.4.2 and CiviCRM 4.6.11

Haven't done an upgrade recently and have been using CiviCRM all day with no problems to suddenly encounter:

Fatal DB error, exiting, seems like your schema does not have civicrm_setting table

We did migrate servers yesterday and disabled Cloudflare but it just suddenly stopped!

Where to start looking?

-1

I would start looking at corrupt tables.

If you have access to phpMyAdmin, you can select all tables at the bottom and then choose "repair tables".

If you do not have phpMyAdmin, but you have access to ssh then you can use mysqlrepair (or mysqlcheck -r), see more at http://linuxcommand.org/man_pages/mysqlcheck1.html

If you have neither you should ask your hoster to do a repair for all tables.

2
  • Thanks. I ended up restoring the database to a backup. But I just gave repairing them a go, as you suggested, but unfortunately got the error that that the storage engine for the table does not support repair. So I've asked my webhost for help. I also noticed that there are duplicate tables for _en_US - the first one displays an error, the second "corrupt". This has only occurred after the restore. I'm worried about the tables disappearing again - it's happened twice so far. – Esther Feb 10 '16 at 11:51
  • Did the table actually disappear? If not, then the error message is incorrect. Perhaps something in the table is missing. As Catorghans suggested, do you have PHPmyAdmin or some way to peruse your database? In my case, all the URL paths got marked NULL in this table. I manually entered them back in and...Viola! – BruceW Feb 25 '16 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.