1

I’m having the same issue as what appears to be listed here:

https://issues.civicrm.org/jira/browse/CRM-17864

I get the same "Network Error" message every time I press the CiviCRM button on the WordPress 'new page' screen when using Chome, FF, and Safari. Perhaps it is an admin or setup error on my part, and not a CiviCRM issue.

I took a screen shot that includes the browser console log if it might be helpful.

enter image description here

2

Your page edit screen shows (I think) a URL of the form 'http://domain.ca/civicrm/wp-admin...' whilst the 404 error is looking for 'http://domain.ca/wp-admin/admin.php'. This suggests to me that you're using WordPress Multisite with CiviCRM active on a site that is not the main site. This is not supported at present - CiviCRM is only functional on the main site of a multisite instance.

Edit: this URL schema could also be the result of installing CiviCRM in a sub-directory. This is also unsupported, though it's an issue that's being addressed.

  • I have a client who uses CiviCRM multisite very actively in a WordPress multisite (subdirectory-based, not subdomain). It's been going for over a year successfully with minimal pain, and posted basic docs to the multisite wiki page. I'm wondering what's unsupported? – Jon G - Megaphone Tech Feb 11 '16 at 5:44
  • I'd be interested to know how they're doing this, Jon. Network-activating CiviCRM in WP multisite (sub-dirs) leads to all CiviCRM back-end URLs pointing to the CiviCRM back-end on the main site. Can you post an URL to the wiki page you're referring to? – Christian Wach Feb 11 '16 at 11:25
  • I created a separate question for this, since we're getting off-topic (here: civicrm.stackexchange.com/questions/9602/…). In short though - you put a "switch" statement into civicrm.settings.php, and define your BASE_URL in the switch statement. – Jon G - Megaphone Tech Feb 11 '16 at 18:04
  • The answer provided fixed the problem. I started from scratch with a clean install and was sure not to click the 'multisite' checkbox. Thank-you. – Adam Worobec Feb 13 '16 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.