3

I really need to allow WordPress users to submit their work experience via a page and shortcode... I've read here that it's not possible to allow a multi-value set of fields to be edited via a profile (being embedded into a WordPress page): Multi-value fields in profiles - how to?

...but these docs show it happening with a really tempting screenshot (search for "work experience" to find the section): http://book.civicrm.org/user/current/organising-your-data/profiles/

Civi Books screenshot

...so I wondered if it was now possible somehow or if this documentation was incorrect? Perhaps it's only possible with Drupal? We're stuck with Wordpress atm.

****** EDIT ***** Re-created issue on http://wpmaster.demo.civicrm.org/**

To recreate this issue, create a multi-value custom field group, then set up a profile and add the fields (following documentation). Try to test the profile in Create Mode, the error is thrown:-

"Sorry but we are not able to provide this at the moment. The requested Profile (gid=14) is not configured to be used for 'Profile' edit and view forms in its Settings. Contact the site administrator if you need assistance."

PHP Warnings:- Warning: Invalid argument supplied for foreach() in /srv/buildkit/build/wpmaster/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/CustomOption.php on line 84 Warning: Invalid argument supplied for foreach() in /srv/buildkit/build/wpmaster/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/CustomOption.php on line 84 Warning: Invalid argument supplied for foreach() in /srv/buildkit/build/wpmaster/wp-content/plugins/civicrm/civicrm/CRM/Core/BAO/CustomOption.php on line 84 Warning: fopen(/srv/buildkit/build/wpmaster/wp-content/uploads/civicrm/ConfigAndLog/CiviCRM.8ae48cedfddd4cf1265fa95ce1274dd9.log): failed to open stream: Permission denied in /srv/buildkit/build/wpmaster/wp-content/plugins/civicrm/civicrm/packages/Log/file.php on line 216 Warning: fopen(/srv/buildkit/build/wpmaster/wp-content/uploads/civicrm/ConfigAndLog/CiviCRM.8ae48cedfddd4cf1265fa95ce1274dd9.log): failed to open stream: Permission denied in /srv/buildkit/build/wpmaster/wp-content/plugins/civicrm/civicrm/packages/Log/file.php on line 216

  • might help to confirm your version of civi – petednz - fuzion Feb 10 '16 at 18:47
  • Sorry Pete, we're setting up CiviCRM 4.7.1 with WordPress 4.4.2. – Darren Feb 11 '16 at 10:15
  • Tried on Demo site: wpmaster.demo.civicrm.org, but unable to add shortcode to a page. – Darren Feb 11 '16 at 10:29
  • Looking at Jira I can't see a bug report raised for this. Should I go ahead if there are no answers here? – Darren Feb 11 '16 at 10:49
  • Please note this error is in "Create" mode, rather than "Edit" mode, which may simply be a limitation we need to live with. – Darren Feb 11 '16 at 11:48
2

Seems the only workaround is to use the "Edit" mode for the profile, rather than "Create" mode.

The limitation being this will only work for logged in users.

1

Since this is in theory in-built capability i expected it to be cms agnostic but i don't see it working when i try on demo at http://wpmaster.demo.civicrm.org/civicrm/?page=CiviCRM&q=civicrm/profile/edit&gid=14&reset=1

Which may mean this is a bug that should be added to Jira

  • I'm seeing the same behaviour using the "Classes" group of fields, Pete, but this doesn't really help answer the question. – Darren Feb 11 '16 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.