0

I have an issue with PayPal receipts. They are appearing as "Pending (Incomplete Transaction)".

I have discovered that there was a fix to the file BaseIPN.php in CiviCRM 4.3, but looking at the modified 4.3 file and my version (4.7), they appear totally different.

The receipt is successfully received in PayPal and the user is taken to the "Thank you" screen, with no errors, however the transaction in Contribution Dashboard is showing as Pending.

Is this a similar problem as was reported in version 4.3? If so, what would I need to change in the 4.7 version of BaseIPN?

Joomla 3.4.8 / CiviCRM 4.7.1 / PHP 5.6 (FastCGI)

PayPal IPN History reports the following:

Message ID 0T926689FX401850L Date/time created 11/02/2016 16:14 GMT Original/Resent Original Latest delivery attempt date/time 11/02/2016 16:14 GMT HTTP response code 200

These are the only errors I can see in the log with debug switched on for the same time period. They may be related, or may not...

Feb 11 10:12:36 [info] $GET = Array ( )

Feb 11 10:12:36 [info] $POST = Array ( )

Feb 11 10:12:36 [info] Could not find an entry for txn_type in POST

Feb 11 10:12:36 [info] $error data = Array ( [error_code] => 0 )

Feb 11 10:12:36 [info] $REQUEST = Array ( )

Thank you.

  • have you been able to resolve this issue on your Joomla/Civi sites? I have just started experiencing the same problem on my site after one of the recent updates. Your feedback will be greatly appreciated. Cheers, Adri – user3360 Jun 4 '16 at 4:46
1

This came up on the old site: Not receiving IPNs from Paypal Standard

Short answer was there were mod_security rules on my server blocking the IPNs from coming back.

  • Thanks, I will contact my ISP support, however have been waiting for over 2 weeks for another issue to be resolved, so guess I'll not be using CiviCRM anytime soon :-( – Lee Cooper Feb 12 '16 at 14:25
  • Wow, 2 weeks! I would start looking for another ISP. I have had good luck with Hostgator, but I know most folks on here would advocate for an ISP that supports CiviCRM. You might want to look around and see if your current price justifies such poor customer service. Just my two cents. – Hudson Essex Terraplane Club Feb 12 '16 at 17:28
  • Here is another possible thing to look at if you are using Paypal Pro: Why does CiviCRM 4.4.20 try to use the wrong listener for Paypal Pro recurring transactions? civicrm.stackexchange.com/questions/9394/… – Hudson Essex Terraplane Club Feb 12 '16 at 19:14
  • 1
    I don't think hosting is the problem ... I have exactly the same issue on 2 separate servers both sites using Joomla both issues started after Civi update in Feb..... – Dave Florence Mar 12 '16 at 21:20
1

Do you have a firewall installed? I had the same issue, but found out that RSFirewall was blocking PayPal's IPN's, otherpeople have found that the HTCAccess file was blocking them.

Here is the resouce I used to let it through: https://www.rsjoomla.com/support/documentation/rsfirewall-user-guide/frequently-asked-questions/rsfirewall-blocks-paypal-responses.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.