The wiki currently states that CiviCRM has bare minimum (5.3.10) and recommended (>= 5.4) PHP requirements.

Knowing what CiviCRM has been tested with can help identify what should be expected to work reliably.

  • As of today, what versions of PHP do CiviCRM's test infrastructure test with?
  • This question will become out of date over time; for future reference, is there a better place to check this information?
  • For orgs who aren't able to match the PHP versions that CiviCRM is tested with internally, what other options are available?

1 Answer 1

  • At time of writing, all PRs tests and scheduled tests run under Ubuntu 12.04 (PHP 5.3.10). There is an effort underway to introduce a test node for Ubuntu 16.04 (PHP 7.0) (although details are still a bit in flux).
  • When you inspect the results of a test run, you can get some details (such as the node name and console output). The node names follow a convention -- test-ubu1204-5 is running Ubuntu 12.04 (precise); test-ubu1604-1 is running Ubuntu 16.04 (xenial).
    • This tells you the general platform and hints at the PHP version. I'd like to keep these generally aligned with upstream versions.
    • As a somewhat stronger statement, I want to keep the test nodes aligned with civi-download-tools --full, which autoinstalls system requirements on some common builds of Ubuntu/Debian. If you know the target platform, you can lookup a more specific list of packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.