I am using the latest Wordpress with Polylang and CiviCRM versions. I try to call the online event registration form in both German and English, but I don't know how to do it.

How can I force CiviCRM to switch to a specific language? The &lcMesssages=de_DE parameter has no effect at all, neither does &lang=de.

Inherit language from CMS also does not work - I cannot even see a pattern. When I call CiviCRM from the Dashboard, it's always the current language, just from Wordpress itself, it does not work at all.

But there must be a way to force CiviCRM to use a specific language - or not? Any help is appreciated.

1 Answer 1


Polylang is not supported by CiviCRM yet but it should change soon : I have just submitted a patch here : https://github.com/civicrm/civicrm-core/pull/11312

If you still have a need for this functionality, you should try it and confirm if it resolves the problem.

To make it work with the patch :

  1. Install Polylang and configure at least 2 languages polylang - languages config wordpress

  2. Configure CiviCRM in multiligual mode with 2 languages and set "Inherit CMS Language" settings - localization wordpress

  3. In civicrm.settings.php, uncomment as needed lines like : define('CIVICRM_LANGUAGE_MAPPING_xx_XX') (to resolve ambiguity between language short 'fr' and language long form 'fr_FR' or 'fr_CA')

  4. Create a contribution page and translate at least the title
  5. Add a page with the shortcode to the contribution page and translate it to the second language edit page shortcode and language wordpress
  6. You should be able to go to one page you've created and switch language to have another version of the same form

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.