0

This might be a silly question - how do I import notes into existing contacts? I tried importing data to the Note field with the related Contact ID, which results in the following warnings - with no visible alterations to the records I'm trying to update. I can import memberships and activities but can't find the option for Notes anywhere.

Warning: Illegal string offset 'code' in /wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php on line 969

Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php:969) in /wp-content/plugins/civicrm/civicrm/CRM/Utils/System/Base.php on line 895*

  • 2
    I just tried in on the demo for wp 4.7.2 and it worked. I had a cvs file with two columns: id, note. I imported to individuals and did an update. It automatically matched to the columns to internal identifier and note. So what are the steps you are using? – Paul-Tahoe Feb 18 '16 at 3:24
  • Brackets all through the data. You are correct Paul, thank you for responding so quickly – Jambo Feb 18 '16 at 3:29
  • I do not know why the error, some data is imported, some isn't. There is no great difference between the type of characters in those that succeeded and those that failed. I started checking at the first record of my csv and it failed, but some further on worked OK. So I have 2000 odd contacts to review and check the Notes on. No clue why this happened, although I thought it was special chars, but it's not. – Jambo Feb 18 '16 at 3:39
  • Are some of your notes excessively lengthy? If so, perhaps Civi is not happy with the amount of data that you're trying to insert. Additionally, I'm not sure how many records you're trying to import/update at once, but you might consider breaking it up into smaller chunks, especially if there is some lengthy data in there. – Lesley Carter - BackOffice Feb 18 '16 at 16:06
  • Thank you Lesley, I did break the data down to run a couple of tests and they worked fine. I also have the suspicion, which I am yet to confirm, that there is at least one rogue entry. I am thinking it is an issue with the contact type rather than the length of the data. Will investigate further and revert. – Jambo Feb 19 '16 at 6:56
1

The issue was due to unexpected multiple contact types in the same import file. Resolved by splitting import files by contact type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.