6

For those that are using CiviRules, what has your testing on CiviCRM 4.7.x shown? Is this something that is showing major issues, minor issues, seems to fine? Having never used CiviRules, I've got no basis from which to begin test, but may have reason to use the extension now.

(CiviCRM 4.7.2 is the current stable at the time of writing.)

6

I'm in the same boat! Just about to install and enable as we need to trigger email to customer when they submit a profile from WordPress...

UPDATE From initial testing it seems to work fine with 4.7.3 however I have only used the "Add to group" trigger and "send email" function. Both seem to work fine.

UPDATE 2 CiviRules is working on a live site now and performing well. Only have 10 rules which just send emails when people are added to groups. The delayed actions also work fine.

So to get it installed on 4.7.x, simply edit the "info.xml" file for the extension, adding <ver>4.7</ver> under the /extension/compatibility element and then installing as normal.

This is by no means a comprehensive test! Please perform your own prior to a live release!

2

Found an apparent problem in the comparison routine. Posted on the GitHub page: https://github.com/CiviCooP/org.civicoop.civirules/issues/68

Also, the New Contact trigger does not seem to be working: https://github.com/CiviCooP/org.civicoop.civirules/issues/79

-1

Doesn't seem to work with any of the event triggers (create,change,delete) across versions 4.6.x and 4.7.x

This error message comes up.

Sorry but we are not able to provide this at the moment. One of parameters (value: ) is not of the type Integer

  • I see you have been asking this question three times on stack exchange – Jaap Jansma - CiviCooP Jul 1 '16 at 13:16
  • I created 1 question asking about a function that didn't work. Then I found 2 questions asking about issues with civirules with versions 4.6.x and 4.7.x and I answered them both with the current issue I am having as I have cross tested on both versions. So other people who are installing civirules who are after similar functionality are aware. I have also created an issue log on the official github repo so the ext creators are aware of the issue. Why have you given my answer a negative rating? – pacusi Jul 1 '16 at 13:58
  • I have given you a negative rating because you have indeed found a issue with events and posted that correctly on github. However that issue has nothing to do with 4.7 nor 4.6 compatability. So your answers will confuse people – Jaap Jansma - CiviCooP Jul 6 '16 at 6:20
  • Are we reading the same question asked? For those that are using CiviRules, what has your testing on CiviCRM 4.7.x shown? Is this something that is showing major issues, minor issues, seems to fine? I answered saying there is a issue with creating event triggers as it doesn't work as expected. The answer before mine says the New Contact trigger doesn't seem to work either. Yet I get a negative rating? @jaap jansma – pacusi Jul 6 '16 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.