3

I have a problem that appears to be similar to this post: https://forum.civicrm.org/index.php?topic=34290.msg145436#msg145436

I'm in the middle of setting up an evaluation instance of CiviCRM within my staging WordPress environment. I used FTP to upload all files and folders into a newly created civicrm folder within the wp-conten/plugins folder. It appeared as a plugin and i clicked "activate", which seemed to go well. I followed the link to configure, validated ddatabase information, clicked "Verify and Install" (or whatever it was) and it seems to have run without issue, except that I can't proceed with step 6 of the install instructions. All prerequisites were met.

I have no civicrm.settings.php file to backup (or even view).

When I click on the "CiviCRM" link in the main navigation, I get a page that looks like this:

ScreenShot of CiviCRM Main Page

Note there's an error, but when I click on the error link it doesn't tell me anything. Figuring perhaps I'll just proceed without backing up the file, step 7 talks about performing functions I don't have available to me in this state.

I'm stuck. I've tried this twice, and both times the results are the same (thinking perhaps I missed a step earlier, which is still quite possible, but I don't think so after doing it twice).

Any help would be appreciated.

WordPress Version: 4.4.2 PHP Version: 5.5.9-1ubuntu4.14

Clicking on "Refresh Dashboard Data" first couple of times didn't do anything, but the 3rd time it gave me the following in a red box: System Status: Error Cron Not Running Configure Default Mailbox Complete Setup

The link to "View details and manage alerts" didn't render anything.

  • I have exactly the same issue when installing 4.7.1 on wordpress. – DirkV Feb 20 '16 at 10:51
  • I just tried this on my WPE account and it failed as well. It's possible they are doing something 'tricky' with the install directories. They have moved wp-content (that should be OK) but I am getting a bunch of resource not found errors - CiviCRM cannot find the files and the paths point to exactly where they should be. Can you look in a web inspectoir (I like firebug) and see what errors you receive? – Kevin Cristiano Feb 20 '16 at 15:39
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Allen Hutchison Feb 20 '16 at 22:05
0

Am new to CiviCRM and have installed WP many times on various platforms. I had the same issue installing the latest version (4.7.3) with WP.

First tried installing CivicCRM on an existing test WP site using the existing MySQL DB. Got same error as explained above. Next tried new WP (4.4.2) and different DBs, no luck? Tried to give cli.php write access as mentioned on a forum, no luck. Wasted time trying to chase cron jobs not running error? Actually, this can be handled later and is not critical for installation! Got timestamp mismatch error (again, not critical). Verified MySQL and PHP times, seem to be OK.

Finally, tried to install prior version (4.6.14) and found bunch of errors during the installation step! Turns out that it requires wp-content/plugins/files directory with write permission! This seems to be correct and not reported by new version! Create the directory and installation seems to have worked. Need to spend some time to get familariazed with it next.

Hope this saves some of you some time (cost me 5 hrs and tons of frustration!)

  • The location of the files directory was moved in 4.7. Previously (4.6.x) it had been plugins/files/civicrm. Now it is uploads/civicrm in 4.7. If your php user has the ability to create files and directories under /uploads then now – Kevin Cristiano Mar 23 '16 at 12:27
  • Last sentence ^ s/b - If your php user has the ability to create files and directories under /uploads then it will be created for you. Otherwise you will get a warning to create it first. – Kevin Cristiano Mar 23 '16 at 12:45
5

I dug further into the changes that WPE does to the file structure.

It looks like the new magic method of determining the file location using [civicrm.files] is failing. See https://github.com/civicrm/civicrm-core/blob/master/Civi/Core/Paths.php

I am able to get both 4.6.13 and 4.7.2 running on WPE by adding the following to my civicrm.settings.php file right after the opening <?php tag:

global $civicrm_setting;
$civicrm_setting['Directory Preferences']['customTemplateDir'] = '/nas/content/live/kcrist/wp-content/civicrm/templates/';
$civicrm_setting['Directory Preferences']['customPHPPathDir'] = '/nas/content/live/kcrist/wp-content/civicrm/php/';
$civicrm_setting['Directory Preferences']['extensionsDir'] = '/nas/content/live/kcrist/wp-content/civicrm/extensions/';
$civicrm_setting['URL Preferences']['extensionsURL'] = 'http://kcrist.wpengine.com/wp-content/civicrm/extensions/';
$civicrm_setting['URL Preferences']['imageUploadURL'] = 'http://kcrist.wpengine.com/wp-content/uploads/civicrm/persist/contribute/';
$civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = 'http://kcrist.wpengine.com/wp-content/plugins/civicrm/civicrm/';

This is based on the following article https://wiki.civicrm.org/confluence/display/CRMDOC/Override+CiviCRM+Settings

Give this a try and I will create an issue for the [civicrm.files] issue. edit- Issue updated https://issues.civicrm.org/jira/browse/CRM-18009

  • Thanks Kevin! You're right, we are on wpengine. I'm really happy with them in general. I'll try this when I get home later today and let you know how it works out. Fingers crossed. – Bob Smiley Feb 20 '16 at 20:09
  • OK, now that I'm at my computer giving it a try, I don't see the file in the uploads/civicrm folder (where you found it). My uploads/civicrm folder is empty. So I'll try to create a file and hope I get the format right and test it out, but I may need more help. I think I saw mention of a sample settings file that I can look for to ensure I get the right format. – Bob Smiley Feb 20 '16 at 23:37
2

Looks like the menus did not build correctly. I would install this plugin https://wordpress.org/plugins/civicrm-admin-utilities/

You can activate and it allows for a menu rebuild and a cache flush.

The file civicrm.settings.php is in uploads/civicrm

I do see that you are on WP Engine, to be honest , I have not been able to install CiviCRM on WPE.

Try clearing the cache and menu via the plugin. If that fails, I would move the civicrm.settings.php file to plugins/civicrm

We look in both locations for the settings file. It is much better outside the plugins folder, but we can try this.

Please let me know if we make any progress.

  • I was able to install these utilities manually (the canned installation didn't work, presumably because the settings file isn't working right yet), but unfortunately the rebuilding of menus didn't make any difference. I'm still looking for the settings file; for my install it didn't land in the uploads/civicrm folder as you found in yours. I have no file named civicrm.settings.php anywhere in the set of folders touched by civicrm. If I can get a file to use as a template I can then drop it into the folder to see how well that fares. I wonder what other files might be missing. – Bob Smiley Feb 21 '16 at 0:22
  • If you have a version that was upgraded the settings file is in plugins/civicrm a new install should have the file in uploads/civicrm if it is missing, you should not even get the screen you uploaded earlier – Kevin Cristiano Feb 21 '16 at 0:46
  • Well, I'm not sure how to explain it then, but when I search all folders for a file by that name it comes up empty. I'll continue looking into this on Monday and let you know what I find. – Bob Smiley Feb 21 '16 at 16:14
0

OK, so I had similar problem - the CiviCRM menu is perfect for http URLs but as soon as you switch to https, the menu breaks.

In my installation, there appear to be two civicrm.settings.php files:

  • one in uploads/civicrm and
  • one in plugins/civicrm

They appear to be the same file. Both of them have several URLs that need amending from http to https:

  • Lines 80 to 82 under '// Additional settings generated by installer:'
  • Line 222, where the CIVICRM_UF_BASEURL is defined

In addition, I've changed the WordPress address in the WordPress UI (in Settings > General)

And fianlly, the CiviCRM Resource URL in the CiviCRM > Administer > Resource URLS (http://yoursite.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2Furl&reset=1)

Then I cleared the cache and I think I also rebuilt the menus (using the CiviCRM Admin Utilities plugin) and it works!

Took me several attempts to get this working!

  • So, just to confirm, the file in plugins/civicrm is no longer needed. Not sure why it's still there in my install but I've deleted it and nothing broke! – Rose Lanigan Feb 9 '18 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.