1

Drupal 6.7 Civicrm 4.7.2 php 5.5.13 mysql 5.6.(sumpin')

I have looked at so many other threads that had this problem. I checked to make sure all the contacts in the group are not listed as deceased (we are not) and I've made sure that all the groups are mailing lists.

If I go to "manage groups" and choose the small test group I made, I can select all members of that group and "E-mail - schedule/send via Civimail" THEN, and only then can I get the recipients to fill in. BUT if I click on the little wrench to edit options, the dialogue window opens, but the whole screen gets greyed out. At that point, I have to F5, or reload, or choose another menu option ... something to take me away from that screen.

So, I made a larger group, one that I would normally send our newsletter to. About 3500. I selected the members of that group and chose "E-mail - schedule/send via Civimail". They were all added to the recipient box. But no matter what I do, after I type in the newsletter contents, it will NOT SAVE. It also will not preview. Therefore, it won't go to the next screen.

It does show up in Unscheduled mailings, but without any content in the body. I still can't add it.

Can anyone help me troublshoot? I really need to be sending out mailings for our organization, but I can't.

1

From your comment referencing the forum post, I can see that this is a Javascript error. You should be able to resolve this by following the steps outlined here: Troubleshooting JavaScript in CiviCRM

0

The easiest way to use Mailings is not via the group contact list and select all contacts, but to go directly to "Mailings" in the top menu bar.

There you select "new Mailing". In that screen you can select the Mailing Group(s) you want.

Does your error occur there too?

  • Thank you so much. Yes, the error occurs there as well. Exactly as described. That's what made me go look and see how to get recipients into their field in the first place. I thought choosing the group would be a workaround until I could get it tackled, but it didn't work. – Missy Scott Feb 23 '16 at 22:06
  • Not sure why you get a grey screen when clicking on the wrench. Do you know what is in there and do you need it? In there are options to change the email location type. Does the mailing work when you just ignore the wrench? The Next button will only work if all required fields are filled. But "Save Draft" should always work. – Catorghans Feb 23 '16 at 22:19
  • The little wrench seems to hold dedupe rules. dedupe by email. The mailing will work if I'm only mailing three people. And, even in that, it was only a word or two of text ("test and time"). I haven't even tried it with a lengthier message, like what our newsletter would be. In the test with three contacts, and a tiny message, the save and next buttons worked fine. – Missy Scott Feb 23 '16 at 22:32
  • I've been comparing my site to the drupal6 demo and finally noticed that the drop downs in the mail component are different ... they are all already dropped down and pushed to one side. I'm wondering if this is a js issue, but no other components are like that. – Missy Scott Feb 24 '16 at 1:56
  • Digging in some more... I've found my issue is exactly like this: forum.civicrm.org/index.php?topic=36343.0 – Missy Scott Feb 24 '16 at 2:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.