1

I have Access denied when : Administer > ... > Custom Data > Display and Edit Custom Fields

I notice that "www." is added between htpps:// and my site name : https://bapa-lacellesaintcloud.com/drupal/index.php?q=civicrm/admin/custom/group&reset=1 is moved to : https://www.bapa-lacellesaintcloud.com/drupal/index.php?q=civicrm/admin/custom/group/field&reset=1&action=browse&gid=1

... and I get the right form when I (manually) remove this "www." from the URL

Why (how ?) is this "www." added ?

BTW : I don't have this error on 2 test sites which are not https but only http ; All my sites have been upgraded to 4.7.2, but I am not sure that this problem was not there before.

1

Take a look at this answer. Another possibility is that your web server has a rewrite that adds the www. Another possibility is that there's an .htaccess file in your CMS's path that's adding a rewrite.

  • I think you are right : when I passed this site in HTTPS a colleage modified the .htaccess file (I am not able to do this by myself) and must have missed sthg ; I have to manage this with him, and will come back. Thanks a lot – Jacques-Marie Moranne Feb 25 '16 at 11:19
0

Have you checked your settings file to ensure the base URLs are set correctly? From the Civi 4.7 demo site I see that some changes have taken place in how those are handled (with tokens instead of direct references in the Resource URLs page): http://screencast.com/t/lYLFOtdqrkK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.