2

CiviMail and CiviSMS both default to tracking click-throughs. To do so, it converts a link like http://www.cnn.com to something much longer, like https://www.example.com/wp-content/plugins/civicrm/civicrm/extern/url.php?u=91701&qid=2521100. That's fine in CiviMail, when you a) can turn it off, and b) you can hide it behind a hyperlink - but it can be really annoying in a text message.

Since there's no "track click-throughs" checkbox when creating an SMS, how do I fix this?

2 Answers 2

5

You can install this extension: https://github.com/PalanteJon/coop.palantetech.nosmsurltracking. This will automatically turn off click-through tracking on all mass SMS messages. There's no checkbox (unless someone codes one in), so it turns tracking off on ALL messages - but if you need tracking on a single message, you can disable the extension temporarily.

0

If you do not use https:// my Android phone recognizes it as a link and makes it hyperlinked.

On Civi 5.23.4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.