1

This one has me baffled. I've got a membership contribution page that works just fine with paypal standard payments (membership is processed and everything ends up correct, no problems.) It also has a pay later option. This works in so far as a pending transaction and membership is created. It does not, however, show the pay later instructions at any point to the user. It does not send any email from the contribution page, I think it should. When you manually enter payment then it will send a receipt.

I'm stuck for things to look for. I can't find any errors in any drupal logs or the civiCRM log file that look remotely relevant. There is no custom code being used anywhere, everything is straight up configuration of civiCRM. There is no customization of email templates. The only thing I've done that is unusual is this used to be a civiCRM installation on Joomla that has now been moved to Drupal. I thought the pay later instructions were being displayed correctly when I fist did the transfer to Drupal, but maybe I saw things that were not there, not sure. I've added more extensive instructions since then and they don't show. The same instructions for pay later do show on event bookings (I've used the same text copy and paste.) Pay later works as expected on the events and sends emails and everything.

The civiCRM version currently running is 4.7.2 after just upgrading from 4.7.1 - there was no change with this upgrade.

Any ideas on where to look next? Do I need to turn on debugging and stat looking for things that way? Is there an obvious answer I've overlooked? I welcome all ideas.

  • What version of CiviCRM are you using? This sounds suspiciously like some bugs that have been fixed in current versions. – Jon G - Megaphone Tech Feb 26 '16 at 4:50
  • CiviCRM 4.7.1 - there is one more minor version now available. Alright I'll try that. <mumble> When did that one pop up, must be very recent. </mumble> – Josh Feb 26 '16 at 7:58
  • OK, upgraded to civiCRM 4.7.2. No change. Drupal is at version 7.43 if anyone is interested. – Josh Feb 26 '16 at 8:53
  • have the same issue - is a significant problem in that pay by check donors do not get the reminder to send payment. – Dave T Mar 3 '16 at 12:44
  • I'm using CiviCRM 4.7.3 on WordPress and encountering the same problem. – Esther Mar 8 '16 at 12:43
1

Just Managed to test the same against CiviCRM 4.7.2

Membership has been created with an contribution pending status

But in pay later option their is no email sent in Civicrm 4.7.2 Where as when payment is made using dummy payment processor an receipt is been sent out

I guess this is an Bug in this version so you should wait till the next release or you need to roll back to CiviCRM Version 4.6.10 where this option is working fine - Please raise an issue for the same so this gets fixed in next release

  • I guess this helps
  • @Josh - based on Ramesh's answer, this is not only a bug but a regression. If you can open a ticket at issues.civicrm.org with step-by-step instructions for replicating this on the demo server at demo.civicrm.org, it will get the attention of the core team. – Jon G - Megaphone Tech Feb 26 '16 at 20:09
  • 1
    Yes, a bug. I opened an issue issues.civicrm.org/jira/browse/CRM-18118 and there supposedly is a fix for this now. I'm yet to test it. I'm yet to figure out how to test it! Off I go to do so. – Josh Mar 4 '16 at 0:02
  • 1
    I tested on my test VM. Seems to work. All should be good in version 4.7.4 when it is released I hope. – Josh Mar 7 '16 at 3:08
  • I've just installed 4.7.4 and all is fine for me. Other people seem to be having problems, I think they might be using Joomla where as I am using Drupal. – Josh Mar 22 '16 at 0:45
0

UPDATE: Issue returned in 4.7.4 .... "pay later" does not display on LIVE pages, while it does on the backend when using the 'test drive' link.

I was able to test the patch on my website, and the "pay later" now shows the proper instructions.

However, I'm still having issues with receipts not being sent. Different issue, and I'll pursue that elsewhere.

That said ... I wish whoever is in charge of maintaining the Joomla demo site would take the time to UPGRADE the site to 4.7.3, or 4.6.14 at least

  • Not having this problem on Drupal: maybe this problem is confined to Joomla!? Somehow... – Josh Mar 22 '16 at 0:43
0

Just updated to 4.7.4 ... Pay Later block no longer appears.

While 4.7.4 is supposed to have a fix, it DOES NOT and reverts back to old behavior.

Did some additional testing. While the Pay Later block appears on the backend when you do a 'test drive', when you go to the 'Live Page' it does not.

Major regression issue here !!

UPDATE reverted back to 4.7.3. With the patch from 18118 to file CRM/Contribute/Form/Contribution/Main.php installed under 4.7.3 the pay later block appears on the main page.

UPDATE2 added the patch to CRM/Contribute/Form/Contribution/Confirm.php as listed in CRM-18118, and emails are being sent. I am going to hold off on reinstalling 4.7.4 until I see any responses on this issue.

  • I have not had this problem. I've updated to 4.7.4 with no issues so far. Pay later and emails to pay later membership payments are certainly working for me. – Josh Mar 22 '16 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.