2

We are trying to disable the automatic wildcard option in Civicrm (Wordpress 4.7.2). However, when we try to disable the option and save we get an error that says “Save Failed: DB Error: Unknown Error”. I tried to disable the automatic wildcard option in the main 4.7.2 Wordpress demo installation of Civicrm and it saved with no error message. We contacted our hosting provider who enabled "Enable Debugging" and "Display Backtrace", and they stated that they could not determine what the issue is without manually debugging the code. They recommend that I ask the Civicrm Stackexchange team for help.

Thanks

  • After enabling debugging and displaying backtrace, you should get a more detailed error. Please edit your question to show the more detailed error and folks can help! – Jon G - Megaphone Tech Dec 10 '16 at 7:12
2

I started experiencing this also, although I was trying to enable the auto wildcard option, which I had previously turned off.

I think it's a bug, but did have success updating it directly in the database as a workaround. In the civicrm_setting table there's a value called includeWildCardinVlaue. s:1:"1" means "yes" it's on, s:1:"0" means "no" it's off.

I'm running Civi 4.7.3 in Wordpress 4.4.2 on civihosting.com.

Looks like it might be happening to Drupal users, too. Why can't I save search preferences? Specifically 'Autocomplete Results'

1

This might be related to this issue "Fatal when creating InnoDB fts indexes": https://issues.civicrm.org/jira/browse/CRM-19610

If your hosting provider doesn't allow the TRIGGER privilege for MySQL, you'll get an error any time you try and save the search preferences. Until this bug is addressed, I think directly updating the database to alter the setting is your only option. If there's an API call that can be made to update that setting, you might be able to use the API Explorer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.