Questions tagged [4.7]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
9
votes
3answers
253 views

Paypal Interruptus - Wordpress w/ CiviCRM 4.7.1

Wordpress 4.4.2 CiviCRM Just upgraded from 4.6.10 to 4.7.1 last week. Ever since we've upgraded, CiviCRM allows payments to be made via PayPal, but event registrations and membership renewals are now ...
7
votes
1answer
143 views

Help: Fatal error doing an export (Civi 4.7.4)

I have just upgraded my Drupal 6 site to the latest CiviCRM 4.7.4 All seemed to go well except that when I try to export contact records (using primary fields). I get the following fatal error: ...
6
votes
3answers
183 views

How to make status always 'Completed' for activities added to a case?

A couple of clients would like to use CiviCase and both of them have very unstructured cases, so a timeline or a sequence is not appropriate. So I have created a case without a timeline or sequence ...
6
votes
1answer
218 views

What differences are there between CiviCRM 4.6 and 4.7?

We're trying to make the decision to upgrade from 4.6 to 4.7 and would like a complete list of changes between the two. Does such a document exist? I can't find anything except blog entries about ...
6
votes
1answer
34 views

Is revealing Internal id a security risk?

We are planning on a mail out with recipients returning completed paper forms, then we'll update Civi with the results. This is where we have no email address for users. On the returned form we are ...
5
votes
5answers
257 views

What version am I running?

The latest version of civicrm no longer prints the version in the footer. Is this correct? How do I find the version I am running?
5
votes
2answers
81 views

How to remove notice at login

When users login right now (Jan 4, 2018) they get a notice publicising CiviCamp 2018. For 99% of users this notice is inappropriate. How do I remove it? I know it can be removed via some update to ...
5
votes
2answers
119 views

How to access the 4.7 Administrator Status Page?

I see a prominant feature of 4.7 is the "Administrator Status Page" and the Issue is https://issues.civicrm.org/jira/browse/CRM-13823 but I do not see a menu item for the status reports. How do you ...
5
votes
2answers
644 views

What is the recommended level of PHP for CiviCRM? There seems to be some inconsistencies

See the wiki which says the minimum level is 5.4+ But see this linked page from the wiki which recommends 5.6 with a bare minimum of 5.3.10. See also the system status for release 4.7 which says ...
5
votes
1answer
52 views

How to Disable Calls to CiviCRM site in 4.7?

I am running CiviCRM on a standalone network (for testing purposes) and am getting regular errors about not being able to connect to the CiviCRM site. How can I disable these calls in 4.7? Thanks!
5
votes
1answer
128 views

Upgrade to 4.7 breaks custom php

After upgrading to 4.7.2 from 4.6.11 I no longer can load any of my custom_php reports or searches. The custom folder location is not inserted into the include path Fatal error: require_once(): ...
5
votes
1answer
206 views

Does anyone have a working example for CiviMail bulk emails on Wordpress and 4.7.x

Do you have a CiviCRM installation with bulk email working on the latest wordpress and CiviCRM 4.7.x, using a cron job set up in cPanel? I have been unable to get cli.php or wp-cli.php to work ...
5
votes
1answer
73 views

Manage Group broken on 4.7.5

after update to 4.7.5, the "manage Groups" page just says "No groups have been created for this site". Although the groups are functioning otherwise. This also happens on the sandbox/demo site.
5
votes
1answer
156 views

How are recurring contributions (standing orders) implemented in 4.7?

I've read that recurring contributions are supported in core 4.7. I can't figure out how this is done, and book.civicrm.org is still at 4.6 (or have I missed something?). By recurring payments I ...
5
votes
3answers
340 views

Cron error after upgrade to 4.7.1

Upgraded from 4.6.11 to 4.7.1 and now this this error when running /wp-content/plugins/civicrm/civicrm/bin/cron.php Fatal error: Uncaught exception 'Exception' with message 'Function "is_admin()" ...
5
votes
1answer
398 views

Unable to install CiviCRM 4.7 on Wordpress 4.4.1

Environment: PHP Version 5.6.15 Apache 2.4.17 MySQL 5.6.27 Windows 10 Wordpress Plugins Active: Exclude Pages from Navigation, Ninja Forms, Ninja Forms - Layout Master When attempting to ...
4
votes
1answer
77 views

Exports in 4.7.6 are not working correctly

If I do any type of search and then try to export my search results, the export CSV only contains one record. Even if the search finds hundreds of records, and I tell the export to export them all, I ...
4
votes
2answers
91 views

How do I use the joins feature of the new API

4.7 lists the ability to use joins for API queries, but I can't find anything in the docs or in the API Explorer. Can someone point me to documentation or examples?
4
votes
1answer
95 views

How can arrange custom fields so they are side by side?

I have a high number of 'outcomes' for a client in the format of 3 fields for each outcome as below: 'outcome words', date identified, date met Problem is that custom fields are formatted as one ...
4
votes
1answer
138 views

How to fix translations in CiviCRM 4.7

We have a localized CiviCRM instance (Dutch), and after upgrading from 4.6 to 4.7, some things are not translated. In particular, after a contact search, the tasks you can do on the results (add ...
4
votes
1answer
54 views

Warning: count(): Parameter must be an array or an object that implements Countable

I am not a PHP/SQL programmer. Our CivicCRM is Version 4.7. PHP is 7.3.27. I upgraded our WordPress site to WP 5.6.1 and now get these errors: Warning: count(): Parameter must be an array or an object ...
4
votes
1answer
179 views

Unable to Upgrade from CiviCRM 4.6.16 to 4.7 (Wordpress)

When attempting to upgrade from CiviCRM 4.6.16 to any of the 4.7 releases, I receive the following error message: Error: Migrate "on behalf of" information to module_data Debug info says: "Unknown ...
4
votes
2answers
284 views

How can I select all countries to be available for address fields in CiviCRM 4.7?

I am asking this question to clarify the issue raised in this question: Available countries list won't appear when set in Localization The user interface on the 'Settings - Localization' page (...
4
votes
1answer
259 views

iAmAnIntentionalENoticeThatWarnsOfAProblemYouShouldReport and other event registration warnings in 4.7.1

On the Find Participants page for an event: Warning: array_keys() expects parameter 1 to be array, null given in CRM_Utils_Array::formatArrayKeys() In the Drupal log, lots of these: Notice: ...
4
votes
1answer
202 views

Credit Card Receipt after 4.7 update

Prior to updating to CiviCRM 4.7 our customers received receipts that included: Membership fees with each item listed separately with a description and price. The Transaction number The Billing ...
4
votes
1answer
153 views

Custom Field Groups with File fields cannot be edited as a Tab

I have a site with several custom field sets that use the "Tab" style for displaying information about a contact. Included in one field set is a "File" field that is used to store a profile image for ...
3
votes
3answers
172 views

How can I speed up a slow upgrade to 4.7?

Upgrades to 4.7 for big CiviCRM databases can take many many hours. What is the best way to speed them up?
3
votes
2answers
1k views

Additional Fonts CKEditor

I want to configure the font drop-down menu of the CKEditor and add additional fonts there. The Fonts are locally available, and shall be usable for PDFLetters etc. Has anyone made any Progress with ...
3
votes
1answer
79 views

What to do about "File 'Array' presents a security risk and should be deleted." on 4.7?

After some brief difficulty upgrading from Civi 4.6.x to 4.7.0, we managed to get it done, with one small hiccup. Post-installation, we got a notification saying: File 'Array' presents a security ...
3
votes
1answer
377 views

How can I fix this problem with duplicate index in 4.7.21?

Upgraded from 4.7.17 to 4.7.21 and got the following message that I don't know how to fix. I don't have drush and the other answers to this problem don't include this index or don't fix this ...
3
votes
3answers
188 views

Upgrade from 4.7.14 to 4.7.15 failed on Database Upgrade

I tried to upgrade from 4.7.14 to 4.7.15 today. I followed the instructions 1 - 3 in the documentation. Everything looked good up to that point. I got a message that installation was successful. ...
3
votes
1answer
248 views

What to do about "Operation failed: Update Indices DB Error: unknown error Debug" after upgrading to 4.7.25

This is related to a question I posted yesterday (How does one delete "key indices"?), which was considered a duplicate of another question (Performance Warning: Missing Indices. Mismatched ...
3
votes
2answers
2k views

Font-Awesome icons not showing -- missing class=fa?

The Font-Awesome icons are not showing properly. I believe this is because the required class "fa" is missing everywhere where one of the icons is supposed to display. I have tested this by ...
3
votes
1answer
120 views

Using Profiles for Data Entry

I am using profiles for data entry in my CiviCRM instance. They seem to be working (the contacts that should be created are saving), but I get the following (big ugly) notices at the top of the page ...
3
votes
1answer
379 views

How to empty the trash? (permanently delete)

I know you can permanently delete a deleted contact from the contact's screen, but how can you en-masse delete all the deleted contacts or "Empty Trash"? Ideally delete all things trashed over 30 ...
3
votes
1answer
211 views

After upgrade to 4.7.13, I get 500 Internal Server Error when creating new mailing

After upgrading from 4.7.11 to 4.7.13 (with Drupal 7.51), I get à 500 error (Internal Server Error) on an ajax call when attempting to create a new mailing. The screen stucks at "Initializing..." The ...
3
votes
2answers
113 views

MyISAM, Cron, ERROR

I get this error on installing the CiviCRM plugin for Wordpress (Wordpress version 4.4.2, CiviCRM 4.7.4) System Status: Error MyISAM Database Engine Cron Not Running Configure Default Mailbox ...
3
votes
2answers
62 views

Form no longer entering into CiviMember for free memberships

CMS: WordPress 4.4.2 CiviCRM: 4.7.1 After upgrading from 4.6.6 to 4.7.1, when someone submits our contribution form for a free membership, the membership is not recorded in the contact record nor in ...
3
votes
2answers
235 views

Mailings Scheduler fails after upgrade to 4.7.1

After upgrading to 4.7.1 (Joomla) I get the following error in the Mailing Scheduler log when activated by cron: Finished execution of Mailings scheduler with result: Failure, Error message: API ...
3
votes
1answer
47 views

CiviReport 'insufficient permission' error running financial report after update to 4.7.29

Only since upgrading CiviCRM to 4.7.29 from 4.7.11 (on Drupal), one of my users with 'editor' role is unable to run a financial report. The error she sees is: "API permission check failed for ...
3
votes
2answers
112 views

Switched "logging" on - now get 'Unable to reach server'?

I just switched logging on for a 4.7.27 install which was working just fine. Now, when clicking on 'Change Log' tab I get the 'Network Error' popup with the message about being unable to reach the ...
3
votes
2answers
118 views

How can we hide the CiviCRM System Status page?

How do I hide CiviCRM System Status page (in CiviCRM) and Status Error pop-up messages from non-admin users? I am Using Drupal 7 with CiviCRM 4.7.
3
votes
1answer
111 views

How to set up recurring contributions on Webform using Stripe

I'm a little confused from other questions here as to whether setting up recurring contributions on a webform using Stripe works. They work just fine using a regular contribution page. But using a ...
3
votes
2answers
261 views

How to get IATS working

Seems that IATS will not work using extension 1.5.3 - It logs the transaction in CiviCRM but never makes a connection with IATS. I'm not sure it is even connecting with the network. Any clue folks?
3
votes
1answer
169 views

Unable to upgrade in WordPress from 4.6.12 to 4.7

I have a Civicrm installation that's been running for quite some time. I've never had an issue upgrading until now. I've been able to upgrade to 4.6.12, but then I try 4.7.0 or 4.7.1, all I get is "[]"...
3
votes
1answer
503 views

4.6.12 to 4.7.1 upgrade causes problems with directories, update paths and clear cache

This issue has been asked in two other threads specifically: 4.6.10 to 4.7.1 upgrade woes 4.6.10 to 4.7.1 upgrade woes Upgrade to 4.7.1 results in blank page Upgrade to 4.7.1 results in blank page ...
3
votes
0answers
86 views

Fix for column names breaking the 64-character limit

I'm trying to generate a report using custom fields and I am getting nativecode=1166 ** Incorrect column name This happens when the report is trying to generate temp tables using an alias as the ...
3
votes
1answer
161 views

Directory path problem on 4.7.30 upgrade

On upgrade to 4.7.30 (Joomla) the status message tells me of path problems. For example, that the directories are not writeable or do not exist. When I try to check/set the directories I get ...
3
votes
0answers
85 views

Merging contacts and cases

I think I have found an issue with merging contacts (and it also seems to manifest when assigning a different client to a case - which apparently performs a similar merging function). On the demo ...
3
votes
1answer
53 views

Why does the Constituent Summary & Detail reports contain deleted contacts? (or, how to remove them?)

The constituent summary & constituent detail reports both contain deleted contacts - this is 4.7.21 (and 4.7.23) under Drupal. I verified the problem on this demo site. This doesn't seem right ...