Questions tagged [composer]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
58 views

Problems with composer civicrm:publish

I recently had an error becuase my kcfinder package was out of date. I fixed it by manually copying the kcfinder folder from dir/vendor/civicrm/civicrm-packages to dir/html/libraries/civicrm/packages. ...
Ben's user avatar
  • 946
0 votes
1 answer
50 views

civicrm:publish on pantheon

Is there a way to run civicrm:publish manually and not via CLI? I updated to 5.69.2 but have the error in status: Wrong version of assets in public web directory: expected 5.69.2 but found 5.69.1. ...
Bud Stewart's user avatar
1 vote
0 answers
27 views

civicrm:publish

I have just updated an environment running under IIS/Windows to CiviCRM 5.69.1. It's system status is Error with Running composer civicrm:publish gives I have a similar problem on a development ...
Stephen Palmstrom's user avatar
2 votes
1 answer
129 views

Install CiviCRM on Drupal 10 without Composer

I would like to install CiviCRM on Drupal 10. But I use a mutual hosting without Composer. How to do ? It's possible to install without Composer ? Thanks for your help.
Adrien's user avatar
  • 21
2 votes
0 answers
143 views

composer require civicrm/cv will not install

I installed a new project using composer. First Drupal 10.1.6, next civicrm (following the install guide https://docs.civicrm.org/installation/en/latest/drupal/), but when I try to run composer ...
Stefaan H's user avatar
0 votes
2 answers
147 views

guzzle and symfony errors - WordPress

I've been getting a persistent guzzle error since Civi version 5.5x, and I now realise there's also some weird permission error and am wondering if this is related. I'm on the latest versions of ...
Hugh's user avatar
  • 272
1 vote
0 answers
15 views

API 4 problem while running composer

everybody. Since the installation of CiviCRM I have problems in composer. Another installation, on the same VPS, is not causing any problems. The website is a Drupal based one (9.5.10) I started it ...
Alessandro Bronzo's user avatar
3 votes
0 answers
73 views

When using composer update I get a message about a vulnerability with version 5 of firebase/php-jwt installed with CiviCRM- how can I fix this?

I have CiviCRM 5.63.1 installed with the latest Drupal 9 (9.5.10) - when running composer update I get a message about a vulnerability with firebase/php-jwt with versions less than 6. Looking in the ...
marksuk2004's user avatar
0 votes
1 answer
638 views

Applying patches that time out on composer update?

I've just updated to MacOS ventura 13.0.1. How do I get composer update to work? Applying patches for pear/mail_mime https://raw.githubusercontent.com/civicrm/civicrm-core/...
Interlated's user avatar
0 votes
1 answer
39 views

Installing CiviCRM on a Drupal 9 site with Drush 11 conflict due to symfony/filesystem ~4.4 requirement

Currently if you install Drupal 9, Drush then CiviCRM you end up with a Composer "Problem" due to Drush requiring consolidation/site-alias (^3.1.6 || ^4) and composer picking the v4 version ...
Luke Stewart's user avatar
  • 1,855
1 vote
1 answer
160 views

Composer Drupal Update fails because unappliable Patch of Civicrms zetacomponents/mail

I try to update a Drupalmachine on 9.4.5 site via composer 2.4.1. ~/bin/composer.phar update drupal/core "drupal/core-*" --with-all-dependencies (see below for composer.json) first try i can ...
gzwg's user avatar
  • 37
1 vote
1 answer
241 views

Update CiviCRM with composer fails during patching: "Cannot apply patch Allow single quotes to be used in return path"

Currently on CiviCRM 5.51.1 with Drupal 9.4.3 and PHP 8.0. I wanted to update CiviCRM but no matter if I try to update to 5.51.3 or 5.52 - I get the composer error: Applying patches for ...
Tobias Krause's user avatar
1 vote
1 answer
49 views

is it possible to use composer with a Joomla-installed CiviCRM instance?

I have an extension version conflict problem on my Joomla site, for which the recommended solution is to change the civicrm dependencies via composer (Guzzle conflict between CiviCRM and Community ...
minbori's user avatar
  • 551
1 vote
0 answers
28 views

Inconsistent errors with composer update

I'm working on updating a Drupal 9 + CiviCRM installation which is managed with composer. I'm staging the updates on a local VM copy of the site for testing prior to updating on the live instance, and ...
AlexT's user avatar
  • 81
2 votes
1 answer
171 views

Drupal 9 - CiviCRM Compilation Error

I've installed Drupal 9.2.5 using Composer (version 2.1.8). I am trying to install CiviCRM 5.41.0. I followed the steps in the CiviCRM instructions for installation on Drupal 8/9 using Composer. The ...
PaulC's user avatar
  • 51
1 vote
1 answer
136 views

compilation error

I cannot get composer to install civicrm I get this error Continue as root/super user [yes]? pre-compile-list: Civi\CompilePlugin\Subscriber\OldTaskAdapter->mapRunner pre-compile-list: Civi\...
Lawrence's user avatar
3 votes
0 answers
31 views

Update CiviCRM's copy of CKEditor using composer?

According to https://civicrm.org/advisory/civi-sa-2021-09-ckeditor-multiple-advisories a recommended mitigation is to replace /civicrm/bower_components/ckeditor/ with version 4.16.2 (it's currently 4....
Alan Dixon's user avatar
  • 6,841
1 vote
1 answer
166 views

Drupal 8/9 Compilation Install Error

I'm getting thiis error, when I try to install civicrm on Drupal 8 and 9 The following packages have new compilation tasks: civicrm/composer-compile-lib has 1 task civicrm/civicrm-core has 1 task ...
Craig Creque's user avatar
1 vote
1 answer
174 views

Composer 2 and CiviCRM Installation Error

I am trying to install CiviCRM on a Drupal 8 site using Composer 2. I am getting the error below. Is this a Composer 2 issue? Do I need to revert to Composer 1? Is there a different fix? Thx. ====...
Marv S's user avatar
  • 88
0 votes
1 answer
280 views

Compilation error when installing on Drupal8

Following install guide I get fatal error at compilation tasks in composer require civicrm/civicrm-core:'~5.35'. The setup is on Aegir with Drupal 8.9 and drupal/recommended-project composer template, ...
Doka's user avatar
  • 397
1 vote
1 answer
72 views

Keep getting this error on Composer require

I'm using the current instructions to get the current version of CiviCRM for Drupal 8 [play@ceres web]$ composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.35' It keeps giving me this error ...
Tony Horrocks's user avatar
0 votes
1 answer
112 views

What has happened to totten/lurkerlite?

Problem 1 Installing CiviCRM using Composer has started giving these errors: - Root composer.json requires civicrm/composer-compile-plugin ^0.14.0 -> satisfiable by civicrm/composer-compile-...
Stephen Palmstrom's user avatar
3 votes
2 answers
226 views

Install or upgrade CiviCRM using Composer 2?

Has anyone documented using Composer 2 with an install and/or upgrade of Drupal 8 + CiviCRM? I'm getting this error: - civicrm/composer-downloads-plugin[v2.0.0, ..., v2.1.1] require composer-...
Alan Dixon's user avatar
  • 6,841
0 votes
0 answers
161 views

Can't upgrade drush with composer

For upgrading CiviCRM, I've been told that it is safer to upgrade with drush than manually, but my version of drush, according to another post, has to be upgraded from 8.0.0 to 8.4.5. (See Command &...
Pierre François's user avatar
2 votes
1 answer
248 views

Upgrading CiviCRM under Drupal 8: How can I get around this error?

I'm guessing that the upgrade process for CiviCRM under Drupal 8 is something like this: Use composer require to get the latest version of the package. Navigate to the database update URL through the ...
TwoMice's user avatar
  • 1,814
5 votes
1 answer
308 views

Drupal 8: How do I shift a project/site from using the roundearth installation method to the CiviCRM official composer asset plugin

From an existing site set up using the roundearth composer plugin method as detailed -> https://www.mydropwizard.com/blog/better-way-install-civicrm-drupal-8 composer create-project roundearth/...
Luke Stewart's user avatar
  • 1,855
1 vote
2 answers
209 views

roundearth/drupal-civicrm-project fails to give me the CiviCRM menu

I now have an automated process working to deploy CiviCRM on drupal based on roundearth/drupal-civicrm-project. Only issue is, drush en civicrm fails to expose the CiviCRM menu. What step might I be ...
Hugh Esco's user avatar
5 votes
3 answers
754 views

How can I update CiviCRM installed with Drupal 8 using Composer?

I've got CiviCRM installed and working with Drupal 8 using Composer via https://gitlab.com/roundearth/drupal-civicrm-project What I'm not clear on is how best to update CiviCRM using Composer. Is it ...
Graham's user avatar
  • 4,025
0 votes
1 answer
32 views

Trying to kill civicrm/civicrm-cxm-rpc to fix a conflict, and it won't die

Ubuntu 18.0.4 LTS, Drupal 8.7. New to composer and Drupal 8, trying to resolve a conflict between required libraries for CiviCRM and Open Social. Open Social requires phpseclib/phpseclib 0.3 or 2^, ...
Jeff Porten's user avatar
1 vote
0 answers
72 views

composer package - CiviCRM + WordPress Blueprint

I am experimenting with roots/bedrock, roots/soil, roots/sage "platform" as the "sage" theme sounds compelling and the dependency management inhernet in composer is also compelling. To that end, I ...
drummondislebsd's user avatar
3 votes
1 answer
173 views

How can I install/manage CiviCRM patches on Drupal 8 (using Composer)?

I sometimes need to fix a bug in CiviCRM before that bug is fixed in the latest version of CiviCRM. With non-composer installations, I patch my dev site, commit my changes to git, and push them to a ...
Jon G - Megaphone Tech's user avatar
4 votes
1 answer
199 views

Drupal 8.4 & CiviCRM Issue

Last evening I tried to follow along with the amazing work @david-snopek posted but I've been running into some issues with the module finding the civicrm "library". I'm trying to get this working ...
Justin Levi Winter's user avatar
4 votes
0 answers
329 views

How to use Composer to install and upgrade CiviCRM 4.6.x / Drupal 7

I am building a composer.json file for my project which involves core Drupal, contributed Drupal modules, Drupal related libraries, core CiviCRM. All initialisation of the empty prototype and ...
ñull's user avatar
  • 1,208