Questions tagged [extension]

CiviCRM Extensions are packaged pieces of functionality that extend CiviCRM's out-of-the-box functionality, independent of the CMS platform.

Filter by
Sorted by
Tagged with
0 votes
1 answer
25 views

How to remove APIv4 extension

Sorry if this has been asked before, but I couldn't find it if so. How can I remove the obsolete APIv4 extension cleanly? There's no disable or uninstall uption on the Extensions page. Thanks.
user avatar
  • 1,222
0 votes
1 answer
23 views

Getting fatal error when doing things with extension

Whenever Im doing anything with extensions Im getting this error CiviCRM_API3_Exception: "API error: on OptionValue.getsingle" #0 /home/lgsecrmo/hub.littlegate.org.uk/sites/all/modules/...
user avatar
3 votes
0 answers
19 views

Move or Hide unused extensions from Extensions tab to Add New tab

Under System Settings > Extensions there is the first tab that shows up "Extensions" and there is another tab called "Add New". Is it possible to remove unused extensions from ...
user avatar
  • 343
1 vote
0 answers
10 views

When saving Group with Mailchimp settings - nothing happens

I have weird issue with Civi Mailchimp extension. By looking at instructions after setting up API key, I need to update Civi Group which to be synced to Mailchimp. However, when saving group after ...
user avatar
  • 13
1 vote
1 answer
47 views

What does the CiviCRM Administration UI or civicrm_admin_ui actually do?

As the title says - what does this do? I know it says it replaces legacy pages with configurable search display forms - but what is considered legacy, what are these pages? Also - personal annoyance - ...
user avatar
  • 3,222
0 votes
0 answers
20 views

Getting Omnipay API error after Civicrm 5.47.3 upgrade (Wordpress)

I upgraded from Civicrm 5.46.x to 5.47.3 for Wordpress. When I ran Update, I got an error API error: DB Error: already exists on payment_processor_type.create( entity name ...
user avatar
0 votes
0 answers
30 views

Can't download and install extension

On a fresh 5.47.3 on WP 5.9.2 on CentOS / Plesk I can't download and install extensions from the extension manager Error message: Extension Download failed - ZIP file is unavailable or malformed Of ...
user avatar
0 votes
2 answers
39 views

Upgrade to 5.47.2 failed on several systems - workaround?

In attempting to upgrade several 5.45.3 system to 5.47.2 I ran into this problem with 3 of them - "[info] $CRM_Queue_Page_AJAX_runNext_error = Exception: "API error: DB Error: constraint ...
user avatar
  • 4,263
2 votes
0 answers
18 views

Project to implement API for Signal messaging?

Has anyone thought about creating an extension to send messages through Signal messenger APP?: https://github.com/signalapp/Signal-Server/wiki/API-Protocol#sending-messages Opposite to WhatsApp, ...
user avatar
7 votes
2 answers
212 views

Upgrade to 5.47.x fails with error: Exception: "API error: DB Error: constraint violation on ReportTemplate.create"

On running an upgrade to 5.47.1 I get the following [Error: Finish core DB updates 5.47.1] Exception: "API error: DB Error: constraint violation on ReportTemplate.create" Partial stacktrace #...
user avatar
  • 1,685
1 vote
1 answer
21 views

CiviCase extension not displaying non-case activities in contact summary screen

Ive installed the CiviCase extension - ie the one provided by colemanw, version 5. Works fine, except on the normal activities tab. Clicking on that loads placeholders for the default listing, which ...
user avatar
0 votes
1 answer
65 views

Can't upgrade Mosaico Extension from 2.8XXXX to 2.9 without Afform but no Afform Ext. Available in Joomla

Unable to upgrade Mosaico Extension. I keep getting an error that I need to upgrade Afform from Civicrm.org. (See picture.) I can't find Afform within the extension browser within civicrm, and either ...
user avatar
  • 103
0 votes
0 answers
26 views

AngularJS extension - angularFileUpload is an "Unrecognized Angular module"

I am trying to use the angularFileUpload module within my AngularJS extension, but I am receiving an error message that reads Unrecognized Angular module . Please ensure that all Angular modules are ...
user avatar
2 votes
1 answer
36 views

symbols next to extension versions

I've just done a test updgrade from CiviCRM 5.35.1 to 5.46.2 and notice some new symbols next to the version number for extension on the extension management page. I'm sure the green tick is a good ...
user avatar
  • 3,137
3 votes
2 answers
44 views

Can't create quickform via CRM_Core_Form in my custom extension

I want to create page with form via my custom extension. I find this page in documentation: https://docs.civicrm.org/dev/en/latest/framework/quickform/ But when I create a class according to the ...
user avatar
  • 53
0 votes
2 answers
23 views

Any Paid courses on CiviCRM extension development?

Any organizations out there offering a full hands on course on developing extensions for CiviCRM? I'm willing to pay for such a course.
user avatar
  • 695
4 votes
1 answer
110 views

ERROR Class 'CRM_Search_Upgrader' not found since upgrading CiviCRM to 5.45.1 on Wordpress 5.8.3

I upgraded from CiviCrm 5.38 to 5.45.0 on my staging server which is on Wordpress(5.8.3). I get a Error Thrown ...Class 'CRM_Search_Upgrader' not found when I access: CiviCRM from the Wordpress Admin ...
user avatar
  • 41
0 votes
0 answers
10 views

Have any organisations or developers explored or currently working on a Hopin extension?

Our organisation is currently using Hopin to host events. I've searched whether there is an extension but haven't come across anything yet. I would welcome to hear from anyone that has used this with ...
user avatar
  • 1
1 vote
1 answer
54 views

Upgrade fails: Unknown column 'entity_modified_date'

CiviCRM is currently running on version 5.42.1. I wanted to upgrade to 5.45.0 but here the upgrade script fails with following message: [callback] => Array ( [0] => CRM_Core_Error ...
user avatar
1 vote
1 answer
31 views

How Can I make the source field as dropdown

I remember there used to be an extension that would make the source field as a dropdown instead of an editable field, cant seem to remember how it's called! Anyone? EDIT: I think It’s the contribution ...
user avatar
  • 2,846
2 votes
2 answers
42 views

Move data from field to another field as a batch

I recently have taken over managing CiviCRM for an orchestra in Holland. Some fields have been used inconsistently, for example Nickname and First Name. I now need to copy all data in Nickname to ...
user avatar
0 votes
0 answers
14 views

Compucorp Membership Extras: renew memberships scheduled job not present

I have installed the extension on our site. We are running CiviCRM 5.42.1 and I have version 4.6.0 installed. I have a few questions: I do not find the renew memberships scheduled job. The only thing ...
user avatar
  • 695
0 votes
2 answers
24 views

How to programmatically check if an extension is installed

I want to progressively enhance one of my extensions by altering the code paths to use another extension, if it's installed, and fall back to my own extension's code if not. How can I check if an ...
user avatar
  • 3,688
1 vote
2 answers
55 views

It is possible to receive an alert when we have an action planified?

I would like to receive a notification when I plan a future action in Civicase ? For exemple, if I plan to call a prospect next monday, is it possible to have at 9 am an alert on the following monday ...
user avatar
0 votes
2 answers
71 views

Extension Download error public extensions directory

Hi this message has started appearing on our CIVI CRM system over the last couple of days - it is intermittent and not there all of the time. Any advice on this would be much appreciated. Thank you ...
user avatar
  • 21
1 vote
0 answers
26 views

Nested entity and API endpoints for a custom extension

I am working on an extension and I want a particular API endpoint structure. I'm trying to have this structure: Based on the documentation here, having entities created as direct children to the v3 ...
user avatar
1 vote
1 answer
87 views

How to write update script

What I am trying to achieve - is to write a custom module(CiviCRM extension)/script, which should update( Run small SQL query to update about a missing "Module" ) Basically - what the script ...
user avatar
0 votes
1 answer
16 views

Date field not rendering correctly through extra.tpl file

We have one custom extension which try to add additional field on scheduled job New/Edit screen using hook. function jobextra_civicrm_buildForm($formName, &$form) { if ($formName == '...
user avatar
1 vote
1 answer
57 views

Events Calendar Extension on Wordpress: jQuery is not defined

Wordpress 5.8 CiviCRM 5.40.3 CiviCRM Events Calendar - Extension 4.1 Working with the Event Calendar extension from osseed. Followed the instructions for Wordpress here: https://github.com/osseed/com....
user avatar
1 vote
1 answer
39 views

Is a callback URL needed for the GoToWebinar integration?

I am trying to upgrade the GoToWebinar extension which now uses OAuth2 authentication. With OAuth2 there is usually a callback URL used to provide the necessary auth token back to the caller. GoTo has ...
user avatar
  • 2,455
0 votes
1 answer
34 views

Uninstalling civivolunteer - trigger remains

I uninstalled civivolunteer. We've opted to instead use an activity type with a couple custom fields tracking role and time spent. Anyway, when uninstalling it did not delete the 2 volunteer and ...
user avatar
  • 2,904
1 vote
1 answer
14 views

Looking at Building CiviCRM extensions - Symfony info

It looks like Symfony is fairly capable of being integrated into Civi Extensions, but the documentation seems sparse. I am going through the Symfony docs/training but would like to see some good docs ...
user avatar
1 vote
1 answer
126 views

What is the actual status of CiviHR

Is CiviHR still active? This extension looks really interesting but the last release is almost 3 years-old.
user avatar
0 votes
1 answer
47 views

Group of unsolvable API and core errors

I really would appreciate any advice to dig deeper into the debugging of some errors. The reason may lay in our installation which is grown since late 2015 (I think it was version 4.2) and widely ...
user avatar
  • 1,272
0 votes
1 answer
15 views

DB set entity install priority

How can I set the entity install order? now the new table refers to a nonexistent one because the new table has not yet been created
user avatar
  • 39
1 vote
1 answer
22 views

Using CRM_Utils_Mail and logs

I have a custom extension which I have working great- sends out email using the CRM_Utils_mail function. The emails go out fine, look fine, but are not registered to the contact's profile (not under ...
user avatar
2 votes
0 answers
13 views

Download latest version of an extension without installing?

Also raised in https://lab.civicrm.org/dev/core/-/issues/2635 Download latest version of an extension without installing Overview It would be good to be able to download the latest version of an ...
user avatar
0 votes
1 answer
26 views

Forms Question -- href issue

I have an extension that adds a tab to Events. The form is called up, and works using the automatic layout for the top piece. {foreach from=$elementNames item=elementName} <div class="...
user avatar
1 vote
2 answers
118 views

Angularjs called from an extension?

Good morning from Canada. I am trying to create an extension with angularjs forms. I have followed the development guide and have created the angularjs page but I cannot get it to display in CiviCRM....
user avatar
0 votes
0 answers
23 views

Hello! Is it possible to make content in CiviCRM and publish it directly to Facebook?

Is it possible to make content in CiviCRM and publish it directly to Facebook? For example, uploading the video and posting a link that's leading to an article, or official website?
user avatar
1 vote
1 answer
55 views

"The CiviCRM public extensions directory at could not be contacted" -- why is my repo URL empty in the browser but not in `cv`?

Question: What could be causing the ext_repo_url setting value to be empty when running in the browser, though it appears to be correct when running in cv? Under civicrm 5.35.2, if I visit the ...
user avatar
  • 1,640
0 votes
1 answer
14 views

Installing IParl extension

I have installed the extension to work with IParl. I am at the stage in the intructions where I want to test whether the API is working. The instructions https://github.com/artfulrobot/uk.artfulrobot....
user avatar
0 votes
1 answer
32 views

Missing extension "moregreetings" after upgrade to CiviCRM 5.36

I am running CiviCRM with the extension Moregreetings. After upgrading CiviCRM to version 5.36 without other problems, I got two notifications: Unknown extension: de.systopia.moregreetings Warning: ...
user avatar
2 votes
1 answer
68 views

Member Self Service

I would like members to be able to log into our website and be able to see the relationships that are on their organization record so that they can let us know who is still there and who needs to be ...
user avatar
  • 21
2 votes
1 answer
38 views

Does the system status check and upgrade version check only list available updates for in-app extensions?

It seems like extensions which are listed in the extension directory but not available for in-app distribution are not included in update checks. They also don't appear in the sites/default/files/...
user avatar
  • 17.9k
0 votes
0 answers
43 views

Documenten document extension - backfilling documents

I was testing out the functionality of the Documenten extension as it looks promising. (We use CiviCase heavily and are starting to scan some paper files and add them to cases.) The blog post here: ...
user avatar
  • 2,416
1 vote
2 answers
173 views

CiviCRM core now includes Flexmailer: how to remove old flexmailer extension?

I have Flexmailer 1.1.1 installed as a "non-core" extension , but since upgrading to 5.35.1 Flexmailer 1.1.2 is included with core. (This probably came in before 5.35.) The extensions page ...
user avatar
  • 3,688
0 votes
1 answer
14 views

How to solve [error_message] => Entity declaration references invalid or inactive module name

I get this [error_message] => Entity declaration references invalid or inactive module name [name_of_extension] When trying to run: cv ext:upgrade-db It's an extension I don't recognize - but yeah ...
user avatar
3 votes
1 answer
118 views

Upgraded to CiviCRM 5.34.0 and extensions broke

I have upgraded to CiviCRM 5.34 and things seem to have gone astray. When loading the extensions page (Administer -> Systems Settings -> Extensions) the following error message is displayed: ...
user avatar
  • 33
1 vote
1 answer
88 views

Activity Duration in Hours extension NOT working for CiviCase

Currently using CiviCRM Version 5.31 (Wordpress Version 5.5.3) Installed the extension to change Activities Duration from Minutes to Hours https://lab.civicrm.org/extensions/activityhours The ...
user avatar
  • 11

1
2 3 4 5
10