Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [installation]

Tag a question "installation" if you are having trouble completing the initial installation of CiviCRM on Drupal, Joomla, or WordPress. If you encounter problems while using the system, use tags that are more specific to the features affected.

Filter by
Sorted by
Tagged with
0 votes
1 answer
17 views

DB constraint violation: newly installed but cannot get to Civi home screen

Brand new Civi installation on a brand new Drupal 10 site. Followed the instructions on the Civi documentation. Everything checks out in the Drupal Status; everything seems to have installed ...
Tiffani Chin's user avatar
0 votes
2 answers
21 views

Installing Civivolunteer 2.4.5 for Civicrm version 5.73.2 gives errors and fails

Code Hi, I know this issue has come up before but the situations and suggested solutions of previous posts don’t solve this issue. I can't install CiviVolunteer (2.4.5) for CiviCRM (5.73.2) and have ...
Axelvds's user avatar
  • 21
1 vote
2 answers
28 views

System Error and no dashboard on install

Finally got a new install of Civi on what is a just installed Drupal 10 site. When I got to Civicrm, I get a system error with this informations: System Status: Error Public Assets Not Published ...
Tiffani Chin's user avatar
3 votes
2 answers
204 views

Civicrm install on Drupal 10 -- packages downloaded but cv command not found for installation

Trying to install civi on a brand new Drupal 10 site (have used Civi for years and have installed before, but back in the Drupal 5, 6, 7 days without any of these new tools). I'm pretty well ...
Tiffani Chin's user avatar
0 votes
0 answers
23 views

Help on installation required: "The website encountered an unexpected error. Try again later."

I keep running into the same error. Please help! I installed Drupal 10 (latest) I can access Durpal via https://192.168.100.135/ and I can log in. Next followed these steps: https://docs.civicrm.org/...
Guido's user avatar
  • 11
0 votes
0 answers
26 views

Trouble Migrating CiviCRM From WordPress to Drupal

I am volunteering on a project to help a small nonprofit move their CiviCRM database from WordPress to Drupal. I think I am close but I am running into an issue after CiviCRM is installed. I have ...
Steve's user avatar
  • 137
0 votes
1 answer
39 views

I am having Installation issues can someone help?

I am having issues getting my installation to populate on my URL any help is appreciated I am using joomla
Nic W. B.C.T.P.S.'s user avatar
1 vote
2 answers
28 views

Updating from CiviCRM 5.38.0. to 5.71 on wordpress

Any help with how to update CiviCRM 5.38.0. to 5.71 on wordpress? Currently my website says--> System Status: Critical (which is obviously quite worrying!) I've downloaded the zip file from ...
PeaceSam's user avatar
1 vote
1 answer
52 views

Problem installling CiviCRM on Drupal 10

I am attempting to install CiviCRM on a Drupal 10 website. The composer instructions seem to have downloaded the software just fine, and it all looks reasonable, but when I put in cv core:install --...
Steve Hanson's user avatar
0 votes
0 answers
31 views

Unable to install CiviCRM

I am attempting to install a fresh copy of CiviCRM 5.70.1 on WordPress 6.4.3 I have been working with CiviCRM for years and I have never encountered this issue before. After uploading and extracting ...
fdarn's user avatar
  • 127
0 votes
0 answers
32 views

Civi plugin fails to install on fresh version of wordpress

Server is Ubuntu 23.04 Php 8.1 using FPM On a fresh install of Wordpress, and a fresh download of civi, as soon as I activate the plugin in Wordpress plugins, it errors out. Here are the details. Any ...
Andy's user avatar
  • 1
1 vote
0 answers
27 views

How to fix CiviCRM Hosting Expired Notification

I am continuing to get a system status warning that my hosting has expired and I am not sure how to fix this. I have so far tried to pay twice and I have been billed twice by clicking on the link that ...
Lach's user avatar
  • 11
1 vote
0 answers
58 views

CiviCRM 5.70.1 install on Drupal 10.2.3 - failure

I am trying to install the latest CiviCRM on a fresh Drupal 10.2.3 install. This is on Ubuntu 22.04.3 LTS. When I run the cv command (see below) to install CiviCRM, it is not installed and I receive ...
Coventure Joe's user avatar
1 vote
1 answer
72 views

Failed upgrade from 5.69.2 to 5.69.5

My System Status page says "The site is running 5.69.2" but the Civi footer on the same page and WP's plugins page say version 5.69.5 - clearly an upgrade has gone wrong! Now, several pages ...
Torben Gundtofte-Bruun's user avatar
0 votes
1 answer
14 views

joomla package not installing

I am trying to install the CiviCRM package for Joomla. I have 4.4 and I am installing the latest version of CiviCRM for Joomla. pHp 8.1. Hosting on GoDaddy. I receive the below error both when ...
Mary's user avatar
  • 145
1 vote
2 answers
60 views

Can't install CiviCRM extension with fresh install of Joomla

When I attempt to install CiviCRM (5.69.2) in my Jooma (5.0.2) instance I receive the following error: Compile Error: Declaration of Psr\Log\NullLogger::log($level, $message, array $context = []) must ...
thejason's user avatar
0 votes
1 answer
61 views

Installation (5.69.1) fails: Server 500 Error (Joomla 5.02)

I just wanted to update from an older version (I gues it was 5.63 or so) to the current 5.69.1, but the installation runs into a red screen with a Server 500 error. This is what I see after turning on ...
Stefan Schoch's user avatar
1 vote
2 answers
114 views

CiviCRM installation fails on Drupal 10

I am installing CiviCRM on a new server, new Drupal 10. Per instructions, I ran the following commands: cd /var/www/drupal composer require civicrm/civicrm-{core,packages,drupal-8} composer require ...
Felix's user avatar
  • 283
1 vote
1 answer
70 views

Cost for Setup and implementation

Hi can anyone give me a rough figure please? If I were to pay a developer to set up Civi CRM into Wordpress and just get it up and running, we host it ourselves and maintain it ourselves, but they do ...
GCserve's user avatar
  • 21
0 votes
1 answer
33 views

I am trying to install CiviCRM to a Wordpress multisite, and getting an error Uncaught TypeError: method_exists()

I have been following the instructions for installing to Multisite here: https://docs.civicrm.org/installation/en/latest/multisite/wordpress/ I created a separate civicrm database. I set the CiviCRM ...
Norman Cates's user avatar
1 vote
1 answer
410 views

WordPress error: Creation of dynamic property ... is deprecated

I have a brand new installation of WP+CiviCRM on a virtual private server. Every page loads with these errors at the top of the page: Deprecated: Creation of dynamic property ...
Torben Gundtofte-Bruun's user avatar
0 votes
0 answers
7 views

Package Implementation methdology

Basically, interested to learn on the suggested phased approach to have typic CiviCRM functionality adopted by an organization. Is there any recommendation available on deployment plans in terms of ...
Carlos Martinez's user avatar
2 votes
1 answer
147 views

Install CiviCRM on Drupal 10 without Composer

I would like to install CiviCRM on Drupal 10. But I use a mutual hosting without Composer. How to do ? It's possible to install without Composer ? Thanks for your help.
Adrien's user avatar
  • 21
1 vote
1 answer
120 views

Unclear on install instructions - D10?

I've been using CiviCRM on Drupal 7 for many years, and it's time to upgrade my Drupal. Drupal 8 went EOL November 2, 2021. Drupal 9 goes EOL November 1, 2023, which is in 12 days. So it looks like ...
Ken Williams's user avatar
2 votes
1 answer
134 views

How to obtain the ESR For Wordpress

I signed up for the CiviCRM ESR Program and paid the $20.00, and was given access to the Extended Security Release Group on lab.civicrm.org. I am showing the latest ESR version is 5.63-ESR. How do I ...
James D. Creen's user avatar
0 votes
0 answers
101 views

Critical Error when installing Civicrm on Wordpress

I'm trying to install Civicrm 5.64.3, using steps outlined on Civicrm's installation guide. I tried ftp upload the zip file and extract and also trying to add the zip file through the Wordpress/plugin ...
iphoust's user avatar
1 vote
2 answers
35 views

Matomo (Piwik) and CiviCRM not compatible? _PEAR_call_destructors()

I have found the following error after installing CiviCRM through uploading the ZipFile. I haven't found any thread with this specific incompatibility. Both Plugins, Matomo and CiviCRM work just fine ...
JPBM's user avatar
  • 11
0 votes
3 answers
89 views

WordPress - Sorry, you are not authorized to access this page

I installed a clean WordPress with Version 6.2.2. I installed the CiviCRM from https://download.civicrm.org/civicrm-5.62.1-wordpress.zip After I click on activate the plugin I get a short time the ...
Ertan's user avatar
  • 1
0 votes
2 answers
59 views

Installing latest version (5.62.1) wordpress edition failure

I am trying to install civiCRM for my wordpress website. I followed the instructions multiple times on how to install civicrm, but it ends in the same way. When I activate civicrm in the plugin menu ...
user15536's user avatar
0 votes
0 answers
14 views

Module Calendar can't be installed with Wordpress

we use WordPress 6.2.2 and CiviCRM 5.58.1. When I try to install the extension "Calendar" I get a white page with a "critical error in WordPress". I can return back to Civi, but ...
Regina Sommerfeld's user avatar
2 votes
1 answer
34 views

I am trying to install CIVICRM on Drupal 9.4.1 using composer as per instruction found here https://docs.civicrm.org/installation/en/latest/drupal/

When i enter "composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.61'" getting error like " Could not parse version constraint '~5.61': Invalid version string "'~5.61'&...
RS Mayer's user avatar
1 vote
1 answer
18 views

Installation failure - doesn't to write to database (D7)

I'm unable to install CiviCRM under Drupal 7. This is something I've done dozens of times, to be clear. I install a clean D7 system (7.97 but also tried 7.95), the Civi install runs, I then get the ...
Andy Clark's user avatar
  • 4,845
1 vote
1 answer
85 views

CivicRM 5.60 installation on WordPress 6.2 in Local 6.7.0 fails

I am trying to install CivicRM for WordPress site in Local environment https://localwp.com/. I unzip the CivicRM (5.60), I place the folder into app/public/wp-content/plugins/ folder. I see the plugin ...
jjosseff's user avatar
2 votes
1 answer
19 views

How to specify database on D9 installation

This question was asked regarding wordpress but is also an issue for D9. When installing from the extend page in Drupal, there is no option to specify the schema for Civi, so all the tables end up ...
Dave S's user avatar
  • 71
1 vote
1 answer
75 views

How fix 'permission denied' on the default /civicrm url in a new install?

CiviCRM is generally working. The default myhost.com/civicrm url has a 'permission denied' error. The dashboard when using the full link works
Interlated's user avatar
1 vote
1 answer
105 views

Error "Database does not support creation of triggers" when installing CiviCRM 5.33.0 on Wordpress 6.2

We are trying to install CiviCRM 5.33.0 (not the latest because of an SQL error that we previously got) on Wordpress 6.2 and keep getting the error "Database does not support creation of triggers&...
Zodongo's user avatar
  • 23
0 votes
1 answer
90 views

PHP Fatal error: Uncaught Error: Class 'Civi\\Setup' not found on install

I'm trying to install the CiviCRM plugin in wordpress, but never get to see the install page. When I want to go to "Install CiviCRM" button beneath the wp-admin-Dashboard it aborts with &...
tmk's user avatar
  • 1
1 vote
0 answers
65 views

civicrm wordpress installation fails with: You have requested a non-existent service "spec_gatherer"

I'm trying to install Civicrm on Wordpress within this docker setup: https://lab.3sd.io/tools/civicrm-docker/ I tried the michaelmcandrew/civicrm:5.59.2-wordpress-php8.1 and civicrm:5.56.0-wordpress-...
yksflip's user avatar
  • 11
1 vote
0 answers
27 views

CiviCRM installation on Backdrop; CiviCRM links produce 404. Any thoughts?

CMS: Backdrop 1.24 CiviCRM: 5.58 PHP: 7.42 MySQL: 5.7.36 etc I have a Backdrop/CiviCRM installation running without errors on MAMP. I then tried to install CiviCRM with Backdrop on a live site hosted ...
Steven James's user avatar
1 vote
2 answers
35 views

CiviCRM video courses

CiviCRM is a great piece of software, but its reputation could be greatly improved giving video material to newcomers. Is there any project or team to involve on this?
Liliana Stronciu's user avatar
0 votes
0 answers
19 views

I can't reinstall civicrm "You do not have sufficient permissions to access this page"?

I installed civicrm on Wordpress without the test data so I just wanted to uninstall it by deactivating + deleting the folders .../wp-content/plugins/civicrm & wp-content/uploads/civicrm I also ...
Mertus's user avatar
  • 1
1 vote
2 answers
57 views

Civicrm on Wordpress installer table doesnt exist

Using Ampp version 4.3 with Apache v2.4.54, MySQL v8.0.31, php version 7.4.32, Windows Every time I run the CiviCrm installer I get an error "Table 'civicrm.civicrm_worldregion' doesn't exist in ....
SaKa's user avatar
  • 11
0 votes
2 answers
84 views

What's the best practice for creating a cronuser for WordPress CiviCRM installs?

I am working on setting up the cron job using cv on a fresh CiviCRM and WordPress install. The docs are unclear on where to set up the "cronuser" user (WordPress user? CiviCRM contact?) and ...
Mark's user avatar
  • 217
1 vote
1 answer
22 views

"Failed to locate boot function (bootJoomla)" error when installing with cv

Learning to use cv, and when trying to upgrade CiviCRM with the following command, I get a "Failed to locate boot function (bootJoomla)" error. Any thoughts where I should start digging as ...
MtnPavlas's user avatar
  • 856
1 vote
1 answer
59 views

Installation fault on Wordpress hosted site

Tried installing on a WP server. Versions: WordPress version 6.0.3 Active theme: Twenty Twenty-One (version 1.6) Current plugin: CiviCRM (version 4.6) PHP version 7.4.32 Zend Engine v3.4.0, Zend ...
Nick Brown's user avatar
1 vote
0 answers
48 views

Permissions issue, 403 on CiviCRM install

I've installed CiviCRM for WordPress without issues in the past but I've encountered a problem on one particular host. CiviCRM installs OK but when I launch the Installer I get a 403 on https://my....
Biggles's user avatar
  • 11
1 vote
2 answers
52 views

Civisualize is not installing. Shows critical error message only. How to fix this issue in civicrm WordPress?

Civisualize is not installing. Shows critical error message only. How to fix this issue in civicrm WordPress? Tried to solve this a lot. But no proper solution is found till now. Please reply if any ...
Vishnu MD's user avatar
0 votes
1 answer
52 views

No CiviCRM pages on completely new install

New Server: Intel Xeon-E2388G 3.2, with 64GB RAM and 2 1TB nvme on soft raid running ubuntu server Database Server: 10.4.24-MariaDB-1:10.4.24+maria~focal PHP 7.4.30, Memory Limit 512MB Drupal 9.4.5, ...
Mark Carson's user avatar
1 vote
1 answer
46 views

Installation failed: DB Error:connect failed

I'd appreciate any hint on how to fix this: wordpress installed, civicrm installation fails with Initialization Error code 24 DB Error: connect failed. Access denied for user 'user'@'localhost' ...
golha's user avatar
  • 21
1 vote
1 answer
88 views

Issues with installing CiviCRM onto a Drupal 9 instance

I am currently having issues trying to install CiviCRM onto a Drupal 9.3.14 instance for a NPO website which is currently utilising the LocalGov Drupal Install Profile (https://www.drupal.org/project/...
Ryan Jarvis's user avatar

1
2 3 4 5
7