Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [installation]

Tag a question "installation" if you are having trouble completing the initial installation of CiviCRM on Drupal, Joomla, or WordPress. If you encounter problems while using the system, use tags that are more specific to the features affected.

0
votes
1answer
12 views

Installation CiviHR

I would like to install CiviHR and design the data base, but I need support and training for tha. Is there any organisation or individual in the Netherlands that can provide that support?
0
votes
0answers
7 views

Joomla Installation causes Internal Server Error

I have a fresh install of Joomla 3.9.6 and trying a fresh install of CiviCRM 5.13.4 and I have been following the instructions found here https://docs.civicrm.org/sysadmin/en/latest/install/joomla/ I'...
1
vote
2answers
76 views

Fresh WP install succeeds then fails - path or permissions problem?

I've followed the install instructions on docs.civicrm.org site to make a fresh installation of CiviCRM in Wordpress on a local server (Synology NAS running Linux kernel). All went fine, leading to ...
0
votes
1answer
23 views

Split Data from Wordpress Database

On my initial setup, I had installed CiviCRM onto the same database as the Wordpress installation. Now I want to split this as I am migrating the website and would rather backup and have a copy of the ...
2
votes
1answer
125 views

404 Error During Install (Wordpress)

I m attempting to install CiviCRM 4.7 in Wordpress. I have all green bars, and have verified multiple times that the database password and user are correct. When I click the "Check Requirements and ...
1
vote
1answer
114 views

I am to install CiviCRM on Windows 10 with WAMP

I have been trying to setup CiviCRM on Windows 10, But I am not able to install "bin/civi-download-tools" on it. Even I have installed and enabled Linux subsystem tools on windows. Please guide me ...
0
votes
0answers
18 views

Installing Civicrm on Drupal 7 site

I have uploaded Civicrm 5.12.0 on a Drupal 7.65 site via FTP. After upload was completed, I attempted the installation script, but nothing happened. Is there a step that I forgot to do or wasn't aware ...
0
votes
1answer
41 views

Tyring to Upgrade to civicrm 4.7.28 on Joomla but wsod error says civicrm.settings.php is missing

I', having a hard time upgrading my Joomla! 3.8.3 site on Php 7 to civiCRM 4.7.28. This is the error I'm getting when I install from directory. I looks like it's not creating the civicrm.settings.php ...
0
votes
2answers
91 views

Getting this install error using latest CivicCRM on wordpress

Fatal error: Uncaught Error: Call to undefined function set_current_screen() in /var/www/html/wp-admin/admin-header.php:30 Stack trace: #0 /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Utils/...
0
votes
2answers
124 views

CiviSMS extension

I am running CiviCRM 4.7.6 on Drupal 7.43 on a CentOS 7 platform. I need to install CiviSMS with the Twilio and am running into a problem with the PHP version requirement of 5.5. CentOS natively has ...
1
vote
1answer
29 views

Is it better to install civi (Wordpress) on a dev server first then migrate to production or is the reverse better?

Assuming the goal is to install clones of Civi + WP + MySQL on two servers (let's call them "production" and "dev" with those roles in mind): These days, is it better to install first on dev then ...
2
votes
3answers
222 views

Fatal error: Uncaught CRM_Core_Exception: Civi/Core/InstallationCanary.php on line 53

I am just trying to install on a WordPress platform and it said OK for all the checks and fairly sure that everything is okay. After running with Install button, I get this error and if I click in ...
2
votes
1answer
25 views

Installer not showing up

I've uploaded the file civicrm-5.8.2-wordpress.zip into the plugins folder and unzipped it. I've activated the plugin. The first time through this process the installer ran to the point of creating ...
2
votes
0answers
64 views

What does undefined extension class 'Smarty_Internal_Method_Assign_By_Ref' Mean?

The new installation of CIVI works. LAMP server, shared hosting, PHP 7.2, Joomla! 3.9, etc. When I click to go to configuration checklist, I get the error: undefined extension class '...
9
votes
7answers
1k views

Getting permission error when installing CiviCRM under Drupal

I've recently set up a subdomain of mine on a VPS, installed Drupal 7.56, and managed to download the civicrm module but when I go to http://mysite.net/drupal-7.56/sites/all/modules/civicrm/install/...
3
votes
1answer
38 views

CiviVolunteer - Where to put translations file on WordPress

after some work on Transifex, we need to install civiVolunteer italian translation on WordPress. Where is the right place to put the .po file?
3
votes
1answer
34 views

Installer says cannot create triggers but I can with phpMyAdmin

Any suggestions how to get the civicrm installer to recognize that I have permission to create triggers. The installer says I don't, but my host says I do. I can create triggers with phpMyAdmin. I am ...
2
votes
0answers
72 views

Errors on install WP 5.02 (fresh install) , Civicrm 5.82, PHP 7.2.13 (xampp)

I installed civicrm 5.82 on a fresh install of Wordpress 5.02 with PHP 7.2.13 (xampp). Went through civicrm setup, then saw a few PHP warnings on the CiviCRM Home page. This is running on my local dev ...
0
votes
1answer
26 views

Warning after installation: Invalid argument supplied for foreach() in CRM_Utils_Check_Component_Env

anyone an idea what this warning is about? I get this warning straight after fresh installation. Warning: Invalid argument supplied for foreach() in CRM_Utils_Check_Component_Env->checkVersion() (...
1
vote
1answer
56 views

Can't use function return value in write context in … civicrm.php on line 342 (5.8.1, WordPress)

After manual installation of the plugin in Wordpress (5.0.1), PHP (7.2.12), mySQL (10.1.36-MariaDB). I can't activate it. I receive this info: Fatal error: Can't use function return value in write ...
3
votes
1answer
57 views

Unable to create InnoDB tables. MySQL InnoDB support is required for CiviCRM but is either not available or not enabled in this MySQL database server

I'm trying to install an old CiviCRM version on Drupal 6, the purpose is to migrate an old database data to the latest CiviCRM version, but I'm getting this error when I try to install CiviCRM in a ...
5
votes
1answer
392 views

Unable to install CiviCRM 4.7 on Wordpress 4.4.1

Environment: PHP Version 5.6.15 Apache 2.4.17 MySQL 5.6.27 Windows 10 Wordpress Plugins Active: Exclude Pages from Navigation, Ninja Forms, Ninja Forms - Layout Master When attempting to ...
0
votes
2answers
47 views

Hosting Provider for CiviCRM

I am trying to install my CiviCRM instance on my current drupal installation that is my website which is hosted by the webgo24.de. During installation I get an error „DB Error“ and after some emails ...
2
votes
1answer
26 views

Installation issues - unmet dependencies

trying to install the civicrm buildkit using the instructions found here : https://docs.civicrm.org/dev/en/latest/tools/buildkit/ I am on ubuntu 16.04. When I run curl -Ls https://civicrm.org/get-...
2
votes
2answers
74 views

Can not enable Contact Distance Search under CiviCRM modules

I have installed CiviCRM 4.7 and CMS is Drupal 7.56 CiviCRM Contact Distance Search is showing disabled in the modules list. Why is it disabled? how to enable it?
4
votes
3answers
275 views

CiviVolunteer install fails

Failure installing CiviVolunteer ver 4.6-2.1.1 on CiviCRM ver 4.7.6. I'd previously had CiviVolunteer1.4, (pretty much just playing with it) then attempted 2.0 install several weeks ago. Nothing ...
1
vote
0answers
13 views

Any issues known when installing via docker image?

I have installed Bitnami CiviCRM Stack 5.5.3-0, containing CiviCRM, Drupal, MySQL, Apache ... It works like a charm, at least the are no obvious issues for me - ok, im a complete beginner regarding ...
1
vote
1answer
34 views

2 Drupal Sites and 1 CiviCRM

I am looking for some advice on whats the best approach to implement two Drupal sites with different domain names + designs and link them to one CiviCRM. I know multi-site for CiviCRM is on option ...
2
votes
1answer
105 views

CiviCRM Page Not Found Error After Copying Site to New Server

I wanted to do some testing on my CiviCRM site (on Drupal) and so copied everything over to another server. I am using CiviCRM 5.3.1 with Drupal 7.59. I followed the steps in the "Moving an Existing ...
1
vote
1answer
35 views

Running 2 civicrm instances on 1 database

I have one mySQL database and one Apache webserver. Can I still run 2 separate wordpress/Civicrm environments (like staging and production)?
1
vote
1answer
35 views

Cannot bootstrap Civi from standalone script in WP

We have an old script in the bin folder that bootstraps Civi like so: require_once '[whatever]/wp-content/plugins/civicrm/civicrm/civicrm.config.php'; require_once 'CRM/Core/Config.php'; But as of 4....
5
votes
0answers
40 views

Oops! Incorrect CiviCRM version. This installer can only be used for the Drupal version of CiviCRM

I get this message after (successfully) installing 5.4.0 into Backdrop 1.10.1. The download file is civicrm-5.4.0-backdrop.tar.gz and when I start to install it shows the correct version (it says ...
1
vote
1answer
58 views

CiviCRM 5.4.0 Install “You do not have permission to access this page”

I am stuck on this step: Then go to Settings > CiviCRM Installer: http://example.org/wp-admin/options-general.php?page=civicrm-install In version 4.7 and above you will see a link on the wp-...
1
vote
1answer
31 views

Drupal Installation Error on Centos

I am getting this error during installation. Has anyone else seen this? You don't have permission to access this page The installer can only be run by a user with the permission to administer site ...
2
votes
2answers
238 views

How to reset CiviCRM?

When writing a re-initialisation script / extension or drupal module, how would you reset CiviCRM back to clean installation state? Is it possible to install "minimal" without components and their ...
0
votes
1answer
53 views

CiviCRM reports Cron not running, but my web host is adamant that it is

I'm using the cli.php method to run cron as described in the System Administrator Guide. I am able to run this command from ssh, and it seems to execute fine: php /var/sites/c/<mydomain>/...
1
vote
3answers
99 views

DB Error: connect failed when trying to call Job.execute using cli.php?

I've set up a new CiviCRM install on a new Drupal install and I'm trying to configure Cron using the instructions at https://docs.civicrm.org/sysadmin/en/latest/setup/jobs/. I'm a complete newbie at ...
1
vote
3answers
54 views

My hosting company does not support SUPER privilege - can I use CiviCRM with them?

I finally after a week and 3 tickets got CiviCRM/Joomla to install on my Startlogic hosted server, but I can't add anything to the database. The final response I got from Startlogic support was "...
4
votes
1answer
38 views

Moving site from WordPress to Drupal

I've been moving a CiviCRM from WordPress to Drupal but getting a strange array of errors. It's on the same hosting so I've set up a new database for the new CiviCRM, moved all the tables except the ...
2
votes
2answers
80 views

Can't install extensions on CiviCRM 4.6.36 with Drupal 7.59

So I successfully installed CiviCRM and most things are running well but I can't install extensions. From Gui I get to the "Download and Install button and the installation fails with: WARNING: The ...
1
vote
1answer
117 views

CiviCRM installation page is blank on Wordpress

I am trying to install CiviCRM in Wordpress. The upload and activation of the plugin worked fine. Issue is now using this URL /wp-admin/options-general.php?page=civicrm-install to complete the ...
2
votes
1answer
151 views

`Failed opening required 'Log.php'` trying to install

I'm attempting to install CiviCRM 4.6.19 in order to perform a migration and am completely stumped on something. This is going into a Drupal 7 site and the entire thing is being put together with ...
1
vote
0answers
61 views

white screen when trying to install civicrm on drupal, which is installed on a subdirectory

I have a Drupal site installed in a subdirectory, and would like to install the Civi module in it. I have uploaded all the civi files, alas, when I try to install Civi here: www.mysite/drupal/civi/...
1
vote
1answer
87 views

Error when installing civicrm-4.7.29-drupal on Drupal-7.56

when I install civicrm-4.7.29-drupal on Drupal-7.56 just using one database for drupal an civicrm the installation runs perfectly without any errors. If I use two databases for drupal and civicrm I ...
0
votes
1answer
88 views

Unable to install CiviCRM 5.0.1 as Drupal site admin

Just been trying to install CiviCRM 5.0.1 in Drupal 7.58, and when I try to run the install script, I get a message saying I don't have permission to do so: "You don't have permission to access this ...
2
votes
1answer
29 views

Is there Support?

Do you provide support services to users? If so, what is the cost or cost of additional add-ons? I've heard that this is priced a-la-carte per submitted request
1
vote
2answers
25 views

Is it possible to set the list of CiviCRM components from the command line using drush

drush and cv have both have commands to install extensions. But know I want to create a script that sets the CiviCRM components. Is it possible to do this?
1
vote
4answers
38 views

CiviVolunteer Fails to Install

After moving my Joomla-based CiviCRM site to a new server that included an upgrade to Joomla 3.8.2 on PHP 7.0 and CiviCRM 4.7.29, CiviVolunteer stopped working. I eventually uninstalled CiviVolunteer ...
1
vote
2answers
534 views

Joomla installation error: Please enter a package folder. Unable to find install package

When I tried installing by uploading the package file, nothing happened. Then I tried exactly as the installation guide says for Joomla and I get this error: Please enter a package folder. Unable to ...
3
votes
0answers
162 views

Wordpress V4.7.31 install - Cannot add or update a child row: a foreign key constraint fails

installation fails with a bunch of the same errors. Summary below: DB_Error object ( [error_message_prefix] => [MODE] => 1 [level] => 1024 [code] => -3 [MESSAGE] => db ERROR: ...