Questions tagged [installation]

Tag a question "installation" if you are having trouble completing the initial installation of CiviCRM on Drupal, Joomla, or WordPress. If you encounter problems while using the system, use tags that are more specific to the features affected.

Filter by
Sorted by
Tagged with
1
vote
1answer
24 views

What does it mean to “configure your MySQL server for utf8mb4 support” when my database charset and collation are already utf8mb4?

I am about to run the CiviCRM installer, but I get the following warning: CiviCRM MySQL utf8mb4 Support: It is recommended, though not yet required, to configure your MySQL server for utf8mb4 support. ...
0
votes
1answer
44 views

Installation CiviHR

I would like to install CiviHR and design the data base, but I need support and training for tha. Is there any organisation or individual in the Netherlands that can provide that support?
2
votes
1answer
25 views

Wordpress Installation Bug?

Anyone has experience installing CiviCRM in Wordpress? I tried to follow the installation guide but I come with this problem, Google doesn't offer much help. It comes with an error in the database ...
0
votes
0answers
19 views

Installing civicrm on wordpress

I have followed the Civicrm installation instructions for wordpress and when I activate the plugin in wordpress I get this error, can anyone help:
3
votes
2answers
815 views

After installation Civi menu and dashbord do not show (SOLVED)

after a successful installation of CiviCRM 4.7.19 on WordPress 4.7.4 – the installer said everything was fine –, the menu and dashboard of CiviCRM does not show. I know, this issue has been ...
2
votes
2answers
147 views

404 Error During Install (Wordpress)

I m attempting to install CiviCRM 4.7 in Wordpress. I have all green bars, and have verified multiple times that the database password and user are correct. When I click the "Check Requirements and ...
0
votes
1answer
29 views

cannot access /wp-admin/options-general.php?page=civicrm-install after installing 5.28.3

I have found it impossible to upgrade from CiviCRM 5.25 to 5.28 to get around the breakage caused by the WP upgrade from 5.4 to 5.5 My attempted solution has been to make a staging site, completely ...
1
vote
2answers
118 views

Fresh WP install succeeds then fails - path or permissions problem?

I've followed the install instructions on docs.civicrm.org site to make a fresh installation of CiviCRM in Wordpress on a local server (Synology NAS running Linux kernel). All went fine, leading to ...
0
votes
0answers
15 views

Errors encountered after installation of CiviCRM [BackdropCMS]

This is an updated version of my question here. CiviCRM v5.28.3; Backdrop v1.16.2; Shared hosting at TSO Host (UK shared hosting) Fresh install of both Backdrop and CiviCRM. Does not show Civi menu, ...
1
vote
1answer
23 views

Installing CivicRM

I have installed CivicRM in Wordpress but there is no menu or dashboard. All I see is the attached. What have I done wrong? Thanks Paula
1
vote
1answer
204 views

I am to install CiviCRM on Windows 10 with WAMP

I have been trying to setup CiviCRM on Windows 10, But I am not able to install "bin/civi-download-tools" on it. Even I have installed and enabled Linux subsystem tools on windows. Please guide me ...
2
votes
2answers
61 views

Error on CiviCRM Activation. Can't Install CiviCRM

I’m trying to install a new copy of CiviCRM for Wordpress on Plesk Onyx. I get the following error when I try to activate CiviCRM after uploading the files to my server: Warning: require_once(CRM/...
2
votes
1answer
92 views

Local (flywheel) wordpress install with CiviCRM

we are trying to install latest civicrm 5.23 using latest wordpress 5.3.2 Using latest version of previous Local by Flywheel (version 3.3.0) I want to install in french language. I'm following the ...
0
votes
2answers
51 views

Installing Civicrm on Drupal 7 site

I have uploaded Civicrm 5.12.0 on a Drupal 7.65 site via FTP. After upload was completed, I attempted the installation script, but nothing happened. Is there a step that I forgot to do or wasn't aware ...
0
votes
0answers
37 views

Unable to extract civicrm zip file in file manager

I tried to follow the civicrm install guide for wordpress (https://docs.civicrm.org/sysadmin/en/latest/install/wordpress/). I am stuck after copying the civicrm-5.28.0-wordpress.zip file into the file ...
0
votes
1answer
54 views

Tyring to Upgrade to civicrm 4.7.28 on Joomla but wsod error says civicrm.settings.php is missing

I', having a hard time upgrading my Joomla! 3.8.3 site on Php 7 to civiCRM 4.7.28. This is the error I'm getting when I install from directory. I looks like it's not creating the civicrm.settings.php ...
0
votes
2answers
147 views

CiviSMS extension

I am running CiviCRM 4.7.6 on Drupal 7.43 on a CentOS 7 platform. I need to install CiviSMS with the Twilio and am running into a problem with the PHP version requirement of 5.5. CentOS natively has ...
2
votes
1answer
30 views

New Install “MYSql Server Has Gone Away”

Good evening, I'm new here and trying to get CiviCRM installed for the first time (volunteer sysadmin for a non-profit). I think I have gone through all of the steps to troubleshoot but I suspect I am ...
0
votes
1answer
20 views

How to call my post_provision_install hook after CiviCRM installed?

I want to automate the removal of households from CiviCRM, right after it has been installed via Aegir on Drupal 7. I implemented my post_provision_install hook, but it runs before the same hook of ...
1
vote
3answers
26 views

Clean install on WordPress and blank dashboard

After install on WordPress I am getting a blank dashboard and the "configure dashboard" button doesn't do anything. I tried deactivating all plugins except CiviCRM, that made no different. ...
1
vote
0answers
26 views

CiviCRM installation (Backdrop) incomplete

Backdrop CMS: 1.16.1 CiviCRM: 5.25.0 php 7.3.17 Shared host (Civihosting) Following installation of CiviCRM on fresh install of Backdrop, I started the CiviCRM configuration process, but was unable ...
3
votes
1answer
27 views

Why settings.default.json file is neglected during install?

Since CiviCRM 5.23, one can set a custom L10n/I18n resource directory. Using this feature with Aegir and Drupal 7 profiles, this setting almost works: CiviCRM sites install with selected language, ...
1
vote
1answer
15 views

Error in Class CRM_Extension_Mapper 'Class CRM_Extension_Info not found' when installing 5.24 in Drupal 7

I have a problem enabling CiviCRM 5.24.2 after installation in Drupal 7.69 under PHP 7.2.27 under Centos7 Apache/2.4.6 CiviCRM installs correctly using both UI and CV method - ie builds database &...
2
votes
1answer
63 views

When reinstalling CiviCRM, it will not allow connection to a database with preexisting data

I am reinstalling CiviCRM on Wordpress after Civi quit quit working. I deleted the folder civicrm in /plugins and also in /uploads. This allowed me to upload the new plugin version of Civi and took ...
0
votes
0answers
10 views

Panopoly causes blank CiviCRM installer screen

I've been exceedingly unhappy with various themes on my site, and I'm experimenting with rebuilding from the ground up starting with Panopoly. Seems that this route will be easier to migrate to Drupal ...
1
vote
0answers
28 views

Installation fails

I'm using Wordpress 5.3.2 multisite and CiviCRM 5.22.1. Installing CiviCRM in a subdomain, and can't get the CiviCRM installer to work. I created a new mySQL database. Ran the first stage of the ...
0
votes
1answer
24 views

How do I delete a CiviCRM instance?

Trying to find details on how to remove a CiviCRM test data setup I've created. I'm using Wordpress 5.3.2 multisite and CiviCRM 5.22.1. I've installed CiviCRM into the plugin directory which ...
1
vote
2answers
37 views

Flush system cache does not work during installation of Drupal Profile

I am creating a distribution Drupal profile which is bundling CiviCRM and CiviCRM extensions. Background Currently, I am having an issue with extensions that CiviCRM settings, for example, Mosaico ...
3
votes
4answers
352 views

CiviVolunteer install fails

Failure installing CiviVolunteer ver 4.6-2.1.1 on CiviCRM ver 4.7.6. I'd previously had CiviVolunteer1.4, (pretty much just playing with it) then attempted 2.0 install several weeks ago. Nothing ...
1
vote
2answers
57 views

Are the WordPress install docs wrong?

I'm following the docs at https://docs.civicrm.org/sysadmin/en/latest/install/wordpress/ I downloaded 5.17 in a zip file from https://github.com/civicrm/civicrm-core/releases, unzipped it and renamed ...
3
votes
1answer
131 views

What is the easiest way to set up cron for CiviCRM on a Drupal 7 installation?

I have created a test instance of CiviCRM that uses Drupal 7 as the CMS. It's running inside a Ubuntu Desktop virtual machine that has a LAMP stack installed on it (Apache2, php7.2 and mySQL). I am ...
2
votes
2answers
188 views

Errors in functions.php after installing 5.16.2 on Drupal 7

I'm running Drupal 7.67 on PHP 7.1 and am now getting the below error when I invoke Drush commands. Another gripe is that upon install, Civi blew out my blocks settings, so I needed to reconstruct ...
1
vote
3answers
200 views

Basic Wordpress user cannot see CiviCRM

I have installed CiviCRM on Wordpress and done the setup. I have created a basic (subscriber role) in WP, have filled the Permissions (Access Control) table for this role, synchronized the WP contacts ...
0
votes
2answers
176 views

Getting this install error using latest CivicCRM on wordpress

Fatal error: Uncaught Error: Call to undefined function set_current_screen() in /var/www/html/wp-admin/admin-header.php:30 Stack trace: #0 /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Utils/...
1
vote
0answers
109 views

Help: Need someone to migrate us from the old wordpress plugin

When CiviCRM abandoned the WordPress plugin after Version 4.4, and never coded an upgrade path, we got stuck on 4.4 and are now getting the "The site is experiencing technical difficulties. Please ...
1
vote
0answers
15 views

Tyring to install civicrm-5.15.1 on Joomla 3.9.9 Stable - “Installation error com_civicrm/admin/configure.php on line 115”

sorry for my approximate English. civicrm-5.15.1-joomla Joomla! 3.9.9 Stable Unfortunately the installation ends with the following error message. Fatal error : require_once(): Failed opening ...
3
votes
1answer
55 views

CiviVolunteer - Where to put translations file on WordPress

after some work on Transifex, we need to install civiVolunteer italian translation on WordPress. Where is the right place to put the .mo file?
2
votes
1answer
31 views

How to change a sites URL

CiviCRM 5.14.0 I've read several explanations of how to change a sites URL but I am not having luck. I have made the changes in my apache2 sites-available conf file and restarted apache2. I have also ...
2
votes
0answers
31 views

Joomla Installation causes Internal Server Error

I have a fresh install of Joomla 3.9.6 and trying a fresh install of CiviCRM 5.13.4 and I have been following the instructions found here https://docs.civicrm.org/sysadmin/en/latest/install/joomla/ I'...
0
votes
1answer
41 views

Split Data from Wordpress Database

On my initial setup, I had installed CiviCRM onto the same database as the Wordpress installation. Now I want to split this as I am migrating the website and would rather backup and have a copy of the ...
1
vote
1answer
39 views

Is it better to install civi (Wordpress) on a dev server first then migrate to production or is the reverse better?

Assuming the goal is to install clones of Civi + WP + MySQL on two servers (let's call them "production" and "dev" with those roles in mind): These days, is it better to install first on dev then ...
2
votes
3answers
305 views

Fatal error: Uncaught CRM_Core_Exception: Civi/Core/InstallationCanary.php on line 53

I am just trying to install on a WordPress platform and it said OK for all the checks and fairly sure that everything is okay. After running with Install button, I get this error and if I click in ...
2
votes
1answer
38 views

Installer not showing up

I've uploaded the file civicrm-5.8.2-wordpress.zip into the plugins folder and unzipped it. I've activated the plugin. The first time through this process the installer ran to the point of creating ...
2
votes
0answers
140 views

What does undefined extension class 'Smarty_Internal_Method_Assign_By_Ref' Mean?

The new installation of CIVI works. LAMP server, shared hosting, PHP 7.2, Joomla! 3.9, etc. When I click to go to configuration checklist, I get the error: undefined extension class '...
9
votes
7answers
2k views

Getting permission error when installing CiviCRM under Drupal

I've recently set up a subdomain of mine on a VPS, installed Drupal 7.56, and managed to download the civicrm module but when I go to http://mysite.net/drupal-7.56/sites/all/modules/civicrm/install/...
3
votes
1answer
78 views

Installer says cannot create triggers but I can with phpMyAdmin

Any suggestions how to get the civicrm installer to recognize that I have permission to create triggers. The installer says I don't, but my host says I do. I can create triggers with phpMyAdmin. I am ...
2
votes
0answers
126 views

Errors on install WP 5.02 (fresh install) , Civicrm 5.82, PHP 7.2.13 (xampp)

I installed civicrm 5.82 on a fresh install of Wordpress 5.02 with PHP 7.2.13 (xampp). Went through civicrm setup, then saw a few PHP warnings on the CiviCRM Home page. This is running on my local dev ...
0
votes
1answer
103 views

Warning after installation: Invalid argument supplied for foreach() in CRM_Utils_Check_Component_Env

anyone an idea what this warning is about? I get this warning straight after fresh installation. Warning: Invalid argument supplied for foreach() in CRM_Utils_Check_Component_Env->checkVersion() (...
1
vote
1answer
61 views

Can't use function return value in write context in … civicrm.php on line 342 (5.8.1, WordPress)

After manual installation of the plugin in Wordpress (5.0.1), PHP (7.2.12), mySQL (10.1.36-MariaDB). I can't activate it. I receive this info: Fatal error: Can't use function return value in write ...
3
votes
1answer
93 views

Unable to create InnoDB tables. MySQL InnoDB support is required for CiviCRM but is either not available or not enabled in this MySQL database server

I'm trying to install an old CiviCRM version on Drupal 6, the purpose is to migrate an old database data to the latest CiviCRM version, but I'm getting this error when I try to install CiviCRM in a ...

1
2 3 4 5