Questions tagged [installation]

Tag a question "installation" if you are having trouble completing the initial installation of CiviCRM on Drupal, Joomla, or WordPress. If you encounter problems while using the system, use tags that are more specific to the features affected.

54 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
57 views

Oops! Incorrect CiviCRM version. This installer can only be used for the Drupal version of CiviCRM

I get this message after (successfully) installing 5.4.0 into Backdrop 1.10.1. The download file is civicrm-5.4.0-backdrop.tar.gz and when I start to install it shows the correct version (it says ...
3
votes
0answers
181 views

Wordpress V4.7.31 install - Cannot add or update a child row: a foreign key constraint fails

installation fails with a bunch of the same errors. Summary below: DB_Error object ( [error_message_prefix] => [MODE] => 1 [level] => 1024 [code] => -3 [MESSAGE] => db ERROR: ...
2
votes
1answer
141 views

Local (flywheel) wordpress install with CiviCRM

we are trying to install latest civicrm 5.23 using latest wordpress 5.3.2 Using latest version of previous Local by Flywheel (version 3.3.0) I want to install in french language. I'm following the ...
2
votes
0answers
35 views

Joomla Installation causes Internal Server Error

I have a fresh install of Joomla 3.9.6 and trying a fresh install of CiviCRM 5.13.4 and I have been following the instructions found here https://docs.civicrm.org/sysadmin/en/latest/install/joomla/ I'...
2
votes
0answers
189 views

What does undefined extension class 'Smarty_Internal_Method_Assign_By_Ref' Mean?

The new installation of CIVI works. LAMP server, shared hosting, PHP 7.2, Joomla! 3.9, etc. When I click to go to configuration checklist, I get the error: undefined extension class '...
2
votes
0answers
131 views

Errors on install WP 5.02 (fresh install) , Civicrm 5.82, PHP 7.2.13 (xampp)

I installed civicrm 5.82 on a fresh install of Wordpress 5.02 with PHP 7.2.13 (xampp). Went through civicrm setup, then saw a few PHP warnings on the CiviCRM Home page. This is running on my local dev ...
2
votes
0answers
219 views

500 Error on install

I'm having issues just getting CiviCRM installed. This is a Drupal 7.55 install. I got as far as installing CiviCRM as a module but the next step is to go to the install/index.php file and that is ...
2
votes
2answers
156 views

404 Error During Install (Wordpress)

I m attempting to install CiviCRM 4.7 in Wordpress. I have all green bars, and have verified multiple times that the database password and user are correct. When I click the "Check Requirements and ...
2
votes
0answers
62 views

Unable to install extensions - Joomla

Trying to install the summary fields extension, however I keep getting this odd error that I've been unable to figure out. Looks like this: An error has occurred. CiviCRM-001 @import url(/...
1
vote
0answers
21 views

No admin page for civiCRM on Drupal 8 install (Xampp on Windows 10)

Sorry if my English contains mistakes. I just installed Drupal 8 on Xampp (Windows 10 latest version) with Composer and Drush. I then used the following commands for civiCRM: cd /c/xampp/htdocs/site/...
1
vote
1answer
30 views

Keep getting this error on Composer require

I'm using the current instructions to get the current version of CiviCRM for Drupal 8 [play@ceres web]$ composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.35' It keeps giving me this error ...
1
vote
0answers
28 views

Installing Civi onto WordPress under Local does not work due to XML path errors

Civi used to work under Local (née Local by Flywheel) on Windows, but I can't get it to install under the latest version. The Civi installer can't parse the schema xml files due to a path error. What ...
1
vote
0answers
30 views

Is it possible to copy the “structure” from one CiviCRM install to another without copying data?

We are testing in a locally hosted config (easy to rollback if something goes wrong, thank you VirtualBOX!) and I am wondering if it is possible to copy the config from the local install to our hosted ...
1
vote
0answers
55 views

CiviCRM installation (Backdrop) incomplete

Backdrop CMS: 1.16.1 CiviCRM: 5.25.0 php 7.3.17 Shared host (Civihosting) Following installation of CiviCRM on fresh install of Backdrop, I started the CiviCRM configuration process, but was unable ...
1
vote
0answers
33 views

Installation fails

I'm using Wordpress 5.3.2 multisite and CiviCRM 5.22.1. Installing CiviCRM in a subdomain, and can't get the CiviCRM installer to work. I created a new mySQL database. Ran the first stage of the ...
1
vote
0answers
110 views

Help: Need someone to migrate us from the old wordpress plugin

When CiviCRM abandoned the WordPress plugin after Version 4.4, and never coded an upgrade path, we got stuck on 4.4 and are now getting the "The site is experiencing technical difficulties. Please ...
1
vote
0answers
19 views

Tyring to install civicrm-5.15.1 on Joomla 3.9.9 Stable - “Installation error com_civicrm/admin/configure.php on line 115”

sorry for my approximate English. civicrm-5.15.1-joomla Joomla! 3.9.9 Stable Unfortunately the installation ends with the following error message. Fatal error : require_once(): Failed opening ...
1
vote
0answers
23 views

Any issues known when installing via docker image?

I have installed Bitnami CiviCRM Stack 5.5.3-0, containing CiviCRM, Drupal, MySQL, Apache ... It works like a charm, at least the are no obvious issues for me - ok, im a complete beginner regarding ...
1
vote
1answer
254 views

I am to install CiviCRM on Windows 10 with WAMP

I have been trying to setup CiviCRM on Windows 10, But I am not able to install "bin/civi-download-tools" on it. Even I have installed and enabled Linux subsystem tools on windows. Please guide me ...
1
vote
0answers
107 views

white screen when trying to install civicrm on drupal, which is installed on a subdirectory

I have a Drupal site installed in a subdirectory, and would like to install the Civi module in it. I have uploaded all the civi files, alas, when I try to install Civi here: www.mysite/drupal/civi/...
1
vote
0answers
84 views

Facing issues with CiviCRM installation on Drupal 7

I manage to install CiviCRM on Drupal 7 ( had to do it manually ) and ran installation program successfully. However, I am facing following issues : 1) civiCRM option is not visible on top menu ...
1
vote
2answers
140 views

Fresh WP install succeeds then fails - path or permissions problem?

I've followed the install instructions on docs.civicrm.org site to make a fresh installation of CiviCRM in Wordpress on a local server (Synology NAS running Linux kernel). All went fine, leading to ...
1
vote
0answers
58 views

Failure to install CiviCRM on a clean new Wordpress site, running on Debian Jessie. Installation activation went to a blank page

Using Let's Encrypt for ssl, no problems with WordPress. Installation and plugin activation for CiviCRM led to a blank page. Apache2 log looks like this: [Wed Jul 05 13:58:40.895212 2017] [ssl: ...
1
vote
0answers
54 views

problem installing civicrm on drupal 7 acquia on windows or linux LAMP.

Environment is window 7, drupal 7 using acquia dev desktop. Then tried on a linux box at home... LAMP... Error messages vary from white screen with only a waiting for domain at the bottom of the ...
1
vote
0answers
27 views

install extension civibooking

As the installer gave us a warning that we maybe will have issues with http Redirect, so we did a Manual Installation of civibooking. Now we cannot find any indicator that the process really was ...
1
vote
0answers
59 views

Install on Wordpress ends in 404 via HTTPS

I have a testing site I wish to install civiCRM on. The server and software specs all match civiCRM's requirements as seen here. The pre-install check all seems to be okay with it's green text. After ...
1
vote
0answers
25 views

Unable to access CiviCRM remotely

We are a having an issue where we are unable to access the CiviCRM feature outside of the server. When we try to access CiviCRM as a domain user on another machine, we are only able to access ...
1
vote
0answers
59 views

Unable to install CiviCRM plugin

Wordpress 4.5.2 CiviCRM 4.7.7 PHP 5.5.34 The installation goes smoothly and the database is created but I cannot continue with the configuration. I get this screen: CiviCRM Home Configure Your ...
1
vote
0answers
340 views

problem installing civicrm 4.7 on Wordpress 4.5

According to my hosting company failure is being caused by a code fault within the CiviCRM plugin itself, the following fatal error is being returned: Fatal error: Call to a member function register()...
1
vote
0answers
53 views

CiviCRM 4.6 installation on Drupal 7

I recently set up a new CiviCRM and everything's working fine but there's a couple of error messages that I get in the admin menu that I would love to resolve: When I go to 'Manage Extensions', this ...
1
vote
0answers
20 views

“Unsupported action” error on attempting to install an extension

I'm trying to install the extension Extended Mailing Stats on Civi 4.6.14 running on Wordpress 4.4.2. I added the extension's files to my Civi extension directory, went to the Civi extension manager ...
1
vote
0answers
22 views

Install CiviVounteer 4.5 - 1.4.1

I am using CiviCRM 4.6.7 installed on CMS WordPress version 4.3.1 and I'd like to install the extention CiviVolunteer. From Administer > System Settings > Extentions, I choose CiviVolunteer version 4....
1
vote
1answer
166 views

CiviCRM 5.4.0 Install “You do not have permission to access this page”

I am stuck on this step: Then go to Settings > CiviCRM Installer: http://example.org/wp-admin/options-general.php?page=civicrm-install In version 4.7 and above you will see a link on the wp-...
0
votes
0answers
8 views

Default URL settings wrong when using 'cv core:install'?

I have tried to create a clean setup using cv core:install. The setup did not work properly due to the following: The 'CIVICRM_UF_BASEURL' variable did not end with a slash, although the comments ...
0
votes
0answers
14 views

Can't connect to separate database

Trying a new install of CiviCRM 5.3.9 using a separate Wordpress database. Wordpress, MySQL and PHP are confirmed required versions. Path is definitely correct using mysql://USER:PASSWORD@localhost:...
0
votes
0answers
11 views

Error 503, CiviCRM 5.32.2 on Joomla 3.9.27 & PHP 7.3.27

Error 503, CiviCRM 5.32.2 on Joomla 3.9.27 & PHP 7.3.27 Hello, After successfully installing CiviCRM on a local test environment, I am trying to install CiviCRM on my hosted production Joomla ...
0
votes
1answer
37 views

WordPress WSOD When Activating CiviCRM 5.37.2

I am attempting to activate the CiviCRM 5.37.2 plugin on WordPress 5.7.2 after editing the MySQL connection string. After saving the connection string, I briefly get the CiviCRM "Success" ...
0
votes
1answer
33 views

Corrupt installation during upgrade to 5.37.2 on Joomla 3.9.26

I have run into some trouble trying to upgrade from and old version of Civi to version 5.37.2 on Joomla 3.9.26 running on PHP 7.3.27 and MySql 5.7.32-35. The initial problem was that I could not get ...
0
votes
1answer
36 views

Drupal 8/9 Compilation Install Error

I'm getting thiis error, when I try to install civicrm on Drupal 8 and 9 The following packages have new compilation tasks: civicrm/composer-compile-lib has 1 task civicrm/civicrm-core has 1 task ...
0
votes
0answers
33 views

New install of Wordpress and civiCRM failed to open stream template_c / civi 5.37.0 on Synology NAS DS720+

I tried at least 5 times complete new installation on my Synology NAS, I always end up with the same errors. In Wordpress on the CiviCRM Tab it shows these errors: Please can someone help me. Warning: ...
0
votes
0answers
21 views

Re-Instalation Error

I'm having trouble re-installing CiviCRM 5.31. on Wordpress, hosted on Ubuntu 20. I needed to uninstall an earlier version, and I now want to install the latest version. When I activate the plugin I ...
0
votes
1answer
47 views

Cannot install on live Joomla site

Have attempted many times to install 5.35.1 or later 5.36.0 on live Joomla site. Find little info anywhere. Must not be many Joomla installations. Followed instructions explicitly and kept getting php ...
0
votes
1answer
55 views

What has happened to totten/lurkerlite?

Problem 1 Installing CiviCRM using Composer has started giving these errors: - Root composer.json requires civicrm/composer-compile-plugin ^0.14.0 -> satisfiable by civicrm/composer-compile-...
0
votes
0answers
29 views

Installing civicrm on wordpress

I have followed the Civicrm installation instructions for wordpress and when I activate the plugin in wordpress I get this error, can anyone help:
0
votes
0answers
22 views

Errors encountered after installation of CiviCRM [BackdropCMS]

This is an updated version of my question here. CiviCRM v5.28.3; Backdrop v1.16.2; Shared hosting at TSO Host (UK shared hosting) Fresh install of both Backdrop and CiviCRM. Does not show Civi menu, ...
0
votes
0answers
50 views

Unable to extract civicrm zip file in file manager

I tried to follow the civicrm install guide for wordpress (https://docs.civicrm.org/sysadmin/en/latest/install/wordpress/). I am stuck after copying the civicrm-5.28.0-wordpress.zip file into the file ...
0
votes
1answer
54 views

Installation CiviHR

I would like to install CiviHR and design the data base, but I need support and training for tha. Is there any organisation or individual in the Netherlands that can provide that support?
0
votes
2answers
57 views

Installing Civicrm on Drupal 7 site

I have uploaded Civicrm 5.12.0 on a Drupal 7.65 site via FTP. After upload was completed, I attempted the installation script, but nothing happened. Is there a step that I forgot to do or wasn't aware ...
0
votes
1answer
65 views

Tyring to Upgrade to civicrm 4.7.28 on Joomla but wsod error says civicrm.settings.php is missing

I', having a hard time upgrading my Joomla! 3.8.3 site on Php 7 to civiCRM 4.7.28. This is the error I'm getting when I install from directory. I looks like it's not creating the civicrm.settings.php ...
0
votes
0answers
97 views

How to Install Civi on a Subdomain?

I am installing civi 4.7.27 on a subdomain ( civiinstall.mysite.com ) that will run on WordPress 4.9.1. Has anyone installed Civi on a subdomain before? Do we need to update the paths somewhere as ...