Questions tagged [issues]

Bugs (or issues) on CiviCrm are tracked on https://issues.civicrm.org. The used system is Jira. Clarify your question by using the issue nr.

Filter by
Sorted by
Tagged with
5
votes
1answer
73 views

Manage Group broken on 4.7.5

after update to 4.7.5, the "manage Groups" page just says "No groups have been created for this site". Although the groups are functioning otherwise. This also happens on the sandbox/demo site.
3
votes
1answer
111 views

Using Profiles for Data Entry

I am using profiles for data entry in my CiviCRM instance. They seem to be working (the contacts that should be created are saving), but I get the following (big ugly) notices at the top of the page ...
3
votes
2answers
56 views

Drush failing to build database during new installation

I am building a Docker container for CiviCRM, it is 99.9% done. Unfortunately, when I try to install the actual module via Drush, it spits out an error. I am fairly certain this isn't a Docker related ...
2
votes
4answers
52 views

“Invalid Contact ID” displayed after merge?

Drupal 7, Civicrm 4.7.4 I'm getting this error message after every contact merge. Any ideas? debug message CiviCRM_API3_Exception: "Invalid Contact Id" /var/www/vhosts/example.com/httpdocs/sites/...
2
votes
0answers
83 views

Member Since date is now the same as Start date since upgrade to 4.7.3

For user self sign-ups, the 'Member Since' date is now the same as 'Start date' since a version upgrade to 4.7.3. Was this expected? There appears to be no way to determine the actual join date now, ...
1
vote
1answer
62 views

Fatal error when exporting accounting batch to CSV in 4.7

Using Civi 4.7.2 (and then on 4.7.3; I thought I needed to upgrade to fix) with Drupal, I get the following error when I try to export an accounting batch to CSV: Fatal error: Call to undefined ...
1
vote
0answers
20 views

4.7.1 API query for contributions in same year returns no results

This worked correctly in 4.6.8, but not in 4.7.0 or 4.7.1. This query returns no results: $result = civicrm_api3('Contribution', 'get', array( 'sequential' => 1, 'receive_date' => array('...
1
vote
0answers
33 views

API get of multiple contact_sub_type returns no results

I have this problem on the Joomla demo site (4.6.0) and my own sites with versions 4.6.8 and 4.7.1. If I use the API explorer or run test php code, with a query checking for multiple contact_sub_type,...
3
votes
1answer
74 views

Formatting tags shown in activity view

It seems that any activity created in 4.7.1 (not sure about earlier 4.7 versions) sometimes shows all formatting tags when viewed. I reproduced this both in Wordpress and Drupal demos by creating a ...
4
votes
2answers
227 views

Online receipt change in 4.7: Wrong template is being used

We upgraded to 4.7 and using WP 4.4.1. The Online receipt for payments has changed -- something is telling the system to use the summary receipt and I can not find out what it is. See pics. How can ...
2
votes
1answer
27 views

Bugs in localization

I'm localizing (Italian) some parts of CiviCRM, but I noticed how some terms are not sensible to be translated. I had a look on the code and I found that these terms are written without the ts() call. ...
0
votes
1answer
63 views

Civicrm - Use profile create mode only works 50% of the time

I'm using CiviCRM 4.6.10 with Joomla 3.4.8 I have a profile form setup for public view for volunteers to register. 50% of the time the form works great, submits the new contact to the database, ...
5
votes
3answers
94 views

How do I find a patch for an issue in CiviCRM's issue tracker (JIRA)?

For example, issue CRM-17493 shows that it is fixed in 4.6.11. How do I find the patch to fix this specific issue from JIRA?
2
votes
1answer
46 views

Highly unusual matching error

One of my users created a petition: Both he and I responded and it appended our responses to the wrong records. I wasn’t logged in and it tried to write to an {surname matching mine]. I suspect that ...
3
votes
1answer
72 views

Contribution page “other amount” option causes weird behavior - possible bug?

Using version 4.6.10. I can reproduce this problem on the Demo site. This is the problem: Create a donation page with an "other amount" option in addition to fixed price options. Open the live-page ...
0
votes
3answers
112 views

Issue to install civicrm 4.6.10 on Drupal 7.41

I'm trying to install civicrm 4.6.10 with Drupal 7.41 on Ubuntu server 14.04 through Virtualbox. I installed successfully Drupal 7.41 and after that tried to follow the installation guide of civicrm. ...
0
votes
1answer
32 views

Display Preferences Bug?

we just tried to edit some of the display preferences (unticking various things we don't need) but upon clicking 'save' the changes do not hold, even though the green message box says "changes saved". ...
2
votes
2answers
31 views

Where can I find out more about the changes made from one version of Civi to another?

Do you need to find what changes were made from one Civi version to another - say 4.6.6 to 4.6.9? Where can you find that?
2
votes
0answers
14 views

Bug? Can not remove Group from contact while in Edit Mode

Issue occurs in CiviCRM 4.6.9 and can duplicate in 4.6.10 on CiviCRM.org demo site using WordPress. Step1. A contact is in a group. Step2. Edit the Contact and scroll down to the "Tags and Groups" ...
3
votes
2answers
2k views

Error “Unknown Error” when uploading a file with CKEditor

In CiviCRM 4.6.5, I'm not able to upload files with CKEditor. I get the very informative error Unknown error It's seems to be a permission or problem like that when copying the file but without more ...
1
vote
1answer
22 views

civicrm_handler_filter_participant_role.inc

this file is missing from the latest civicrm \sites\all\modules\civicrm\drupal\modules\views\civicrm\civicrm_handler_filter_participant_role.inc Is this intentially missing? We have functionality ...
0
votes
0answers
80 views

Civimail tracked links seem to be broken in 4.6.8

Links within both old (prior to update to 4.6.8) and new promo emails are not working at all. Resulting in something like this: The requested page "/sites/all/modules/civicrm/extern/url.php?u=2698&...
3
votes
2answers
637 views

Civix: Install error: API error: DB Error: already exists

According documentation I created a skeleton module with civix and answered yes to install it. It then gives an error response as in the Title. Afterwards is listed active in the extensions page. ...
1
vote
1answer
65 views

Exporting contacts merged to households causes DB error version 4.6.8

Viewed contacts from a Smart Group and went to Export. Merged to household and tried with and without do-not-mail/deceased criteria. Seems to work OK if I select a couple of fields, but if I do ...
0
votes
2answers
82 views

Why am I getting “Column not found: 1054 Unknown column 'civicrm_activity.source_contact_id' in 'field list'” on Activity View after upgrade to 4.6.7?

For the past few upgrades I've needed to apply a fix for activity views detailed here: https://forum.civicrm.org/index.php?topic=33513.0 Today I upgraded to 4.6.7 and got the same error, but when I ...
1
vote
1answer
96 views

Contribution import fails for all records with error “No matching Contact found”

I successfully imported contributions from csv files, up to 4.6.3. Now when I try to import using the same saved mapping, in Joomla with 4.6.6, every record fails with the error No matching Contact ...
2
votes
2answers
166 views

Why unexpected attached files are loaded in all mailings by default?

We upgrade recently from 4.5.8 to 4.6.6 on four of our CiviCRM instances. In one of the instances ocurrs something very strange and compromising. When we create a new mailing, in the attachment tab ...
4
votes
2answers
72 views

How do I recover CiviGrant Component?

I disabled, and re-enabled CiviGrant and now I can no longer access it. I tried to rebuild the menus and actually reproduced this on the demo site: Its not just the Grant and Grant Admin menus. if i ...
3
votes
1answer
277 views

Why do Smart Groups now give database errors?

I just updated from 4.6.3 to 4.6.5, on Joomla. I have a number of Smart Groups which worked fine before, but now inconsistently fail to load contacts or settings, giving a database error instead. ...
2
votes
1answer
233 views

CiviMail tracked URLs give “Missing input parameters” from /extern/url.php

Any mailing that I send through CiviMail converts URLs to links in the form of: http://mysite.org/sites/all/modules/civicrm/extern/url.php?u=193&qid=52 But when I visit this URL I get a white ...
1
vote
1answer
60 views

Search builder operators do not work for Preferred Communication Method

You can reproduce this yourself on the demo site: Search Builder > Contacts > Preferred Communication Method = Phone Returns the exact same results as Search Builder > Contacts > ...
3
votes
2answers
55 views

Is there a bug when placing a token inside quotation marks in CiviMail 4.6.2+?

I have a mailing template with this snippet: Trouble seeing this email? <a href="{mailing.viewUrl}">Read in your browser</a>. In previous versions of CiviCRM, the token would render ...
3
votes
0answers
145 views

Recurring Membership Price Set payments don't show after first payment

We have three different membership types configured in a price-set along with an option to add additional contributions. When someone subscribes for membership, they subscribe to all three membership ...
5
votes
2answers
216 views

What should I do if an issue is marked as fixed in JIRA but it is still occurring?

What should I do if an issue is marked as fixed in JIRA for a particular version, but it is still occurring in a later version?