Questions tagged [php7]

Questions relating specifically to running CiviCRM on PHP 7.

Filter by
Sorted by
Tagged with
2
votes
1answer
25 views

Ajax error with Manage Groups after upgrading to PHP 7.3, MySQL 8.0 and 5.22.0

I may have done too many upgrades at once but I was really eager to upgrade my environment following the release of Civi 5.22.0. I started out with upgrading my Civi Wordpress environment from 5.21.0 ...
1
vote
1answer
18 views

DB Error: constraint violation (WordPress)

I am trying to update an install from CiviCRM version 4.4.5 to the current version. I was unable to because the WordPress site was using PHP 5.6. So I installed CiviCRM 4.7.31, and then updated the ...
2
votes
1answer
26 views

failed to open stream after PHP upgrade to 7.3

Started getting this error on some Civi pages after upgrading PHP to 7.3 on server running php-fpm and nginx. Works fine after restarting php-fpm but need to restart every morning to get around ...
1
vote
1answer
43 views

Is PHP 7.4 fully supported?

We've just updated to PHP7.4 and it seems to be working ok, but without extensive testing it is hard to know. PHP 7.4 is not even listed on the requirements and compatibility page.
1
vote
1answer
96 views

Upgrade to civicrm 5.17.4 fails with PHP 7.1 Uncaught Error: [] operator not supported for strings

Testing an upgrade from 5.13.4 to 5.17.4 on wordpress, I get a fatal error. This is on PHP 7.1.32. PHP Fatal error: Uncaught Error: [] operator not supported for strings in /home/dhwpuser/testdomain/...
2
votes
1answer
92 views

mailchimp extension error, php 7.1, civi 5.10.4, drupal 7.x

with civi 5.10.4, Drupal 7.x and php 7.1 there is a warning that in some cases turns into a fatal error that will prevent the webhooks from working Declaration of CRM_Mailchimp_Permission::check($...
3
votes
1answer
78 views

Label Format does not fit in database - PHP 7.1 json_encode() and serialize_precision

I am encountering this error when attempting to define a new label format, "Sorry an error occurred", "Label Format does not fit in database.". This is on CiviCRM 5.8.1 on Joomla 3.9.1. I can't ...
6
votes
1answer
238 views

Is it OK to switch to PHP 7.2 now that Drupal 7.6.1 supports it?

Drual 7.61 was released a few days ago and I notice now "fully supports PHP 7.2". So, can we move to PHP 7.2 for CiviCRM where it runs with Drupal 7.61? I've updated a couple of my Civi sites to ...
1
vote
0answers
14 views

Import contacts missing button

Under Contacts --> Import contacts the button is missing to select which type of contacts should be imported as csv.it should look like this
4
votes
3answers
130 views

Will there be a LTS release of CiviCRM 4.6.x that supports PHP 7+

If an organization is currently heavily invested into customizations built for CiviCRM 4.6 LTS, is it possible for them to continue using the LTS version of CiviCRM when PHP 5.6 EOL? (31 Dec 2018) and ...
1
vote
0answers
44 views

Migrate Jooomla installation to new server

Having a terrible time when changing server and updating Joomla and Civicrm. Apologize for the length of this post, but thought is would be helpful to anyone who can address my issues. Here's the ...
1
vote
2answers
632 views

Email not working after upgrade to PHP 7.0

WordPress 4.9.2 CiviCRM 4.7.29 I'm trying to upgrade to PHP 7 from 5.5, but CiviCRM mailer stops working. The Send test email results in: To verify the email settings I used Easy WP SMTP And it is ...
0
votes
1answer
89 views

Fatal error when accessing Civicrm administrator page

I am unable to access the Civi administrator section on a website using Joomla 3.7.5, Civi 4.7.23 and running on PhP 7.0. Joomla portion works fine, but when I access Components/Civicrm from the ...
2
votes
0answers
199 views

500 Error on install

I'm having issues just getting CiviCRM installed. This is a Drupal 7.55 install. I got as far as installing CiviCRM as a module but the next step is to go to the install/index.php file and that is ...
3
votes
1answer
145 views

Need help upgrading 4.4.5 to 4.7.18 0n Ubuntu 16.04 server with PHP 7 on Drupal 7

The VPS host running Drupal/CiviCRM was upgraded from Ubuntu 14 LTS to 16 LTS. That ran without error. However, that upgrade came with PHP7. immediately after the upgrade all three CiviCRM sites ...
2
votes
2answers
85 views

Buildkit Site fails to load due to PHP ugrade from 5 to 7

After Upgrading from php 5.6 to php 7, when i try to access the sites created using buildkit, I am unable to access it. After typing Civibuild show dmaster I get the following ERROR: Failed ...
1
vote
1answer
814 views

Call to undefined function dl() error w/Joomla 3.5.1 & PHP 7

I've just installed CiviCRM on a Joomla 3.5.1 site to learn how to use it. I am seeing an issue that I have a question about. As long as I use Php 5.6 the installation works properly. If I try to ...
5
votes
1answer
2k views

Unexpected T_CLONE, expecting T_STRING (PHP 7, Drupal 7, Ubuntu 16.04)

On an Ubuntu 16.04 VM with PHP 7.x, I am seeing the following error when enabling CiviCRM in Drupal 7: ParseError: syntax error, unexpected 'clone' (T_CLONE), expecting identifier (T_STRING) or '(' ...
6
votes
2answers
257 views

What are the minimum and recommended changes to CiviCRM to support PHP 7?

To pragmatically help CiviCRM step-by-step to support PHP7 I would like to know what the minimum and recommended changes to CiviCRM to support PHP 7? This will help developers to identify areas of ...
4
votes
2answers
641 views

Is CiviCRM 4.6.x compatible with PHP 7?

Is CiviCRM 4.6.x compatible with newer version of PHP, 7?