Skip to main content
The 2024 Developer Survey results are live! See the results

Questions tagged [php8]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
22 views

Searchkit webpage encountered an unexpected error after CiviCrm upgrade

I've upgraded my environment from Drupal 10.2.0 & CiviCRM 5.69.4 to Drupal 10.2.6 & CiviCRM 5.73.3 (PHP v8.3.7) But since that upgrade the searchkit (overview) page is broken, however (most ...
Paul Van Leemput's user avatar
0 votes
1 answer
27 views

Steps to create a development Joomla environment

Our live CIVICRM environment is CiviCRM 5.67.1, Joomla 4.4.2, PHP 8.1, hosted on Siteground. We are in the process of trying to replicate our live site to a development site where we can configure and ...
Margaret's user avatar
  • 121
1 vote
1 answer
155 views

cron breaks after upgrade 5.69.4 - php 8.2 (deprecated for ${var} in dp.php)

on our staging environment we upgraded to Drupal 10.2.0 - CiviCRM 5.69.4 - PHP 8.2.15 On the Plesk server for the domain there is a scheduled (cron) job created as: script path = httpdocs/vendor/bin/...
Paul Van Leemput's user avatar
1 vote
1 answer
35 views

CiviCRM Spark updates fail due to lack of read permissions on directory

I am using CiviCRM Spark. I don't believe I can change permissions on directories (?). These are the errors: Error: Your extensions directory (/var/aegir/platforms/civicrm-d7/web/sites/atcni.civicrm....
ATCNI's user avatar
  • 11
0 votes
3 answers
96 views

Upgrade To PHP 8.1 Prevented By WordPress CiviCRM Plugin

WordPress v6.4.2 CiviCRM v5.68.0 My hosting provider stated, "The issue with [my website] is caused due to the plugin civicrm. It seems that the version of the plugin is not fully compatible with ...
Paul Williams's user avatar
0 votes
1 answer
36 views

I am trying to install CiviCRM to a Wordpress multisite, and getting an error Uncaught TypeError: method_exists()

I have been following the instructions for installing to Multisite here: https://docs.civicrm.org/installation/en/latest/multisite/wordpress/ I created a separate civicrm database. I set the CiviCRM ...
Norman Cates's user avatar
4 votes
1 answer
1k views

fatal error "unconstructed IntlDateFormatter" after upgrade to php 8.1

On submitted contribution pages, I get a fatal php error "unconstructed IntlDateFormatter." At first I thought the answer was a simple case of a missing php-intl extension. However, it is ...
kapn's user avatar
  • 921
0 votes
1 answer
161 views

"Warning: Undefined array key" messages on Membership form after upgrade to CiviCRM 5.66.0

We're running CiviCRM 5.66, WordPress 6.3.22, and PHP 8.1. We had our hosting service (CiviHosting) upgrade us to CiviCRM 5.66.0 on Sunday. We last upgraded about a year ago. Yesterday (Wednesday) a ...
Brian Downey's user avatar
1 vote
1 answer
42 views

Search Builder - Undefined array key 'contact_is_deleted

When I run a search using Search Builder i get the error above - also occure when editing a smart group criteria. Using Advanced search does work. The PHP is Selector.tpl.php on lines 113 & 114 ...
Peter Turner's user avatar
0 votes
0 answers
41 views

civiEvent calendar not showing details after php 8.1 upgrade

Running civiCRM 5.66.0 on WP 6.3.2 upgraded to php 8.1 over the weekend. The internal civicEvent calendar no longer displays event titles, or previous events at all. We are also using the Event ...
John Bradford's user avatar
0 votes
2 answers
219 views

guzzle and symfony errors - WordPress

I've been getting a persistent guzzle error since Civi version 5.5x, and I now realise there's also some weird permission error and am wondering if this is related. I'm on the latest versions of ...
Hugh's user avatar
  • 272
1 vote
2 answers
124 views

What's the most stable CMS platform for running CiviCRM on PHP8?

I really like CiviCRM... In many ways its kind of overkill for our small NFP (soon to be RC), but it has enough features to make it a better option than having some ERP built up from scratch. The ...
esl2248's user avatar
  • 11
0 votes
1 answer
99 views

Cron: cli.php does not work in the latest Civicrm

This happens on Civicrm for Joomla. It prevents both upgrading to Php 8 and upgrading to latest Civicrm, as doing any of these stops the cron job. This is what I see with Civicrm 5.49.3: $ php74 ...
Francesco Potortì's user avatar
2 votes
1 answer
115 views

PHP Cannot Find File From Vendor Directory

After upgrading to PHP 8 (8.0.25) my CiviCRM install fails to be able to find /var/www/user/web/vendor/civicrm/civicrm-core/install/langs.php. This happens whenever I try and go to a /admin* page in ...
Drupal Learner's user avatar
4 votes
1 answer
346 views

Problems after updating to PHP 8.1

after updating to PHP 8.1, I have a punch of warning, like: Warning: Undefined array key "pledgeBlock" in /.../wp-content/uploads/civicrm/templates_c/de_DE/%%3D/3D1/3D13F2BA%%Main.tpl.php on ...
Charly's user avatar
  • 41
2 votes
1 answer
20 views

Way to reset search preferences, display preferences when admin page inaccessible?

In Refrence to my related issue how do I re-write the default preferences back to what they were when first CiviCRM was installed? Admin screen no longer accessible after search preferences changes.. ...
Eldon Leeburstroghm Allison II's user avatar
2 votes
2 answers
709 views

Is -TypeError: array_flip(): Argument #1 must be of type array, string given- a php 8, Drupal 9, civicrm 5.55.2 or all combined Issue?

PHP 8 TypeError I encountered when making adjustments to the search preferences, unchecking not needed fields and checking new custom fields. no autocomplete drop down anymore and when I TRY to go ...
Eldon Leeburstroghm Allison II's user avatar
5 votes
1 answer
493 views

CiviCRM support for PHP 8.1?

Drupal 9 has now deprecated PHP 7.4. CiviCRM gives lots of deprecated and warning messages under PHP 8.1. It is possible to suppress them by adding // PHP 8.1 generates lots of warnings that 7.4 does ...
Stephen Palmstrom's user avatar
2 votes
1 answer
352 views

Smarty templating and PHP8 warnings

Wondering if anyone had any ideas about modifiying the Smarty so that it automatically handles null values being passed in as variables in the templates? These notices being elevated to Warnings in ...
Jonny Toomey's user avatar
0 votes
1 answer
97 views

I am getting the error '/packages/DB/common.php on line 265' when implementing PHP 8.0

I want to switch to 8.0 as PHP 7.4 is now giving warnings. But, I am getting the error 'com_civicrm/civicrm/packages/DB/common.php on line 265' when implementing PHP 8.0. Code written in the relevant ...
Fatih ATEŞ's user avatar