Questions tagged [settings]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
58 views

"The CiviCRM public extensions directory at could not be contacted" -- why is my repo URL empty in the browser but not in `cv`?

Question: What could be causing the ext_repo_url setting value to be empty when running in the browser, though it appears to be correct when running in cv? Under civicrm 5.35.2, if I visit the ...
user avatar
  • 1,672
1 vote
1 answer
36 views

How to update "wpLoadPhp" setting for CiviCRM WordPress when moving/migrating installation?

On my Civi WordPress multisite installation, I just discovered that there is a wpLoadPhp setting in the CiviCRM settings for each Civi domain that contains the absolute filesystem path to wp-load.php (...
user avatar
  • 319
1 vote
1 answer
40 views

CiviCRM WordPress uninstall - db issue

Uninstall CiviCRM from WordPress, is creating me a big issue. I needed to uninstall CiviCRM (5.31.1) from a production site, saving all theme and others settings. CiviCRM went away without uninstall ...
user avatar
1 vote
0 answers
37 views

CiviVolunteer New Project issues

I have CiviCRM 5.34 CiviVolunteer 2.4.1 and Angular Profiles 4.7.31-1.1.1 on Wordpress 5.6.1 I am logged in as the Admin. I have freshly installed and set up. I try to create a new project and the ...
user avatar
0 votes
1 answer
121 views

How to get Views to work in CiviCRM on Drupal9 with separate CiviCRM database

On based the answers on this question How to get CiviCRM Views to work in Drupal 8 with separate CiviCRM database I'm trying to get work Views on Drupal9. Drupal9 and CiviCRM has different databases, ...
user avatar
0 votes
1 answer
175 views

Wordpress base page error

I need help with base pages for wordpress. I am getting a civicrm system error: CiviCRM relies upon a base page in WordPress, but it is not published. On the setting page, there is the text: By ...
user avatar
  • 740
2 votes
2 answers
81 views

A Couple of Questions from a Newbie

I apologize ahead of time, I was brought on to fix a company's website, but they asked me to do their CiviCRM. Instead, I've never done this, nor have I ever heard of it before this. They have a few ...
user avatar
1 vote
2 answers
44 views

Some checkbox settings not applying

When I change some Civi settings they do not get applied. It seems to be only when deselecting some checkboxes. For example, in Custom Fields I deselect: Collapse this set on initial display. It looks ...
user avatar
  • 353
2 votes
1 answer
28 views

CiviContribute Component Settings not saving settings beyond Enable Tax and Invoicing option

I am setting up a fresh install (CiviCRM 5.24.5 / WordPress 5.4.1) but found that once I 'Enable Tax and Invoicing' within CiviContribute Component Settings no changes are saved on that page (I am ...
user avatar
0 votes
1 answer
35 views

What are typical drupal 7 absolute resource URLs?

As the question says - what are the typical drupal absolute resource urls? Is it: CiviCRM Resource URL https://example.org/sites/all/modules/civicrm/ Image Upload URL https://example.org/sites/...
user avatar
  • 3,155
1 vote
0 answers
42 views

Civi Navigation Menu disappeared on upgrade form 5.20 to 5.24.2

Upgrade of this drupal site appeared to go smoothly, but the navigation menu was missing. I reset menus & backend, cleared caches etc, switched asset caching off. Civi log showed nothing, nor did ...
user avatar
  • 533
0 votes
2 answers
326 views

How to fix stripe webhook settings?

I am on civi 5.16.3, drupal 7.X and stripe 5.4.1 and when setting up stripe webhook, keep receiving this message. how can I fix it please? Thanks
user avatar
  • 2,846
1 vote
1 answer
43 views

Can CiviCRM be managed as a group of companies, where there is a parent company of the group of child companies?

An example of this Group of Financial Companies, which is the Parent company, then below it, are the other daughter companies, but that each one is granted their independent clients and their ...
user avatar
0 votes
1 answer
42 views

How can I include Employer in display name?

I have tried this but doesn't work. Can anyone suggest a correct token format please? Thanks {contact.first_name}{ }{contact.last_name}{ }{contact.current_employer}
user avatar
  • 2,846
4 votes
1 answer
75 views

Beyond provide a profile of an instance's stack, what is the purpose of Connections?

I am seeking information about the Connections admin area (Administer>System Settings>Connections): I have seen in one instance that there is something that can be set up here to generate a site ...
user avatar
  • 454
0 votes
1 answer
45 views

Address Settings missing

Not sure what happened. The image below shows a blank page when I open Address Settings from the Localization menu.
user avatar
3 votes
2 answers
58 views

Extension settings lost on upgrade - known issue?

On a couple of my own extensions and some that are not my own, I've seen that the extension settings go missing immediately upon upgrading the extension. These extensions all define settings metadata ...
user avatar
  • 1,672
3 votes
3 answers
124 views

Should I use Civi::settings()->get and set or

In this post on StackExchange How do I add a new settings page for my extension? the way to create settings in CiviCRM is stated as : Create a settings dir in your extension's base directory, and ...
user avatar
2 votes
3 answers
67 views

Override CiviCRM settings

I want to override my CiviCRM settings. I am new with CiviCRM and I don't know where to put the line referenced in the attached image. Thanks in advance.
user avatar
0 votes
1 answer
20 views

I got this error after I override the civicrm.settings.php

I got this error after I add this line $civicrm_setting['Directory Preferences']['customFileUploadDir'] = '/var/www/testing/sites/default/files/civicrm/upload'; on civicrm.settings.php
user avatar
0 votes
1 answer
160 views

How to Modify CiviCRM settings file

How can I modify the CiviCRM settings file so that the CiviCRM extension directory is set using settings files variables. Thanks!
user avatar
1 vote
3 answers
137 views

One host, multiple Wordpress domains, one CiviCRM database

We want to use CiviCRM on one host which has several domains each with their own Wordpress installation. The CiviCRM database is located on the same host. I have looked at: https://wiki.civicrm.org/...
user avatar
3 votes
1 answer
111 views

how to change civicrm settings from command line?

There are some common settings to change for dev sites at mycivi.localhost/civicrm/admin/setting/debug. How can those be changed from the command line? A better answer for the question How should I ...
user avatar
  • 407
0 votes
1 answer
22 views

Settings Definition (How to Use On_Change?)

Settings definitions allows for a field "on_change". Can anyone explain how to use this? I would like to have it execute a function that I have defined in my extension when my quickform is saved. ...
user avatar
  • 1,146
0 votes
1 answer
43 views

Localization and Address settings disappeared after domain change

We recently changed a site url. After the URL change and making changes in the settings file there was an issue loading so I cleared the cache and reset the paths. Everything came back OK except all ...
user avatar
  • 2,299
1 vote
0 answers
14 views

Mailer Settings - Method Not Implemented

The mailer settings page does not display. Method Not Implemented GET to /fun/wp-admin/admin.php not supported. Additionally, a 501 Method Not Implemented error was encountered while trying to use an ...
user avatar
2 votes
3 answers
2k views

Fix For "Incorrect Resource URL" Not Working

I am getting the error "Incorrect Resource URL" and seeing 404 for URLs that go to "undefinedjs/jquery/jquery.crmAjaxTable.js" and many instances of the error "Unable to reach the server. Please ...
user avatar
  • 803
3 votes
1 answer
257 views

4.7.28 upgrade gives false warning that my resource URL is not correct

when I upgraded a client's staging site to 4.7.28, which added in a check to verify the resource url setting, we started getting a warning that the site's resource url was incorrect. However, the ...
user avatar
  • 590
1 vote
0 answers
27 views

Outgoing SMTP Username reverts

After having filled in all setting for outgoing SMTP (using gmail) I fail to send email. The error from GMail says that the settings are incorrect (most likely). And indeed, even when I set my GMail ...
user avatar
  • 131
1 vote
1 answer
419 views

Localization Settings DB Error: insufficient permissions

Civicrm 4.7.24 Drupal 7 EC2 Server Amazon RDS DB Hey guys I am trying to set the localization settings in my CIVICRM instance but whenever I go to civicrm/admin/setting/localization?reset=1 I get ...
user avatar
1 vote
1 answer
108 views

CiviCRM backup query

I want to make a weekly/fortnight backup of CiviCRM running on Wordpress. Two things I need to do: Backup on same machine Replicate the database on another machine. Looking for simple steps to ...
user avatar
1 vote
1 answer
622 views

timezone in PHP is incorrect

Facing this warning Timestamps reported by MySQL (eg "2017-07-20 13:48") and PHP (eg "2017-07-20 08:18" ) are mismatched. While MySql time matches with my local time. PHP is running 5:30 hrs less. My ...
user avatar
2 votes
1 answer
46 views

configuring SMTP on windows 7 for Civicrm

I am running CiviCRM 4.7.20 on Windows 7, Wordpress. CiviCRM will be accessible only in our LAN network. Want to use the mail functionalities. Got stuck with the email configuration. Bit confused with ...
user avatar
0 votes
2 answers
59 views

Couldnt see Civicrm plugin when logged in as wordpress subscriber/editor and other roles

I created different users for my wordpress page. When logged in as Administrator , I am able to access CiviCRM, but when logged in as subscriber or editor or other roles, I am not able to view civicrm ...
user avatar
2 votes
1 answer
37 views

prompted for password too often

I am trying to run civicrm in my machine and access it through LAN from other machines. So I made a change in word press general settings like below: WordPress Address (URL) http://myipaddress/...
user avatar
0 votes
1 answer
28 views

accessing civicrm in lan [duplicate]

I am running Civicrm wordpress in my PC and I want to access it through LAN. When I am trying to run the site from other machines using http://myipaddress/site, the login page opens fine. but in the ...
user avatar
2 votes
1 answer
89 views

Has the Dashboard Cache Timeout setting been moved?

I can't seem to find the Dashboard Cache Timeout setting, which according to my experience and documentation can be adjusted by visiting Administer > System Settings > Misc and editing Dashboard ...
user avatar
  • 1,672
1 vote
1 answer
40 views

Adding settings with form to my extension - what am I missing?

I would like to add a settings form to a new extension to hold some extension-specific settings. I've put together the extension and form using civix, and am testing in civiCRM 4.7.17 on local MAMP. ...
user avatar
  • 1,489
3 votes
1 answer
94 views

Is there any reason to not run the scheduled job Clean-up Temporary Data and Files every hour?

I discovered some problems with Smart Groups that use IN search criteria for custom fields not showing counts. I have the scheduled job Rebuild Smart Group Cache running. However, only after running ...
user avatar
1 vote
5 answers
168 views

Settings - Outbound Mail are not saved

please help, I have a Joomla 3.6.5 and CiviCRM 4.7.14 I just migrated from the dev site to the live site, and now when I check the Outbound Mail settings in CiviCRM, they are empty. Everytime I fill ...
user avatar
  • 55
0 votes
1 answer
194 views

Using a Variable/Token for Config Directories to Get Site Root Path

I am using Drupal 7 with CiviCRM 4.7.12. When setting the Directories for CiviCRM... I know you can use [civicrm.files] and [civicrm.root] to get file system paths. However, I have my extensions, ...
user avatar
  • 1,146
2 votes
1 answer
59 views

CiviCRM Installer Errors - Can't change DB settings

I can't get past the install page (/wp-admin/admin.php?page=civicrm-install). The installer prepopulates to my WordPress DB settings and won't take the CiviCRM DB settings I put in. I input the MySQL ...
user avatar
  • 23
2 votes
7 answers
137 views

Do I need to know Linux to administer CiviCRM?

Do I need to know Linux to administer CiviCRM? This is not a rhetorical question :) . And it's a question I wish I had asked three and a half years ago. My answer now, to my self of three and half a ...
user avatar
1 vote
1 answer
259 views

regen.sh - Call to undefined function db_query()

So I was following this doc to add a new setting which asked me to run bin/regen.sh script. But running the script failed with the following error: PHP Fatal error: Call to undefined function ...
user avatar
0 votes
1 answer
59 views

How to add a field on Date Formats setting form?

I want to add a field under Localization > Date Formats. What is the correct procedure to do this? This is what I tried. I added an entry in Localization.settings.php, CRM/Admin/Form/Setting.php'...
user avatar
0 votes
1 answer
62 views

Settings - Date Preferences - mailing - start offset, end offset (what do they mean?)

Please can someone explain what the start offset and end offset fields mean in Settings - Date Preferences - mailing. The default values are 0 and 1 respectively. I feel it should understand this, but ...
user avatar
  • 1,222
3 votes
2 answers
181 views

Why can't I access option groups?

Drupal 7 Civicrm 4.74 Receiving this error: API permission check failed for Case/getcount call; insufficient permission: require Array CiviCRM_API3_Exception: "API permission check failed for Case/...
user avatar
2 votes
1 answer
124 views

Connecting Civi to a previous install's database

During my update from Civi 4.2 to 4.7 I let it fill in database information that was not correct it connected to the cms database and not the Civi database from the previous install. Is there a file I ...
user avatar
1 vote
1 answer
80 views

Settings values not showing up. Cache issue?

I am experiencing a strange issue with my CiviCRM (4.7.3) installation on Joomla (3.4.8) with MySQLi 5.6.28-76.1-log and PHP 5.6.18. If I change some of the settings in one of the administration ...
user avatar
  • 181
3 votes
3 answers
76 views

Settings values not showing

I am experiencing a strange issue with my CiviCRM (4.7.3) installation on Joomla (3.4.8). If I change some of the settings in one of the administration pages, they are correctly updated on the ...
user avatar
  • 181