Questions tagged [smarty3]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
31 views

date_format no longer works with Smarty 3 in messages

Since I enabled Smarty 3 under CiviCRM 5.72, the messages containing dates followed by the |date_format:"%e/%m/%Y" modifier cause next error message to occur: There has been a critical ...
Pierre François's user avatar
1 vote
1 answer
42 views

CiviCRM 5.69.x Smarty3 errors

When updating to ESR 5.69.x, we are running into errors with Smarty3 when updating the smarty path in civicrm.settings.php: define('CIVICRM_SMARTY3_AUTOLOAD_PATH', '/var/www/example.com/sites/all/...
Chipleh's user avatar
  • 21
0 votes
1 answer
43 views

Error-Message after update Smarty v2 => Smarty v3 (CiciCRM 5.71.1, Joomla)

following the instructions on the CiviCRM status page, I have added this code in civicrm.settings.php to update on Sparty v2 to v3: define('CIVICRM_SMARTY_AUTOLOAD_PATH', '/var/www/vhosts/mywebsite....
Zenon's user avatar
  • 31
0 votes
1 answer
120 views

Smarty error after upgrading civicrm from 5.69.4 to 5.70.0

I'm still using smarty 2, PHP 7.4, drupal 7.99 (note: I have a test site for php 8 and smarty 3 and there are problems with both) After upgrading from civicrm 5.69.4 to 5.70.0 getting the following ...
Sophie Miron's user avatar
1 vote
2 answers
121 views

Fatal error - unable to register for events with Smarty3 enabled

I've just taken a live site to CiviCRM 5.69.2 (as well as from Drupal 7 to 10!), and have determined that registrations fail completely with Smarty3 enabled. Clearly this has passed testing elsewhere, ...
AlexT's user avatar
  • 81
1 vote
0 answers
65 views

Smarty 3: Unable to load template 'file:CRM/Airmail/Form/Airmail/Settings.tpl' in 'file:CRM/Form/default.tpl'

Drupal 7, CiviCRM 5.69.2, PHP 7.4, Smarty 3. After civix upgrade run on some extensions (Airmail, Sendgrid) got two identical messages on the respective Settings URL/page: Unable to load template '...
yurg's user avatar
  • 2,005
1 vote
0 answers
80 views

Smarty3 you say?

Switched it on with Drupal 10.2.2 and CiviCRM 5.69.2. being an obedient kid. Got some deprecations so far. Deprecated function: Creation of dynamic property Smarty_Internal_Extension_Handler::$...
yurg's user avatar
  • 2,005