Questions tagged [update]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
0answers
16 views

Update sequence for verrry old versions of CiviCRM, Wordpress and PHP

I'm tasked with updating an old installation of CiviCRM for another org - they have CiviCRM 4.6.3 and WordPress 4.5.18 running on a shared server that's on PHP 5.4. I don't yet know if it'll be ...
2
votes
1answer
29 views

CIVICRM Update to 5.13.5 triggers 'CiviCRM requires PHP 7.0.0' on PHP56

I am trying to move a CIVICRM installation up to the 'last' PHP56 supported release which I believe its 5.13.5 however it triggers the PHP7 check expected from 5.14 onwards? So after running: drush ...
0
votes
0answers
21 views

“CiviCRM Update Check” triggering cron warning message

CiviCRM 5.16.0 Worpress 5.2.2 Cron jobs are all running as scheduled, but for the last week or so, I've gotten the following warning from cron: Warning: file_get_contents(https://latest.civicrm....
1
vote
1answer
67 views

SQL upgrade fails on 5.14.2 to 5.15.0 on Joomla

In upgrading from civi 5.14.2 to 5.15.0, the SQL update fails. In civi log, I get: Jul 08 09:48:13 [info] Running task: Cleanup old files Jul 08 09:48:13 [info] Running task: Checking extensions ...
0
votes
0answers
30 views

Joomla 3.9.6 - Civicrm 5.12.2 to 5.13.4 failed

I have just attempted to update to 5.13.4 and at an early stage of process it stalled and now whilst I can still access Joomla backend but the Civicrm has failed. On clicking civi now get this warning ...
2
votes
0answers
26 views

Updating Contribution payment instrument based on Financial Trxn payment instrument when there are multiple transactions

I have a task where I need to clean up payment instrument data. The basic problem was caused by a custom payment instrument of TBD, which is somehow preventing contributions from updating correctly, ...
1
vote
1answer
48 views

CiviCRM Security Patch Needed warning still exists from older Civicrm Version?

I've moved a CiviCRM installtation from 5.7.3 (LTS) up to 5.10.4 *latest. However CiviCRM still gives the 'Security Patch Needed warning' which displayed when it was on 5.7.3. Database updates, ...
1
vote
1answer
39 views

How to install CiviCRM patch (5.7.2 to 5.7.5) on Drupal 7.64 - is my file directory writeable?

Currently running Drupal 7.64 and got a notification that I need to install a security patch on CiviCRM. Currently running CiviCRM 5.7.2 and need to install 5.7.5. Apologies in advance if this ...
2
votes
2answers
51 views

After update, emails have to be written out in full html!

We updated CiviCRM and the next time I tried to email a contact, I found all the buttons to insert bold, hyperlinks etc. had disappeared and the only option seemed to type it all in manually, even ...
1
vote
2answers
73 views

DB Error: constraint violation on anonymous user contribution/membership registration after 5.8.2 -> 5.9.0 update

I upgraded two Joomla sites from 5.8.x to 5.9 and one of them now gives an error for anonymous contributions or membership registrations: Error: Database Error Code: Cannot add or update a child row:...
3
votes
1answer
70 views

Unable to create InnoDB tables. MySQL InnoDB support is required for CiviCRM but is either not available or not enabled in this MySQL database server

I'm trying to install an old CiviCRM version on Drupal 6, the purpose is to migrate an old database data to the latest CiviCRM version, but I'm getting this error when I try to install CiviCRM in a ...
0
votes
1answer
41 views

Database update failing for CiviCRM upgrade in Joomla 2.5

I have installed Civi 4.2.19 in Joomla 2.5, to upgrade the 4.1.1 version. I cleared all cache and then tried to run the database update. I got this fatal error: Fatal error: require_once(): Failed ...
2
votes
1answer
111 views

Multilingual instances show 'no such field' errors after update

I'm not sure if this is the forum where you want this issue raised, or whether Mattermost or a bug report is best, but here goes. Please let me know if I should be raising this elsewhere. A ...
0
votes
1answer
18 views

Update Indices fails on 4.7.29

With successful update from 4.7.25 to 4.7.29 there is a Performance warning: Missing Indices in CiviCRM System Status. When I click the Update Indices button, the error appears Operation failed: ...
0
votes
2answers
93 views

Can I export full database and import it in a fresh newer CiviCRM version?

I am experiencing difficulties during CiviCRM upgrade from 4.7.14 to 4.7.31 or 5.1, namely, fields like contact.birth_date get broken. (More: DB Error after upgrading 4.7.x to 5.1 (Drupal)) I have ...
1
vote
2answers
107 views

How to update Drupal for CiviCRM?

Quick question - is there anything in particular to take into consideration when upgrading Drupal, if it is used as a platform for CiviCRM? Or can I just go ahead with Drupal update as if there was ...
0
votes
2answers
110 views

GDPR - updating preferences / forgetme

Wordpress 4.9.5 / CiviCRM 4.7.31 / GDPR extension 2.1 How do I pass tokens to the GDPR communications preference page (using Veda's extension)? I've got the Communications Preference link working (...
0
votes
1answer
85 views

Civi Updating, 5.0

I tried to work on my database when I got a DB Error: no such field. I can't access my contacts at all. I can search for them, they appear and everything else works. I looked up the error and I found ...
1
vote
1answer
32 views

Unable to run a batch update of contribution soft credits

I created a profile with only two fields: Soft Credit Soft Credit Type I intend to use it to go back into my contributions and assign soft credits to contributions. First I go to Contributions -> ...
2
votes
1answer
79 views

DataTables Warning: Cannot view Activities after upgrade to 4.7.28

I cannot view Activities on a Contact's Activities Tab, or my activities on my CiviCRM Dashboard. In both cases I receive the following error: DataTables warning: table id=DataTables_Table_0 - ...
1
vote
1answer
39 views

problem upgrading php

I updated to CiviCRM 4.7.28 (on Wordpress). However, I have not been able to update the PHP to the 5.6 version. In fact, after much searching, I don't seem to be able to come up with the correct way ...
2
votes
0answers
64 views

CiviCRM Update 4.7.27 Operation failed: Update Indices Errno: 150 [duplicate]

I updated my CiviCRM version to 4.7.27 yesterday and got a Performance warning on my system status page that there are some Missing indices. Clicking the 'Update Indices' button doesn't fix the ...
0
votes
2answers
25 views

Updating the Security

I received a notification to update my security but am unsure on how to do this. I've went to my notifications and it didn't say how to proceed. I also looked in my menu options. I'm honestly lost.
2
votes
1answer
34 views

Comparing Duplicate address

I have set of name, addresses, phone number etc in CiviCRM. These are slightly outdated. I have an excel sheet for the same people with their new addresses. I have a unique external identifier for ...
2
votes
0answers
44 views

Missing Civibooking resource config set

I just upgraded CiviCRM to the latest version with Drupal 7 on a duplicate test installation and now when I select a time slot in the "Select Resources (Step 1 or 3)" screen and the pop-up appears, I ...
2
votes
3answers
113 views

Update extension through code

When I update my civi extension simply by changing the codebase to the most recent version (because the most recent version is not showing up in the config options), my extension is broken. I updated ...
2
votes
1answer
56 views

Indices repair stopped by error

I stuck with the error. When I try to repair indices I get error message: CREATE UNIQUE INDEX index_entity_id_entity_table_account_relationship ON civicrm_entity_financial_account (entity_id, ...
2
votes
2answers
68 views

Update script fails: database already upgraded

Trying to update from Wordpress CiviCRM 4.7.11 > 4.7.23. Update script does not work. Keep getting the same message: "Sorry but we are not able to provide this at the moment. Your database has ...
1
vote
2answers
60 views

CRM/Core/Config.php line 41 throwing 500 error with new require_once api/api.php

Just updated our WP install from 4.7.22 to 4.7.23 -- but can't run the db update script, because whenever I rename the 4.7.23 folder to civicrm, I subsequently get 500 internal server errors while ...
2
votes
1answer
297 views

Update 4.7.22 : Operation failed: Update Indices DB Error: already exists

I'm just update to civicrm 4.7.22 on Drupal 7.56. After the update, I received a system status warning "Performance warning: Missing indices". I click to Update Indices and have these error: "...
3
votes
1answer
320 views

How can I fix this problem with duplicate index in 4.7.21?

Upgraded from 4.7.17 to 4.7.21 and got the following message that I don't know how to fix. I don't have drush and the other answers to this problem don't include this index or don't fix this ...
6
votes
4answers
1k views

Status page angular load error

I've just upgraded a test site from 4.7.15 to 4.7.21 on Drupal before going live. The System Status page isn't showing as expected and the console has this log: GET failed for ..../sites/mysite/...
5
votes
1answer
674 views

4.7.20 upgrade — missing indices warning, but index already exists? [duplicate]

Upgraded to 4.7.20 today. As others on this thread have experienced in earlier release(s), I promptly got the "missing indices on some tables" warning. Of course, I tried the "Update Indices" button, ...
1
vote
2answers
42 views

Multi language update to 4.7 does not update Custom Field Sets to be 'is public'

Ran the update script and said it upgraded successfully... however, when running the Wordpress page where my subscription form was, got a No Such Field error... It seems that the ...
2
votes
1answer
27 views

Submit Credit Card payment missing after update

our non-profit uses civiCRM. Recently we updated from version 4.5.5 to 4.7.16 The update caused the an important option to disappear. On the contributions category the option "Submit Credit Card ...
1
vote
2answers
57 views

Clear data from supplemental address on update

When I import cleaned postal data and the supplemental address information has moved to the first line of the address, the supplemental address data does not clear, even if I put a space in the field. ...
5
votes
1answer
135 views

How to reduce database bloat for faster upgrading?

In order to speed up slow upgrades, experienced folk (1 2) recommend reducing the size of the database to facilitate testing. What is the best way to declutter the database?
1
vote
1answer
64 views

Impossible to Run Cron after civicrm-4.7.14-wordpress update

I just update my civicrm-4.7.14-wordpress, and the Cron don't run anymore. Here is the displayed message in the log : [10-Dec-2016 08:15:01 UTC] PHP Fatal error: require_once(): Failed opening ...
2
votes
3answers
101 views

Is there a way to update CiviCRM through the Drupal Admin/Modules panel?

This is getting so frustrating! It is a real PITA to update CiviCRM every single time there is an update. We use several extensions. According to the documentation, I have to disable each ...
0
votes
1answer
56 views

Update contact's field to empty value

I have updated some contacts and during import there was a mixup in some fields, i.e. an individual's "Website" field was filled with the value of an Organisation's website. I want to set the value ...
1
vote
0answers
51 views

ts() function not define

This issue is related to ts() which is used in JS files and it's not working. The problem is that the system returns an error every time it encounters ts() saying that it is not a function. I have ...
0
votes
2answers
47 views

Civi 4.7.11 Update on Joomla 3.62 with receipts

In addition to some CkEditor issues - I am having issues when trying to print receipts - Thoughts ? @import url(/administrator/components/com_civicrm/civicrm/css/civicrm.css); @import url(/...
5
votes
1answer
375 views

System Status page empty and status remains 'critical' after updating from 4.7.8 to 4.7.11 on Drupal 6

This is a Drual 6 site with internationalization enabled for CiviCRM. There are no extensions installed. Site was updated from 4.7.8 to 4.7.11. After running the db update script, the System Status ...
0
votes
1answer
207 views

How do I perform a security update [duplicate]

When logging on today, I got the following alert: "Jmanage Security Update Required New security release 4.7.11 is available. The site is currently running 4.7.9." What steps do I need to perform to ...
1
vote
1answer
64 views

CKEditor Issue with 4.7.11 install

Run a couple sites using Joomla 3.6.2 and Civi 4.7.10 - Did the upgrade tonight - all went well. One site is having problems with CKEditor and the link tool. Edit link or adding a new link just ...
5
votes
2answers
348 views

How do I update CiviCRM following a security update?

I am getting a warning to update security. It says: New security release 4.7.9 is available. The site is currently running 4.7.3. How do I update it? Thanks. Melissa Brooklyn Commons ...
1
vote
1answer
157 views

Organization/Individual Contact relationship

I'm using CiviCRM as Joomla component Joomla users are not connected to CiviCRM contacts There are Organizations and Individual contacts Each Individual contact belong to Organization (employer) and ...
1
vote
1answer
68 views

After updating civi 4.6.15 to 4.6.16 no access to contacts

After succesfull updating civicrm 4.6.15 to 4.6.16 (files are installed database is updated), I find that access to contactdata in the admin side of my joomla 3.5.1 website has gone. I get a white ...
0
votes
1answer
33 views

Join & Update Notifications

How can you tell if someone joins a mailing list (selects from a checkbox option in custom fields)? How can you tell when someone updates their contact preferences?
1
vote
2answers
44 views

How To Apply Membership Type Update To Existing Records

i have a set of membership records set to expire every two years. So i have a lot of members whose expiry date is set to 2 years. Now i have updated membership type to 1 year expiration. I find that ...