Questions tagged [upgrade]

Questions related to civicrm upgrades or updates

Filter by
Sorted by
Tagged with
0
votes
1answer
11 views

(Fixed) CiviCRM update on Joomla causes existing online registration pages to give 404 errors. What can I do to fix it?

I moved my Joomla based site to another host with better PHP and DB support. Used Akeeba Backup to restore the site, it came up properly. I then upgraded to the latest version of CiviCRM as I now ...
0
votes
1answer
29 views

Upgrade to 5.38.1 seems to loose all my user created reports [closed]

Hi I'm testing upgrading to 5.38.1 and when I install ( even before database upgrade ) all my user created reports seem to have gone. ( user created reports - I means where they go in, copy a report, ...
0
votes
1answer
30 views

CiviCRM database upgrade

I have a Joomla! CiviCRM installation (civi version 5.10.4). This has some functionality issues (reports do not work correctly). I no longer need Joomla! so is there a route to install latest CiviCRM ...
1
vote
1answer
25 views

Drupal 9 View Shows Permission Denied For CiviCRM Tables

I have my Drupal 9 database and my CiviCRM database in two separate databases on the same Amazon MySQL Aurora instance. The setup in our dev environment is identical and is working perfectly. However, ...
0
votes
1answer
25 views

Upgrade Drupal 7 to Drupal 9

I am upgrading Drupal 7 to Drupal 9 and trying to copy over my CiviCRM database. My Drupal 9 install is fresh. I used the instructions at https://docs.civicrm.org/installation/en/latest/drupal8/ to ...
1
vote
1answer
24 views

Upgrade from Drupal 7/ CiviCRM 4.6.38 to Drupal 9 / CiviCRM 5.37.2

Good morning ladies and gentlemen, I would like to upgrade my old installation of CiviCRM on an old system (Drupal 7, CiviCRM 4.6.38 ) to an up to date system like Drupal 9 / CiviCRM 5.37.2. Are there ...
0
votes
1answer
33 views

Corrupt installation during upgrade to 5.37.2 on Joomla 3.9.26

I have run into some trouble trying to upgrade from and old version of Civi to version 5.37.2 on Joomla 3.9.26 running on PHP 7.3.27 and MySql 5.7.32-35. The initial problem was that I could not get ...
3
votes
6answers
160 views

database upgrade script failing: Call to undefined method CRM_Upgrade_Incremental_php_FourOne::getMajorMinor()

I'm trying to upgrade CiviCRM in a Joomla 3.9.26 environment from 5.25.0 to 5.37.0. I ran the file installation, cleared the media/template_c folder, then tried to run the database upgrade script. I ...
0
votes
1answer
26 views

Cannot Require Once When Loading CiviCRM After Drupal Upgrade

I am trying to upgrade to the newest security release of Drupal 8 (8.9.14). After completing the update (Drupal is bootstrapping because the login page works) but CiviCRM stops being able to require ...
2
votes
2answers
24 views

Crypto key has unrecognized type?

After CiviCRM upgrading v5.29 to v5.36, when I run the database update get the following error. I googled "CiviCRM Crypto key has unrecognized type" but did not find anything. Any ...
1
vote
1answer
33 views

Do I have to empty the database of a fresh civicrm install, before I import a dump from another server? (and a question about mysql 5.7 dump ->8.0)

Salut. I am following this wonderful guide https://docs.civicrm.org/sysadmin/en/latest/misc/switch-servers/ in order to migrate civicrm from one server to another (wordpress, external civicrm database)...
1
vote
2answers
67 views

MAJOR ERRORS after civicrm upgraded to 5.35.1 wordpress

I am getting multiple errors since upgrading our civicrm to the latest version. When I try to enable debugging i receive db constraint issues and log file shows: Apr 06 11:54:29 [error] $Fatal Error ...
2
votes
2answers
28 views

URL “civicrm/a/#” breaks the UI

Hello dear colleagues. Yesterday I updated a Drupal 8 site to 5.35.1. Afterwards many of menu URLs become replaced/injected with a "civicrm/a/#" string, for example domain.tld/civicrm/a/#/...
1
vote
0answers
52 views

Contacts->New Email fails when sending to more than one contact after upgrade to 5.35.1 (Wordpress)

Salut. We recently upgraded to Civicrm 5.35.1 (Wordpress). When we try to send Emails to more than one recipient in Contacts->New Email, the operation fails (see screenshot attached). One recipient ...
0
votes
0answers
27 views

Upgrade to 5.35.1. - Events no longer working

I have just upgraded civi to 5.35.1. on my Drupal 7 build but now when I go to 'configure event' I get a whole load of code before the tabs...and then the info/settings page is blank. Please see ...
2
votes
3answers
100 views

Crash in upgrade to 5.35.1 on task core-issue#365 - Add created_date to civicrm_action_schedule

While upgrading several of my sites to 5.35.1 (from 5.28 or later) I experienced a nasty database crash in the step called core-issue#365 - Add created_date to civicrm_action_schedule $Fatal Error ...
0
votes
2answers
72 views

CiviCRM core now includes Flexmailer: how to remove old flexmailer extension?

I have Flexmailer 1.1.1 installed as a "non-core" extension , but since upgrading to 5.35.1 Flexmailer 1.1.2 is included with core. (This probably came in before 5.35.) The extensions page ...
1
vote
1answer
16 views

Error in table state_province for Wales

It seems that a bug must first be reported here before is can be reported as bug. I use version 5.35.0 Joomla, but the error is created in version 5.31.alpha1. In the table the combination '...
1
vote
0answers
40 views

Upgrade from 5.33 to 5.34 failed

Database upgrade from 5.33 to 5.34 on Drupal 7 fails while (I think) updating smtp password. Reverting to the backup works fine, but I can't use the current version. From the log : Mar 01 08:39:03 [...
0
votes
1answer
33 views

Upgrade database URL loops to WP login screen but works on a cloned staging site

Experiencing a strange situation where the database upgrade url worked perfectly for a testing site but not for the live site. I successfully tested the upgrade with a cloned staging site without a ...
0
votes
0answers
17 views

Converted to 5.33.2 but got dashboard crash - can't figure

I'm not having any luck with upgrading one install to 5.33.2! Last week it was orphans in a relationship table. This week the conversion ran OK but was unusable with dashboard crashes for some users ...
1
vote
0answers
22 views

5.28 upgrade failed at 5.29 beta upgrade - how to fix? [duplicate]

I started an upgrade from 5.28.3 but it crashed while updating to 5.29 alpha1, and this traceback was in the log. I haven't seen this problem elsewhere on SE, and am not sure how to fix. Can anyone ...
1
vote
1answer
61 views

Utterly useless and unhelpful error message on attempting upgrade to 5.33.1

I have a Wordpress dev site that we want to bring live with lots of new exciting content. The CiviCRM is out of date so I make a staging site and attempt to upgrade that to 5.33.1 from 5.32.2 so ...
0
votes
0answers
46 views

The dispatch policy prohibits event “hook_civicrm_permission” update error in 5.33

The dispatch policy prohibits event "hook_civicrm_permission"." #0 /home/dusa/public_html/sites/all/modules/civicrm/CRM/Utils/Hook.php(167): Civi\Core\CiviEventDispatcher->dispatch(&...
1
vote
2answers
94 views

Wordpress upgrade from 5.16.12 to 5.32.0 fails

Unfortunately my update/upgrade has failed. I've done my best to follow the instructions on this page: https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/ Made it as far as the "...
1
vote
0answers
23 views

WSOD, time lag when creating/copying contribution, event pages

We recently upgraded to WP 5.6, CiviCRM 5.32.1 Since the upgrade, we see this behavior: When trying to create a new contribution or event page, we receive the White Screen of Death (WSOD) and nothing ...
2
votes
1answer
82 views

Having issues updating to civiCRM 5.32.2

So I've downloaded the file to update to civiCRM 5.32.2 and I'm on WordPress 5.6. When I upload the file to the plugins page it tells me that I need to overwrite the other version. Cool no problem. ...
1
vote
1answer
29 views

DB Upgrade/Update Error - no such field, unknown column

We're using CiviCRM 5.31.0 on Joomla 3.9.23. Even with all CiviCRM extensions disabled, we get similar errors like this when doing a DB Upgrade, installing, enabling, and disabling extensions. How do ...
4
votes
2answers
253 views

Older versions?

I'm currently running 5.27 and need to upgrade. I tried upgrading to the latest version and it got stuck. This usually means I need to do smaller upgrade jumps instead of going straight to the latest ...
4
votes
2answers
160 views

Possible Bug? Foreign key constraint error on upgrade to 5.31.0 (populating civicrm_relationship_cache)

I've actually already diagnosed and worked around this problem for myself in a fairly large CiviCRM database within a Wordpress install, but thought I'd refer to those more expert here as to whether ...
0
votes
1answer
46 views

Wordpress - Civicrm 5.16 upgrade to 5.30 issue - Notice: Undefined index query in /wp-content/plugins/civicrm/civicrm.php on line 483

When upgrading our site from Civi 5.16 to the latest 5.30, when I point my browser to run the upgrade at: http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1 I get the ...
1
vote
3answers
71 views

CiviCRM upgrade from 5.12 to 5.29 - failure

Tried to upgrade CiviCRM on Drupal 7 website. Drupal core 7.73. Using PHP 7.1. Upgrade process started well but received this message: You must reload the database with the backup and try the upgrade ...
1
vote
1answer
64 views

Error after upgrading from v5.22.0 to v5.29.1 in WordPress

I have a WordPress website that is using v5.22.0 of CiviCRM, it was a fresh install and this is my first time trying to upgrade it. To upgrade to v5.29.1 I followed all steps to the letter: https://...
2
votes
1answer
107 views

Upgrade db failed for 5:29

I can't upgrade my database schema, I encounter error: Found CiviCRM database version 5.29.alpha1.upgrade. Found CiviCRM code version 5.29.0. Cannot begin upgrade: The database indicates that an ...
1
vote
1answer
42 views

Civicrm update failed - from 5.19.2 to 5.29.0 - Drupal7 error log - page not found

Update failed - Get initial upgrade screen with message template warnings & The database will be upgraded from 5.19.2 to 5.29.0.. ..see screenshot of following page when I click "Upgrade Now&...
0
votes
2answers
36 views

civicrm upgrade access denied

I have upgraded drupal to 7.72 - (28/8/20). I wanted to update Civicrm from 5.9.1 to 5.10.0 but got "Access denied" after running http://mysite/civicrm/upgrade?reset=1. So I tried going to 5....
2
votes
1answer
135 views

Upgrading CiviCRM under Drupal 8: How can I get around this error?

I'm guessing that the upgrade process for CiviCRM under Drupal 8 is something like this: Use composer require to get the latest version of the package. Navigate to the database update URL through the ...
0
votes
0answers
16 views

Where is the documentation to upgrade CiviCRM under Drupal 8?

As of now, there is official documentation for installing CiviCRM under Drupal 8, and there is official documentation for upgrading CiviCRM under various other CMSs, but I can't find any for upgrading ...
0
votes
1answer
46 views

Where can I find CiviCRM 5.26 for WordPress?

I'm stuck in a conundrum, trying to update CiviCRM 5.22.1 to 5.28.3, but the database upgrade fails, possibly related to wordpress 5.5 already being installed, but also possibly due to requiring the ...
0
votes
1answer
51 views

Database upgrade fails updating to CiviCRM 5.22.1 to 5.28.3

We were still running CiviCRM 5.22.1 when Wordpress updated to version 5.5, which broke our donation pages because of changes how wordpress redirects. I updated to CiviCRM 5.28.3, but the database ...
0
votes
0answers
33 views

Issue upgrading civicrm on wordpress

I'm trying to upgrade my actual installation of civicrm to version 5.20.0 on wordpress 5.4.2 I've follow step-by-step the online documentation (https://docs.civicrm.org/sysadmin/en/latest/upgrade/...
0
votes
2answers
70 views

Consistent failure to upgrade from 5.25.0 to 5.28.x

I try to follow https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/ to upgrade from 5.25 to 5.28.n as 5.25 is broken in WP5.5 After the step Point your web browser to the following URL ...
2
votes
1answer
40 views

Upgrade MySQL to v5.7+

I have a message in my installation as follows: "To prepare for CiviCRM v5.34+, please upgrade MySQL. The recommended version will be MySQL v5.7+ or MariaDB v10.1+." My site is hosted on ...
3
votes
1answer
110 views

WordPress 5.5 'breaks' CiviCRM frontend pages without upgrade to 5.26+

The links in our renewal notifications stopped working following the automatic site upgrade to Wordpress 5.5 on Aug 11th. What happened is that the links just arrived at the 'Wordpress Base Page', in ...
0
votes
2answers
68 views

Cannot upgrade past version 5.26.2, why does constant CIVICRM_PLUGIN_URL appear in URLs and paths?

first up, many thanks to all who help out in the Civi community. I tried upgrading from Civi 4.6.38 to 5.28.0 which failed on the queue runner screen (JS errors). In the screenshot you can see that ...
1
vote
1answer
21 views

Queue runner must be configured before execution. When trying to upgrade in wordpress

What is the logic behind that? I can't upgrade, I am just not familiar enough with this codebase... Why is there no queueuRunner in the session public static function instance($qrid) { if (!empty($...
0
votes
1answer
28 views

CiviCRM DB Error: syntax error during upgrade in Wordpress

I have tried upgrading to several different versions (5.14.1 up to 5.28) and every time I run the database upgrade, I get a DB Error: syntax error message and can't figure out why. Here is an extract ...
1
vote
1answer
41 views

Error upgrading database in WP: "Queue runner must be configured before execution

Just upgraded to 5.27.3. Tried to upgrade database, got "Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service ...
1
vote
2answers
57 views

“MySQL server has gone away” error when attempting upgrade to 5.26

I am attempting to upgrade from 5.24 to 5.27 by stepping through 5.25 and 5.26, however I'm getting weird errors at 5.25.0 -> 5.26.x. I attempted to see what happened if I just pushed through to 5....
2
votes
0answers
96 views

Warning: in_array() expects parameter 2 to be array, null given in /civicrm/CRM/Core/BAO/CustomField.php on line 1241

I have started to get this error on a few contribution pages Warning: in_array() expects parameter 2 to be array, null given in /civicrm/CRM/Core/BAO/CustomField.php on line 1241 I think it started ...

1
2 3 4 5
9