Questions tagged [upgrade]

Questions related to civicrm upgrades or updates

57 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
31 views

Why when upgrading civi via drush I always get You are already upgraded to CiviCRM version-I'm-upgrading-from?

I saw a bug out there on this but it's old and claims to be fixed. I keep thinking the next time I do an upgrade, it'll be fixed. So for example: upgrading from 5.9.1 to 5.10.0 drush civicrm-...
4
votes
0answers
252 views

How to use Composer to install and upgrade CiviCRM 4.6.x / Drupal 7

I am building a composer.json file for my project which involves core Drupal, contributed Drupal modules, Drupal related libraries, core CiviCRM. All initialisation of the empty prototype and ...
3
votes
0answers
25 views

Get list of extensions with upgrades available (from command line)

I would like to know if it is possible to use the command-line to get a list of extensions that have upgrades available. I want to then use that to run cvapi extension.download to install the updates. ...
3
votes
1answer
141 views

Directory path problem on 4.7.30 upgrade

On upgrade to 4.7.30 (Joomla) the status message tells me of path problems. For example, that the directories are not writeable or do not exist. When I try to check/set the directories I get ...
2
votes
0answers
50 views

Network Error Related to CiviCase After Recent Upgrade to 5.8.2

I am new here and not an IT person so hopefully I ask this question correctly and with enough detail. We upgraded over the weekend from CiviCRM 4.7 to 5.8.2 (drupal) and each time I login to the ...
2
votes
0answers
39 views

Upgrade to Civicrm 5.5.3 fails

Error message when I run http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1 Does anyone have any ideas? Initialization Error Array ( [callback] => Array ...
2
votes
0answers
13 views

Does the upgrade process perform enough 'clear caches / templates_c' or should it?

We have hit issues after upgrades that require additional "drush cc all" and/or "clear out templates_c" to make me wonder if the upgrade script could be taking care of this better? Would it be ...
2
votes
0answers
120 views

DB Error after upgrading 4.7.x to 5.1 (Drupal)

After upgrading CiviCRM from v4.7.14 to 5.1 (or v4.7.31) which went seemingly well, CiviCRM encounters the following problem. UPDATE: Issue does not appear until 4.7.29 (including), and comes up only ...
2
votes
0answers
46 views

DB Error -1 when upgrading a WordPress based installation from 4.7.20 to 4.7.23

I got the following message when trying to upgrade from 4.7.20 to 4.7.23. Installation is WP-based with 2 languages: Hungarian (primary) and English-US. PHP 5.6.30 is used. [Error: Upgrade DB to 4....
2
votes
0answers
58 views

Exception for each Civi version DB upgrade

After upgrading files from 4.7.18 to 4.7.22, I run the DB upgrade task in: http://domain.com/civicrm/upgrade/ And then after upgrading to each new version (4 new versions) I get an exception, and ...
2
votes
0answers
40 views

Upgrade to 4.5.0 fails

I'm trying to move from 4.4.19 -> 4.6 (Old LTS to new LTS). Having trouble and not sure where to look next. Any suggestions would be appreciated. When I go to the update page /civicrm/upgrade?reset=...
2
votes
0answers
49 views

.htaccess file in custom templates parent folder breaks styling

I'm developing new site using Wordpress 4.3.1 and CiviCRM 4.6.10 - local WAMP development environment. All working fine, however, I have civiCRM setup to correctly load some custom styles and ...
2
votes
0answers
22 views

Upgrade to 4.4 lost WYSIWIG

Just wanted to share here in case anyone else can benefit from my experience. I upgraded my civi drupal installation recently from Civi 4.2.6 to Civi LTS 4.4.19. Somehow the setting for sharing ...
1
vote
0answers
16 views

Warning: in_array() expects parameter 2 to be array, null given in /civicrm/CRM/Core/BAO/CustomField.php on line 1241

I have started to get this error on a few contribution pages Warning: in_array() expects parameter 2 to be array, null given in /civicrm/CRM/Core/BAO/CustomField.php on line 1241 I think it started ...
1
vote
1answer
15 views

500 Error When Migrating To Drupal 8

I have followed the great instructions on the question Can I upgrade a drupal 7 + civi site to drupal 8? but I am running into a road block. The first time I loaded Civi it loaded without my database ...
1
vote
0answers
16 views

CPANEL file usage high, greatest number of files in bower_components ckeditor directory

CiviCRM 4.7.31 WordPress 5.4.1 I am using cPanel on a hosting provider and notice the File Usage is high (file usage is number of files, not space). I checked to see which directories have the ...
1
vote
0answers
12 views

Civi Navigation Menu disappeared on upgrade form 5.20 to 5.24.2

Upgrade of this drupal site appeared to go smoothly, but the navigation menu was missing. I reset menus & backend, cleared caches etc, switched asset caching off. Civi log showed nothing, nor did ...
1
vote
0answers
46 views

Stuck upgrading to 5.24.1 on Joomla

I am stuck at database upgrade. I deleted the cache before (though FTP) as it says and the progressbar is stuck at this: [Executed: Drop column "civicrm_domain.config_backend"] I increased execution ...
1
vote
1answer
43 views

System Status page notifications

After upgrading CiviCRM on Drupal 7 to 5.22.1 (from 5.21), the system status page says: The site is running 5.21.0. Additional patches are available: 5.21.1 (2020-01-10): Fix recent ...
1
vote
0answers
20 views

Civi Upgrade fail - “Could not delete Payment Processor Type”

I'm on Drupal 7.67 and using IATS extension 1.7.0, While attempting to upgrade Civi from 15.17.4 to 5.21.0 the upgrade script gave me "API error: Could not delete payment processor type" My search of ...
1
vote
1answer
104 views

Upgrade to civicrm 5.17.4 fails with PHP 7.1 Uncaught Error: [] operator not supported for strings

Testing an upgrade from 5.13.4 to 5.17.4 on wordpress, I get a fatal error. This is on PHP 7.1.32. PHP Fatal error: Uncaught Error: [] operator not supported for strings in /home/dhwpuser/testdomain/...
1
vote
0answers
34 views

how to import/Export data from old version to updated version of CiviCRM

recently I have updated my CiviCRM Plugin in Wordpress.Now how can I import/export data of the old version to the new version?
1
vote
0answers
14 views

State/Province Field - Searching drop down menu with keyboard

Recently upgraded from 4.6.17 to 5.11. My staff uses the keyboard to search and select from the drop down menu in the "State/Province" field when entering data. Before the upgrade, the keyboard ...
1
vote
0answers
62 views

System Status: Error after upgrade to 5.10.0

I upgraded from 4.4 to 5.10.0 (WordPress). Upgrade seemed to go fine. Now when I go to the home page for CiviCRM, I get a blank page with System Status: Error in the footer (in pink). There are no ...
1
vote
1answer
62 views

Wordpress CiviCRM site unusable after database upgrade from 5.4.0 to 5.5.1

I'm relatively new to CiviCRM and am trying to get a client set up with the platform. I like it overall, it seems much more usable than most I've touched in the past. All seemed to be going well ...
1
vote
0answers
35 views

Error: Cannot read unrecognized property CRM_Core_Config::$mapGeoCoding

I have just upgraded from CiviCRM 4.6 to 5.4.1. We are getting an error on our events pages Cannot read unrecognized property CRM_Core_Config::$mapGeoCoding I have tried to search for a fix, but ...
1
vote
0answers
44 views

Migrate Jooomla installation to new server

Having a terrible time when changing server and updating Joomla and Civicrm. Apologize for the length of this post, but thought is would be helpful to anyone who can address my issues. Here's the ...
1
vote
1answer
51 views

CiviMail report not showing proper data after upgrade

I have recently upgraded CIVICRM to 4.7.27 and my wordpress version is 4.9.1. Before upgrade civimail report was showing proper data for example "Unique Opens", "Total Opens", etc. But now it's ...
1
vote
0answers
48 views

Update Indices fails with errno 150 on DROP INDEX UI_case_contact_id after upgrade from 4.6 to 4.7.27

Upgraded from 4.6.19 to 4.7.27 (on wordpress 4.8.3) and attempted to update indices. The table that fails is civicrm_case_contact, with the old index UI_case_contact_id. The error is identical to ...
1
vote
0answers
63 views

Upgrading issues on Wordpress - Solution

This is for anyone having difficulties upgrading. I spent a LONG time trying to upgrade the Wordpress version 4.4.4 of CiviCRM and had many problems. I tried upgrading in small steps e.g. 4.4.4 > 4....
1
vote
0answers
50 views

Unable to upgrade

I use civicrm 4.7.13 with joomla 3.6.5. I can't upgrade to civicrm 4.7.14. This is the log: 2017-01-04 18:01:43 Access 200 GET /administrator/index.php?option=com_installer HTTP/1.1 .../...
1
vote
0answers
69 views

Database upgrade error - 4.7.13

The process to upgrade my civiCRM database from 4.7.11 to 4.7.13 terminated with the following error: [Error: Upgrade DB to 4.7.13: SQL] Error Field Error Value Type DB_Error Code -19 Message ...
1
vote
0answers
43 views

Data missing after upgrade from CiviCRM 4.4.14 to 4.7.13 (Wordpress)

I followed the instructions of https://wiki.civicrm.org/confluence/display/CRMDOC/Upgrading+CiviCRM+for+Wordpress#UpgradingCiviCRMforWordPress-2.BackupyourCiviCRMdatabaseandsettingsfile/s but ...
1
vote
0answers
38 views

Missing total amount in receipt after civicrm upgrade 4.5 to 4.6

I have upgrade civicrm 4.5 to 4.6. After that token {$formValues.total_amount|crmMoney:$currency} is not printing the total amount in emails. The template used is one of the System workflow messages ...
1
vote
0answers
42 views

CiviEvent DB Error after Update

After update to CiviCRM 4.7.10, now getting a DB Error: syntax error when trying to access CiviEvent registration links. Any ideas would be very helpful. - /home/carolinasgps/www/www/wp-content/...
1
vote
0answers
28 views

BOM readfile issue

Upgrading from 4.4 to 4.6.14 and I'm struggling to correct an issue with BOM being added to contact images. Note that this isn't custom fields, just the image_url that's part of the organizational ...
1
vote
0answers
55 views

Upgrading 4.6.4 to 4.7.7 on Wordpress Queue Runner error

I'm trying to upgrade CiviCRM 4.6.4 to 4.7.7 on Wordpress. Wordpress, MySQL, and PHP are all current. The update stalls and I get this error: Exception: "Queue runner must be configured before ...
1
vote
0answers
59 views

Is anyone else seeing 502 errors with Civicrm 4.7.4.?

We recently updated to 4.7.4 in an attempt to resolve some issues we were facing, in the end we found another fix for that problem. But since the update we have been experiencing 502 Bad Gateway ("...
1
vote
0answers
54 views

CiviCase losing Relationship in Case?

Since upgrading to 4.7.3 on WordPress, some of our Cases seem to be losing a relationship role. They are not linked to the case from the contact record either, even after re-adding them to the case. ...
1
vote
0answers
105 views

4.7 Upgrade issues: invalid value for State on import, country list reverts to US, contact reports produce warning on htmlspecialchars

Upgraded to 4.7 from 4.6.11 today. Importing contacts containing any value for State field results in an error for that field. Tried abbreviations and full values. Entering that info on a contact ...
1
vote
0answers
35 views

Event Register Issue

WP 4.4, PHP 5.5 Upgraded CiviCRM to 4.6.10 and now getting white screen when on final step of event registration - Confirm PHP error shows: Fatal error: Smarty error: [in string:<!DOCTYPE html ...
1
vote
0answers
31 views

Error on Civi upgrade to 4.6.10 on Wordpress

TypeError: CRM.$ is not a functionhttp://mygriefandloss.org/wp/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fupgrade%2Fqueue%2Frunner&reset=1&qrid=CRM_Upgrade line 284
1
vote
0answers
18 views

Upgrading to 4.6 Joomla. Civi Mail can't generate the text editor

Since I upgraded to 4.6 I can't create any Newsletter email anymore. Html Editor is not showing. Please see two images step 1 and step 2 to understand process.
0
votes
0answers
7 views

Receiving Error when performing a Search --> Find Contacts after Upgrade from 4.6 to 4.7.31

I upgraded CiviCRM from 4.6.27 to 4.7.31 on a Drupal 7 site and although everything looks to work fine, I am getting this error message in the Drupal logs when performing a Contact Search or Contact ...
0
votes
0answers
5 views

Error cookie/session after upgrade wordpress

I'm sorry to ask about this problem, but I'm not able to solve. I have upgrade to the last version of wordpress, related plugin and left Civicrm to 5.19.3 and I have the classic problem of the cookie/...
0
votes
0answers
18 views

“The directory sites/default/files exists but is not writable and could not be made writable.” How can I fix this?

I'm on Drupal 7 and attempting to upgrade to Civi 5.25. I followed the steps here to upgrade and now I'm getting this error when attempting to log in as a user on the front end: "The website ...
0
votes
1answer
38 views

database Upgrade URL does not load Upgrade screen

Civi 5.15.1, WP 5.3.2 We are in the process of upgrading Civi from 5.15.1 to 5.21, and are stuck at the "Upgrade the database" step in the upgrade instructions here: https://docs.civicrm.org/sysadmin/...
0
votes
0answers
27 views

Need Help : Civicrm Upgrade!

Currently I am on 4.2.7 & able to run the migrate URL successfully to 4.2.19; However, can someone be able to help me migrate to the latest CiviCRM version or 4.7.23. Looking forward. Thanks.
0
votes
0answers
23 views

Easy way to rollback a CiviCRM upgrade?

We're running CiviCRM on Joomla on an on premises Linux server. Joomla has the wonderful Akeeba Backup that ensures that you can restore the complete website, including CiviCRM. That has saved us a ...
0
votes
0answers
36 views

Error after upgrading to latest CiviCRM version

After upgrading, I see the following message appear: Strict warning: Declaration of DB_common::raiseError() should be compatible with & PEAR::raiseError($message = NULL, $code = NULL, $mode = ...