Questions tagged [upgrade]

Questions related to civicrm upgrades or updates

Filter by
Sorted by
Tagged with
17
votes
7answers
3k views

How to find and/or fix missing indices?

After upgrading to 4.7.19, I'm now getting a warning: You have missing indices on some tables. This may cause poor performance. How can I find which indices are missing and then, how can I create ...
14
votes
3answers
3k views

Is it easy to upgrade CiviCRM using drush?

The standard upgrade process for CiviCRM is quite a complex process according to the instructions in the wiki. Is it easier to use drush to upgrade CiviCRM? If so, how do you do this? I couldn't ...
9
votes
3answers
250 views

Paypal Interruptus - Wordpress w/ CiviCRM 4.7.1

Wordpress 4.4.2 CiviCRM Just upgraded from 4.6.10 to 4.7.1 last week. Ever since we've upgraded, CiviCRM allows payments to be made via PayPal, but event registrations and membership renewals are now ...
6
votes
3answers
418 views

How can I monitor the progress of a slow upgrade?

CiviCRM upgrades can take a long time. What is the best way of seeing where they are up to?
6
votes
5answers
321 views

Events 'missing' after upgrade to 4.7.19

On a civi 4.7.19 / joomla 3.70 installation I have problems accessing events after the 4.7.19 ugrade (events worked OK on 4.7.18/3.7.0). I have current events displaying on the front page via the ...
6
votes
2answers
84 views

Drupal 6 -> Drupal 7 upgrade path

I'm upgrading an installation from Drupal 6.37 to Drupal 7 and also the associated civicrm module(3.3.5). My problem is I'm not sure of a reasonable upgrade path. I've looked through the version ...
6
votes
4answers
639 views

Fatal error: Cannot redeclare _PEAR_call_destructors()

Fatal error: Cannot redeclare _PEAR_call_destructors() (previously declared in /usr/share/php/PEAR.php:735) in /www/htdocs/w010699b/de/wsk/prod/cms-crm/sites/all/modules/civicrm/packages/PEAR.php ...
6
votes
2answers
707 views

cms.root.path error after upgrade to 4.7 (Joomla)

I upgraded two installations of CiviCRM 4.6.11 to 4.7 on the same server. Both upgraded fine, but now have the following errors: 1) Systems Settings --> CMS Database integration shows nothing (no ...
6
votes
1answer
58 views

What is the Path for LTS? 4.7?

We have our production site on 4.6, the current LTS. I'd like to know what the thoughts are on the next version of LTS. Will it eventually be 4.7? Approximately when might that switch happen? If ...
6
votes
1answer
573 views

How do I debug “Could not find valid value for ct” error message

Performed upgrade of Civi 4.4 to 4.6 alongside upgrade of Drupal from version 6 to version 7. The Drupal upgrade went fine, as did the CiviCRM upgrades (i.e. no errors were reported). All dashboards ...
6
votes
4answers
231 views

Mailings - Disabled Next/Test Buttons

New mailings with all required fields and the default responsive template do not enable the Next or Test mailing buttons. As a workaround I can reuse an old mailing and update the fields. The last ...
6
votes
1answer
99 views

Is command-line upgrade broken on CiviCRM 4.7.7?

I just tried upgrading a very vanilla site from 4.7.6 to 4.7.7. I ran drush civicrm-upgrade-db, which has worked previously on this site (which receives every point update - it's our internal CRM ...
6
votes
2answers
46 views

What is the best way to raise awareness of a extension upgrade that breaks core fuctionality, e.g. all the menus went away?

On Friday one of the extensions, summaryfields popped up showing there is an upgrade available. Well, for many, this upgrade causes all the civi menus to go away. So while people should never ever ...
6
votes
1answer
209 views

Database Error When Upgrading 4.6 to 4.7 on Drupal 7

I was running a 4.6 instance of CiviCRM and am attempting to upgrade to 4.7. Every time I initiate an upgrade, things work well until it reaches 4.7alpha stage of the upgrade. Then I get an error that ...
5
votes
5answers
332 views

Why is CiviCRM Upgrade so Complex?

Upgrading CiviCRM is a painful process (18 steps) : Of course, I admit the necessity to previously backup, put the site offline, disable some Modules, ... But deleting all previous civicrm code ...
5
votes
3answers
128 views

What is the recommended upgrade increments to CiviCRM 5.7 from CiviCRM 5.0?

I've done lots of CiviCRM upgrades over the years in Drupal but I've had CiviCRM complain in the past if I skip too many versions so I'm being a little overcautious maybe. I have a Drupal 7 / CiviCRM ...
5
votes
3answers
519 views

Outgoing Mail Settings, CiviSMTP & PHP 5.6.x Problem

After upgrading CiviCRM from 4.3.8 to 4.7.15 on Drupal 7, our outgoing mail is giving an error after sending a test email. I'm on a Debian server running PHP 5.6.x and we use CiviSMTP for our outgoing ...
5
votes
2answers
684 views

Problem fixing missing indexes after upgrade to 4.7

When I run cv ev 'print_r(CRM_Core_BAO_SchemaHandler::getMissingIndices())' I get the following output: Array ( [civicrm_case_contact] => Array ( [0] => Array ...
5
votes
4answers
198 views

How long should a CiviCRM / Drupal upgrade take?

We are running an outdated version of Civicrm (4.2.7) on Drupal 7 and working on upgrading to the newest version of Civi, 4.6x. We have been quoted a full forty hours by a consulting company for the ...
5
votes
2answers
86 views

How to display recent upgrade messages?

Trying to semi-automate my upgrade process by using "drush civicrm-upgrade", but I'm concerned that any critical messages, e.g. that default message templates have changed, won't be displayed in the ...
5
votes
1answer
26 views

Does Drupal's read-only mode module work for Civicrm too?

Drupal 7 has a module, Read Only Mode, which allows your site to be viewed while in maintenance mode. No changes can take place to the database, but viewers can still see your site. This allows you to ...
5
votes
1answer
699 views

4.7.20 upgrade — missing indices warning, but index already exists? [duplicate]

Upgraded to 4.7.20 today. As others on this thread have experienced in earlier release(s), I promptly got the "missing indices on some tables" warning. Of course, I tried the "Update Indices" button, ...
5
votes
1answer
382 views

Can I upgrade a drupal 7 + civi site to drupal 8?

There is maybe a simpler path but this worked for me. Documenting this here since I don't know where else to put it.
5
votes
3answers
330 views

Performance Warning: Missing Indices. Mismatched Index Key

Just upgraded to 4.7.23 and am receiving a Performance Warning: Missing Indices. The warning states: The following tables have an index key with a mismatch in value. Please delete the key ...
5
votes
1answer
66 views

Monitor ConfigAndLog .log file in real time

I am upgrading the CiviCRM and would like to monitor the current .log file that is in <drupal root>/sites/default/files/civicrm/ConfigAndLog/ as it's being updated, in real time. Currently, I ...
5
votes
1answer
73 views

Manage Group broken on 4.7.5

after update to 4.7.5, the "manage Groups" page just says "No groups have been created for this site". Although the groups are functioning otherwise. This also happens on the sandbox/demo site.
5
votes
3answers
335 views

Cron error after upgrade to 4.7.1

Upgraded from 4.6.11 to 4.7.1 and now this this error when running /wp-content/plugins/civicrm/civicrm/bin/cron.php Fatal error: Uncaught exception 'Exception' with message 'Function "is_admin()" ...
5
votes
2answers
104 views

When upgrading from 4.7.7 to 4.7.8 I get error “Specified key was too long”

I tried to upgrade my Joomla CiviCRM 4.7.7 to 4.7.8 and got the following error in the database upgrade: ALTER TABLE `civicrm_contact` CHANGE `image_URL` `image_URL` VARCHAR(512) CHARACTER SET utf8 ...
5
votes
2answers
118 views

cannot select profile for online event registration after upgrading civi on Joomla

I've just upgraded CIVI on Joomla 3.4.1 from CiviCRM 4.5.3 to CiviCRM 4.6.9 and find that I can no longer select profiles to use for online event registrations when setting up an event. I also find ...
4
votes
3answers
88 views

Up to what version of CiviCRM is secure to upgrade on a Drupal 6 site?

CiviCRM no longer officially supports Drupal 6.x. as of version 4.2 but seems that more than one is running versions above 4.1 with Drupal 6 site. Up to what CiviCRM version I can upgrade my Drupal 6 ...
4
votes
2answers
118 views

CiviCRM 5.9 upgrade

I just finished the upgrade, and I'm getting an error list at the top of some panels consisting of a series of identical messages: Notice: Undefined index: name in CRM_Core_SelectValues::...
4
votes
4answers
364 views

DB Error on upgrade to 4.7: Duplicate entry activity_tab_filter for key 'index_domain_contact_name'

I receive the error below during the upgrade process. I restored to previous backup and tried again and received the same. Any ideas what exactly is it indicating is duplicate? Thanks so much! [...
4
votes
2answers
121 views

I've inherited old CiviCRM data from a Drupal install - how do I get upgraded and running in Wordpress?

I am running Wordpress 4.2.1, with CiviCRM 4.5.6. Everything works for my fresh install of CiviCRM. Now, I am chair of a political organization, and I got the old data for my county from an ex-...
4
votes
2answers
218 views

Upgrade Fails 4.7.4 - 4.7.6 in WP 4.5.1

We have attempted to upgrade the CiviCRM instance multiple times, but all attempts for that failed with the following error: ALTER TABLE civicrm_mailing_event_queue DROP FOREIGN KEY ...
4
votes
2answers
77 views

Is my upgrade failing if the screen appears to hang

We're on 4.7.3 on Drupal 7, and are being affected by some bugs that affect contributions made on behalf of an organisation and paid for by paypal. When I attempt the upgrade to 4.7.5, the upgrade ...
4
votes
3answers
483 views

How long does sourceforge keep older versions / Where can I download an old version?

I tried a couple of the older links at sourceforge, e.g. 4.0.x, 4.1.x, 4.2.x, and I get "file not found" for all of them. How long are older versions archived at sourceforge? If they are really gone, ...
4
votes
4answers
164 views

On upgrade from 4.5.8 to 4.6.2 CiviCRM menu disappears until scroll, then scrambled

The issue: after upgrade the CiviCRM menu will not appear at the top over the Drupal menu. It does not appear at all unless I scroll down the page a short ways and then it appears on the upper left ...
4
votes
1answer
166 views

Upgrading a CiviCRM System

We have a CiviCRM system that hasn't been updated for 5 years and the guy who used to do this has left. Now I do have a lot of IT knowledge but am lost with this. Please, can someone advise how much ...
4
votes
2answers
350 views

How do I use cv to run database upgrades from the command line?

I'd like to run the database upgrades from the command line. I know I can do with with drush civicrm-upgrade-db but I'd like to know a way to do it in a CMS-agnostic way (that will work for Wordpress ...
4
votes
3answers
117 views

How to manually trigger update hook for an extension?

Question: When upgrading an extension from the UI on Site A it will update the files and run the update hook. How do I manually execute the update hook for the extension on the other Site B, C, etc? ...
4
votes
1answer
64 views

CiviCRM Upgrade after 4.0: do I need to update civicrm.settings.php?

From the CiviCRM Upgrade for Drupal wiki article, step 9 indicates that all versions 4.0 or after require editing the civicrm.settings.php file, and provides two options to accomplish this. ...
4
votes
1answer
37 views

Option to add new contact freezes up - won't work

Can anyone help? I just upgraded CiviCRM and have been having problems since. I cleared cache and cookies and that helped with a bit but now we have issues with clicking on Creating a new contact -- I'...
4
votes
1answer
174 views

Unable to Upgrade from CiviCRM 4.6.16 to 4.7 (Wordpress)

When attempting to upgrade from CiviCRM 4.6.16 to any of the 4.7 releases, I receive the following error message: Error: Migrate "on behalf of" information to module_data Debug info says: "Unknown ...
4
votes
1answer
259 views

iAmAnIntentionalENoticeThatWarnsOfAProblemYouShouldReport and other event registration warnings in 4.7.1

On the Find Participants page for an event: Warning: array_keys() expects parameter 1 to be array, null given in CRM_Utils_Array::formatArrayKeys() In the Drupal log, lots of these: Notice: ...
4
votes
1answer
90 views

What is CiviCRM's position on WordPress 4.3?

I've reviewed the WordPress 4.3 release info, and see that it has been downloaded about 3 Mio times now. Is there an expected CiviCRM compatibility date / release for WP 4.3? Thanks for any insights....
4
votes
0answers
31 views

Why when upgrading civi via drush I always get You are already upgraded to CiviCRM version-I'm-upgrading-from?

I saw a bug out there on this but it's old and claims to be fixed. I keep thinking the next time I do an upgrade, it'll be fixed. So for example: upgrading from 5.9.1 to 5.10.0 drush civicrm-...
4
votes
0answers
264 views

How to use Composer to install and upgrade CiviCRM 4.6.x / Drupal 7

I am building a composer.json file for my project which involves core Drupal, contributed Drupal modules, Drupal related libraries, core CiviCRM. All initialisation of the empty prototype and ...
3
votes
3answers
164 views

How can I speed up a slow upgrade to 4.7?

Upgrades to 4.7 for big CiviCRM databases can take many many hours. What is the best way to speed them up?
3
votes
1answer
162 views

screen for composing a mail is blank

I am using CiviCRM 4.7.21, on Drupal 7.56. I am attempting to send a monthly mail-out. If I choose last month's mail-out and click the "re-use" button, I get a blank screen: If I go to mailings->...
3
votes
1answer
108 views

How do I test a CiviCRM upgrade script?

I have a PR that adds a file CRM/Upgrade/Incremental/sql/4.7.alpha1.mysql.tpl. How should I go about testing this code?

1
2 3 4 5
8