Questions tagged [upgrade]

Questions related to civicrm upgrades or updates

Filter by
Sorted by
Tagged with
1
vote
1answer
52 views

UI glitches and “Invalid Classname” error when editing summary fields via AJAX

When trying to edit fields on contact summary using AJAX hover method, the fields don't open up properly for editing (scroll bars are sometimes missing, and not enough space is revealed). On clicking ...
5
votes
3answers
522 views

Outgoing Mail Settings, CiviSMTP & PHP 5.6.x Problem

After upgrading CiviCRM from 4.3.8 to 4.7.15 on Drupal 7, our outgoing mail is giving an error after sending a test email. I'm on a Debian server running PHP 5.6.x and we use CiviSMTP for our outgoing ...
1
vote
1answer
210 views

CiviCRM rebuilding templates_c with permissions

I have just upgraded from 4.3.8 to 4.7.15 on Drupal 7.50. Everything went well except the <drupal_root>sites/default/files/civicrm/templates_c directory is rebuilt with the wrong file ...
1
vote
0answers
50 views

Unable to upgrade

I use civicrm 4.7.13 with joomla 3.6.5. I can't upgrade to civicrm 4.7.14. This is the log: 2017-01-04 18:01:43 Access 200 GET /administrator/index.php?option=com_installer HTTP/1.1 .../...
3
votes
1answer
93 views

CiviDiscount Navigation URL incorrect

After upgrading to 4.7.0 on Drupal 7.50, the link to the CiviDiscount administration in the CiviCRM navigation menu is incorrect (cividiscount_reset_1); see screenshot below. I have attempted to edit ...
2
votes
1answer
564 views

Should I change mysql.connect_timeout variable in php.ini?

MySQL has been losing connection on me while trying to complete the upgrade. I am wondering if I should change the php.ini variable mysql.connect_timeout = 60 to a value of -1 (unlimited) and if this ...
3
votes
3answers
164 views

How can I speed up a slow upgrade to 4.7?

Upgrades to 4.7 for big CiviCRM databases can take many many hours. What is the best way to speed them up?
6
votes
3answers
418 views

How can I monitor the progress of a slow upgrade?

CiviCRM upgrades can take a long time. What is the best way of seeing where they are up to?
3
votes
2answers
133 views

What are these big MySQL mailing tables for?

Tomorrow, I will again begin the process of updating CiviCRM. I know that as the upgrade process is going through 4.7.8, it upgrades mailing foreign key constraints in civicrm_mailing_event_queue and ...
0
votes
1answer
34 views

Is there a mistake in the Upgrading CivCRM for WordPress instructions?

I was following the instructions to upgrade to 4.7.14 here: https://wiki.civicrm.org/confluence/display/CRMDOC/Upgrading+CiviCRM+for+Wordpress It clearly says to extract the zip file in /wp-content/...
4
votes
1answer
64 views

CiviCRM Upgrade after 4.0: do I need to update civicrm.settings.php?

From the CiviCRM Upgrade for Drupal wiki article, step 9 indicates that all versions 4.0 or after require editing the civicrm.settings.php file, and provides two options to accomplish this. ...
1
vote
1answer
67 views

CiviCRM 4.7.9 to 4.7.14 fails with no such field

I'm trying to upgrade a CiviCRM 4.7.9 installation to 4.7.14 and the following errors happen during the upgrade process. This site is also using internationalization, but I've made sure the ...
1
vote
1answer
98 views

Upgrade froze at 4.7.8, Can't find valid value for qrid

My upgrade has been running for about 8 hours, but it stalled after completing 4.7.7, from 4.3.8 at. I checked top to see if Drupal or CiviCRM were running, and there was no indication of the process. ...
5
votes
1answer
66 views

Monitor ConfigAndLog .log file in real time

I am upgrading the CiviCRM and would like to monitor the current .log file that is in <drupal root>/sites/default/files/civicrm/ConfigAndLog/ as it's being updated, in real time. Currently, I ...
1
vote
1answer
71 views

Upgrading CiviCRM that is set up outside of the Drupal docroot with symlinks

I am finally upgrading the CiviCRM on a website I didn't develop. It is running on Drupal 7.50, (upgraded from 7.37), and is currently version 4.3.8. Planning to upgrade to 4.7.13. Here's the thing: ...
2
votes
1answer
237 views

Unknown extension after upgrading CiviCRM in Wordpress

Updrading from CiviCRM 4.6.4 to latest (4.7) and using wordpress 4.4.5.. The upgrade process showed no errors, in fact it showed "Done" and began to redirect to a url that never loaded. I clicked on "...
2
votes
2answers
105 views

4.7.14 Upgrade: CiviMail pages broken - Unknown column 'language' in 'field list'

I recently upgraded from 4.7.11 to 4.7.14 in a Drupal 7 installation. Now I have noticed that when trying to create a new Mailing, the page shows nothing. This message appears in the log file: ...
2
votes
1answer
33 views

“Unsupported html-element” error when trying to create or edit a contact record after upgrading to 4.7.13

I upgraded from 4.5.4 to 4.7.13 (on Drupal); I didn't receive any errors during the upgrade process, but now when I try to create or edit a contact, I get an unsupported html-element, similar to what ...
1
vote
1answer
59 views

Upgrade from 4.2.7 to 4.7.13 fails during DB 4.4alpha1 update Joomla

The upgrade process keeps failing, I even tried doing upgrades version after version but always when getting to 4.4 it fails when we get the 4.4 alpha1 update, the error that shows is: [Error: ...
1
vote
0answers
69 views

Database upgrade error - 4.7.13

The process to upgrade my civiCRM database from 4.7.11 to 4.7.13 terminated with the following error: [Error: Upgrade DB to 4.7.13: SQL] Error Field Error Value Type DB_Error Code -19 Message ...
1
vote
1answer
96 views

Administrator does not have sufficient permissions when running upgrade script

I've run into an issue with Civi CRM and I'm hoping after an upgrade it may resolve itself. It's been a couple years since we starte using it on the site. I'm following the steps that are located here ...
0
votes
1answer
22 views

Lots of failed Static function errors after upgrade to 4.7.13 (Joomla)

Just upgraded from a very old (4.4 something) release to 4.7.13. Lots of things are working, but getting lots of these: Call to undefined method CRM_Contact_BAO_Query::processSpecialFormValue() ...
2
votes
1answer
62 views

Fatal Error after upgrading to 4.7.13 from 4.7.11

Just upgraded Civi from 4.7.11 to 4.7.13 The upgraded installed successfully, but rendered Civi functionally unusuable. Attempting to click on any tab within Civi (such as navigating to ...
1
vote
0answers
43 views

Data missing after upgrade from CiviCRM 4.4.14 to 4.7.13 (Wordpress)

I followed the instructions of https://wiki.civicrm.org/confluence/display/CRMDOC/Upgrading+CiviCRM+for+Wordpress#UpgradingCiviCRMforWordPress-2.BackupyourCiviCRMdatabaseandsettingsfile/s but ...
2
votes
1answer
121 views

CRM.$ is not a function after upgrade 4.7.8 > 4.7.13

Running upgrade CiviCRM 4.7.8 to 4.7.13, on Drupal 7, I have a white screen with just "[]" message and "Retry" and "Skip" buttons, and js error : CRM.$ is not a function. Tried to change the theme : ...
1
vote
0answers
39 views

Missing total amount in receipt after civicrm upgrade 4.5 to 4.6

I have upgrade civicrm 4.5 to 4.6. After that token {$formValues.total_amount|crmMoney:$currency} is not printing the total amount in emails. The template used is one of the System workflow messages ...
2
votes
1answer
41 views

Can I turn off Drupal cron while the CiviCRM upgrade script is running?

I want to know if it is a bad idea to turn off cron while in the middle of upgrading the CiviCRM? Below is my original post, but now I see that this information is irrelevant/unrelated. I am ...
0
votes
3answers
830 views

CiviCRM 4.7 - DB Constraint Violation - possibly dashboard_id should possibly be marked as mandatory for this API

We have moved our hosting to new hosting provided (CiviHosting). CiviHosting installed a fresh installation of CiviCRM 4.7. We then imported our previous sql dump from our old site which also had ...
0
votes
1answer
68 views

Update to 4.7.12 failed

I updated from 4.6.10 to 4.7.12 and it failed at updating 4.7 beta 3 DB, now I cannot load the admin screen at all. This is the wordpress version. All I get now is: Sorry but we are not able to ...
2
votes
2answers
218 views

White screen in 4.7.12

I note with the 4.7.12 version of the difficulties of implementation, particularly with queries that only lead to blank pages. Track errors in apache located abnormalities in smarty. I returned to ...
3
votes
1answer
74 views

Should I disable extensions prior to upgrading CiviCRM?

I couldn't spot anything on this in the upgrade instructions, and as it's something that could affect lots of people, I thought I'd ask the question here. When upgrading CiviCRM, what is considered ...
2
votes
2answers
55 views

Upgrading CiviCRM 4.0.1 to 4.1.0

I am having an issue whenever I run the upgrade for 4.0.1 to 4.1.0. The issue is below: Cannot execute CREATE TABLE `civicrm_setting` ( `id` int(10) unsigned NOT NULL AUTO_INCREMENT, `group_name` ...
1
vote
1answer
283 views

Not allowed to view the pages after upgrade

I have a website where the civicrm plugin stopped working and developed an error. I have since copied the site onto another hosting account I have and have been following these upgrade steps (https://...
1
vote
1answer
53 views

After a failed upgrade, is updating the table structure enough?

tl;dr: After a failed upgrade, is updating the table structure enough? I had a failed upgrade due to a mysql crash a few days ago (4.7.6 to 4.7.11). The database worked fine once mysql was back up, ...
2
votes
2answers
237 views

unable to upgrade from 4.4.5 to 4.7.11 - 'DB Error: no such field' (Wordpress)

Trying to upgrade from CiviCRM 4.4.5 to 4.7.11 in Wordpress 4.5/4.4 (problem doesn't change for either WP version) because it stopped working and just printed this when trying to view /wp-admin/admin....
1
vote
2answers
31 views

Upgrade from 4.6.20 to 4.6.21 fails with fatal error (sqlfile not found)

We're using D7 / Civi 4.6.20, attempted to upgrade to 4.6.21 following the Civi upgrade documentation. The upgrade errors out with this error: Exception: "A fatal error was triggered: sqlfile - 4.6....
1
vote
0answers
43 views

CiviEvent DB Error after Update

After update to CiviCRM 4.7.10, now getting a DB Error: syntax error when trying to access CiviEvent registration links. Any ideas would be very helpful. - /home/carolinasgps/www/www/wp-content/...
2
votes
2answers
100 views

DB table that exists says it doesn't

After upgrading to 4.7.10 from 4.7.9, I'm no longer able to edit/add price sets. I think that the DB changes related to https://issues.civicrm.org/jira/browse/CRM-12252 are biting me. (Multi-lingual ...
4
votes
1answer
37 views

Option to add new contact freezes up - won't work

Can anyone help? I just upgraded CiviCRM and have been having problems since. I cleared cache and cookies and that helped with a bit but now we have issues with clicking on Creating a new contact -- I'...
1
vote
2answers
179 views

CiviCRM Upgrade Wordpress 4.4.5 to 4.7.10 DB Error: no such field

CiviCRM Upgrade Wordpress 4.4.5 to 4.7.10 DB Error: no such field. Site shows at bottom of screens: Powered by CiviCRM 4.4.5 Trying to upgrade to 4.7.10 and after pressing Upgrade button CiviCRM ...
0
votes
0answers
40 views

MySQL Error 1064 when trying to upgrade from 4.7.8. to 4.7.9

I am using MySQL Workbench on MacOSX and there are four SQL statements in the 4.7.9 upgrade script which give a 1064 error. The first of the statements in error is shown below. MySQL Workbench has the ...
0
votes
1answer
110 views

Funky errors in 'drush cvup' / 'drush cvupdb'

I'm trying to upgrade from CiviCRM 4.7.4 to 4.7.9 for its security update. I'm doing this using 'drush' on my dev site. It seems to be hitting a couple different problems. Here's the first step: % ...
0
votes
1answer
18 views

Any experiencing errors upgrading to 4.7.9, related to 'CRM-16189 Financial account relationship'

My upgrade simply hangs (20+ minutes) and then crashes a 2GB VPS trying to execute the MySQL related to 4.7.9. My guess is that line 26 and beyond in 4.7.9.mysql.tpl is writing checks that my server ...
2
votes
3answers
120 views

What's the best strategy for upgrading CiviCRM?

I use CiviCRM 4.5.8 with WordPress. I'd kinda like to try a newer version, but I don't want to mess up the production website. I used the WP plugin Duplicator to create a test site. I changed the ...
1
vote
0answers
29 views

BOM readfile issue

Upgrading from 4.4 to 4.6.14 and I'm struggling to correct an issue with BOM being added to contact images. Note that this isn't custom fields, just the image_url that's part of the organizational ...
1
vote
1answer
34 views

Problem in civicrm upgrade 4.74 to 4.7.5 in drupal 7

When I Intented upgrade my site from civicrm 4.7.4 to 4.7.5 in drupal 7 one error appear and don't is possible continue. (sorry for my english) Could yo help me with this error? This is the error ...
2
votes
1answer
32 views

Is this the desired/typical setup for directories after 4.7?

After an upgrade from 4.6 to 4.7, I see this. While it advertises 'variables' in the top right, they aren't used in the boxes below, and any other hardcoded path has been stripped out. The files ...
5
votes
2answers
104 views

When upgrading from 4.7.7 to 4.7.8 I get error “Specified key was too long”

I tried to upgrade my Joomla CiviCRM 4.7.7 to 4.7.8 and got the following error in the database upgrade: ALTER TABLE `civicrm_contact` CHANGE `image_URL` `image_URL` VARCHAR(512) CHARACTER SET utf8 ...
6
votes
1answer
584 views

How do I debug “Could not find valid value for ct” error message

Performed upgrade of Civi 4.4 to 4.6 alongside upgrade of Drupal from version 6 to version 7. The Drupal upgrade went fine, as did the CiviCRM upgrades (i.e. no errors were reported). All dashboards ...
4
votes
1answer
175 views

Unable to Upgrade from CiviCRM 4.6.16 to 4.7 (Wordpress)

When attempting to upgrade from CiviCRM 4.6.16 to any of the 4.7 releases, I receive the following error message: Error: Migrate "on behalf of" information to module_data Debug info says: "Unknown ...

1
4
5
6 7 8