Questions tagged [upgrade]

Questions related to civicrm upgrades or updates

Filter by
Sorted by
Tagged with
1
vote
2answers
721 views

What can I do to fix my database that has been partially upgraded?

I have run into this problem on two of my websites that run Civicrm separately. Both are running version 4.5.8. When I run the automatic installer, the update process seems to freeze for an infinite ...
1
vote
3answers
566 views

Network error after upgrade to 4.6.5

CiviCRM: 4.6.5 Wordpress: 4.2.2 I have followed the instructions here: https://forum.civicrm.org/index.php/topic,35850.0.html All CiviCRM and Wordpress extensions are disabled. Details: When going ...
1
vote
1answer
43 views

Civi Database erased when upgrading from 4.6.3 to 4.6.4

I tried to upgrade from Civi version 4.6.3 to 4.6.4 but ended up having my crm database erased and filled with an empty civi database. I have tried to import my backup sql file in phpMyAdmin and get ...
3
votes
2answers
69 views

Are log tables updated during an upgrade?

If a CiviCRM upgrade amends the structure of existing tables, do you know if the same changes are applied to the equivalent logging tables? I've noticed in the column civicrm_line_item.label NULL is ...
6
votes
4answers
231 views

Mailings - Disabled Next/Test Buttons

New mailings with all required fields and the default responsive template do not enable the Next or Test mailing buttons. As a workaround I can reuse an old mailing and update the fields. The last ...
1
vote
2answers
105 views

New codebase version detected

I've installed CiviCRM 4.6.4 on my WordPress site. But on admin.php page, I get a message box warning me that "New codebase version detected. You might want to visit upgrade screen to upgrade the ...
0
votes
2answers
109 views

Joomla CiviCRM Upgrade 4.3.9 to 4.4.x version

I am unable to upgrade 4.3.9 version into new version .. I am getting this error : Error: Consolidate activity contacts Type DB_Error Code -2 Message DB Error: syntax error Mode 16 UserInfo ...
1
vote
0answers
18 views

Upgrading to 4.6 Joomla. Civi Mail can't generate the text editor

Since I upgraded to 4.6 I can't create any Newsletter email anymore. Html Editor is not showing. Please see two images step 1 and step 2 to understand process.
1
vote
2answers
218 views

Cloudflare kills dashboard + Relationship tab error. Any ideas?

Drupal 6.36; CiviCRM 4.5.8 I am experiencing two problems after making changes to my site. Not sure if the problems are related. I will start troubleshooting but any guidance would be very helpful. 1....
2
votes
1answer
50 views

Upgrade from 4.6.3 to 4.6.4 not completed

I tried to upgrade version 4.6.3 (Drupal 7.37, dutch) to version 4.6.4. After upgrading the database, [Executed: Upgrade DB to 4.6.4] the process seemed to stop on 2/3 of the bar. After 10 minutes I ...
2
votes
2answers
934 views

Problem after upgrading: table not found

I have a big issue after installing an upgrade of CIVICRM. The debug output indicates a table is missing but does not identify which one: DB Error: no such table What should I do? I have add a ...
3
votes
2answers
53 views

Can't log in to Drupal site: get redirected to random pages after submitting login form

I have one site with a very strange issue that I have been fighting for months and I'm clueless. All I know is that with CiviCRM disabled, the issue does not occur. When I attempt to log in and ...
3
votes
1answer
436 views

Message: “CiviCRM does not have permission to write temp files” after login into back-end Joomla

My host updated PHP to 5.5. last night. Now, I can't login to my Joomla back-end because of an error. It says that CiviCRM does not have permission to write temp files. What can I do to make sure ...
2
votes
3answers
266 views

Downgrading CiviCRM to use an older extension

I am trying to use the civicrm document storage extension. It turns out that CiviCRM 4.4 and 4.3 supported this extension. My question is, is there a way to downgrade CiviCRM 4.6.3 to either 4.4 or 4....
1
vote
1answer
136 views

Update results in failed DB check

In trying to upgrade to Civi 4.6.3, I did a backup using Drupal 7.35 (I know, updating that was next) Backup and Migrate, then copied the Civi code files to my desktop, deleted the old Civi, copied in ...
6
votes
4answers
634 views

Fatal error: Cannot redeclare _PEAR_call_destructors()

Fatal error: Cannot redeclare _PEAR_call_destructors() (previously declared in /usr/share/php/PEAR.php:735) in /www/htdocs/w010699b/de/wsk/prod/cms-crm/sites/all/modules/civicrm/packages/PEAR.php ...
2
votes
2answers
83 views

Upgrading to CiviCRM 4.63 from 4.4x on current Joomla 3.x

The upgrade went fine - the DBs script ran with no errors -- Can view contacts, members, past events just fine When I go to try to manage event - I get the errors below - I also get issues when I ...
3
votes
2answers
36 views

Multiple error messages upon upgrade to CiviCRM 4.2.20

I am trying to upgrade from 4.1.5 to the latest CiviCRM but need to go through some intermediate releases to get there. I have installed 4.2.20 but get the following error dozens of times on each ...
3
votes
1answer
106 views

Fatal error while upgrading

While upgrading from 4.5.8 to 4.6.3 on a Drupal site, the upgrade script stuck and when I refreshed, i got Fatal error: Cannot redeclare class CRM_Core_ClassLoader in [MYSITE]/sites/all/modules/...
1
vote
2answers
98 views

Error: Database check failed when upgrading from 4.6.0 to 4.6.2

When i try to run the database upgrade script i get the following message: Database check failed - the database looks to have been partially upgraded. You may want to reload the database with the ...
1
vote
2answers
94 views

Upgrading from 4.1.5 database to 4.6.2 failing with constraint violation

Trying to upgrade a 4.1.5 database to 4.2.6. I am getting a constraint violation. See the screenshot.
5
votes
4answers
198 views

How long should a CiviCRM / Drupal upgrade take?

We are running an outdated version of Civicrm (4.2.7) on Drupal 7 and working on upgrading to the newest version of Civi, 4.6x. We have been quoted a full forty hours by a consulting company for the ...
1
vote
4answers
99 views

Upgrade from 4.5.8 to 4.6.2 killed View Contact Tabs

We consult with CiviCRM powered by Drupal. Recently we upgraded one client who has CiviCRM powered by the latest Drupal 6 from 4.5.8 to 4.6.2. After the upgrade, they are unable to click between the ...
4
votes
4answers
163 views

On upgrade from 4.5.8 to 4.6.2 CiviCRM menu disappears until scroll, then scrambled

The issue: after upgrade the CiviCRM menu will not appear at the top over the Drupal menu. It does not appear at all unless I scroll down the page a short ways and then it appears on the upper left ...
2
votes
1answer
350 views

Could CiviCRM 4.5 or 4.6 make it easier to generate large numbers of PDFs at once?

I have a client using CiviCRM 4.4, who prefers to generate donation and membership receipts as PDFs for mailing in print form, but has found that they often have trouble generating all the PDFs they ...
2
votes
1answer
37 views

Working with git

My development configuration: I work on netbeans on my Windows. My civicrm site runs on a remote ubuntu-server to which I can ssh and ftp. I need to make some changes to civicrm-core. I would like to ...
1
vote
1answer
107 views

“nativecode=1060 ** Duplicate column name 'created_id'” when upgrading from 4.4.14 to 4.6.2

Keep getting this error when Upgrading from 4.4.14 to 4.6.2 directly. I am upgrading based on the civicrm documentation. Seems like civicm_mailing_abtest has some error. But I have checked I did not ...
0
votes
2answers
53 views

Upgrade 4.5.6 > 4.6.1

Running my upgrade stalls at the upgrade page. The buttons are not working and do nothing. According to the debugger in Firefox, there is an illegal character in noconflict.js and CRM.$ is not a ...
3
votes
1answer
117 views

After upgrade to 4.6, should I get “No available releases found warning” in Reports->Available updates?

In the Drupal menu item "Reports->Available updates", I get the below. Is this normal or is there something I could / should do to fix this? civicrm 4.6.0 No ...
2
votes
2answers
96 views

What to do when upgrade to 4.6 failed, but rolling back breaks SMS?

When trying to upgrade to civi 4.6, the process does a partial upgrade and then errors out. Recovering previous version reveals SMS is no longer working. What should I do?
3
votes
1answer
108 views

How do I test a CiviCRM upgrade script?

I have a PR that adds a file CRM/Upgrade/Incremental/sql/4.7.alpha1.mysql.tpl. How should I go about testing this code?

1
4 5 6 7
8