Hot answers tagged

2

The solution was: Add a define('CIVICRM_L10N_BASEDIR', '/var/aegir/platforms/YOUR-PATH'); statement to platform.settings.php file of Aegir (see: Altering Aegir's Behaviours), to set an environmental variable for CiviCRM, to locate the exact place of its l10n files. More info on CIVICRM_L10N_BASEDIR here and here. Correct the line breaks of the example ...


1

I'm assuming you're talking about DEFINE statements since you mention domain id? Are you able to edit drupal's settings.php? If so you can just put those DEFINEs in there since it loads first and most of the DEFINE settings in civicrm.settings.php check for if (defined(SETTING_NAME)). If you can't edit drupal's settings.php, I haven't tested this but can ...


1

It sounds like you have "http://" hard-coded into your URLs. Check your BASE_URL in civicrm.settings.php (and search the whole file for "http://" while you're there), and check the Administer » System Settings » Resource URLs menu to ensure that your resource URL doesn't include "http://". Finally, check if you have any extensions that have the text ...


1

It's not a setting you can set with Civi::settings. You can set it with a define() anywhere outside of civicrm.settings.php, but it would need to run that section in your file before running the code where it gets used, so somewhere pretty early in a page run. It always falls back to CIVICRM_DSN if CIVICRM_LOGGING_DSN is not set, if your setting runs too ...


Only top voted, non community-wiki answers of a minimum length are eligible