7

Bienvenue sur Stack Exchange, avez-vous vérifié l'extension GDPR qui permet à vos bases de données CiviCRM de suivre les directives GDPR? Vous pouvez l'installer via la page CiviCRM Extension Manager ou via ce lien - https://civicrm.org/extensions/gdpr Welcome to Stack Exchange, have you checked out the GDPR extension which enables your CiviCRM databases ...


4

Jade's answer is very helpful, but I think its important to point out that a piece of software cannot be compliant or not to the regulation and that Pierre's users are actually asking the wrong question. Its your organisation's procedures and processes that are compliant with GDPR (RGPD) or not. The extension helps with that of course. Hope that the Google ...


2

Try $element->updateAttributes(array('readonly'=>true)); The difference between readonly and disabled is a common thing with HTML and forms. See for example https://stackoverflow.com/questions/7730695/whats-the-difference-between-disabled-disabled-and-readonly-readonly-for-ht


2

Try "5.28.x-dev" instead of alpha1 or beta1. Packagist uses different ways to specify the version numbers. https://packagist.org/packages/civicrm/civicrm-drupal-8


2

can you add below lines in your civicrm.settings.php? global $civicrm_paths; $civicrm_paths['civicrm.root']['url'] = CIVICRM_UF_BASEURL . '/sites/all/modules/civicrm';


2

Sounds like perhaps you’re missing -> https://gitlab.com/roundearth/drupal-civicrm-project/-/issues/2 But I do recommend you change how you install D8/CiviCRM to as described in here: Downstream Git/Composer Issues


1

Instead of editing the database why not just override the value in the civicrm.settings.php file? Check you have global $civicrm_setting; Then add $civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = 'http://example.com/example-resource-url/'; More information here on this https://docs.civicrm.org/sysadmin/en/latest/customize/settings/ ...


1

I would firstly suggest checking out the Membership Churn extension


1

Do you have multi-lingual enabled? than try to rebuild the views to see if it resolves your problem Missing column 'frontend_title' in ''civicrm_uf_field_de_DE" after upgrading to 5.1.2 Do you have DB logging enabled? than disabled and enable back again. Else can you check the CiviCRM log/watchdog to get more details of DB error?


1

Another possibility is that you forgot to copy your civicrm.settings.php file into the new plugins/civicrm folder. See the docs at https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/


1

It's complaining about not being able to open CRM/Core/ClassLoader.php Does that file exist? Are the permissions correct to allow the webserver to read that file?


1

I have fixed this issue by doing the following: 1. clearing the sites/default/files/civicrm/templates_c 2. Corrected Resource URL 3. and also go to administer - system settings - cleanup caches & Reset paths


1

I have fixed it on my local sandbox by enabling the Drupal clean url's.


1

Erik I had this in my civicrm.settings.php file. After I changed it fixed the layout


Only top voted, non community-wiki answers of a minimum length are eligible