People who code: we want your input. Take the Survey
5

It should be possible to do any one of these: Use CiviCRM 5.31+. The error message above suggests it is using 5.30.x, which has older metadata. (Compare: 5.31's composer.json vs 5.30's composer.json) Stick to composer v1 for as long as you're using an older version of Civi. composer self-update --1 In the future, after you switch to a newer version of ...


5

Depending on how your initial site set up was created you might need to take a more extreme option detailed below but hopefully the following will work: If you want you can copy composer.json , composer.lock to a new directory (or local) and use issue composer installto check the below works this can be useful if you are having problems and need to remove ...


4

I've been updating it using the following: composer require civicrm/civicrm-core composer civicrm cv upgrade:db That is after making a backup first. Has worked for my installation.


3

In practice it's as simple as doing a composer update for the most part - assuming you're configured "sensibly" - the RoundEarth setup makes (or at least made!) some assumptions re: versioning that are not helpful for upgrading. So here goes: You should declare both civicrm-core and civicrm-drupal-8 in your composer json file. In the require section you ...


3

My experience with anything composer-ish seems to be: Struggle with it for a while until the site becomes messed up beyond repair. Restore from backup and struggle some more until it's messed up again. Create a brand new install and then copy over the sites/default folder and .htaccess and such. Replace the database with my backup. Run the upgrades.


3

Drupal 8/CiviCRM has the composer-patches package already installed. So you can add a section to the "extra" element in composer.json called "patches", and list out the patch with a title and a URL (or path) to a .diff file. Here's an example where I add four patches to standard CiviCRM: diff --git a/composer.json b/composer.json index 453ff74..5827a69 ...


2

Sounds like perhaps you’re missing -> https://gitlab.com/roundearth/drupal-civicrm-project/-/issues/2 But I do recommend you change how you install D8/CiviCRM to as described in here: Downstream Git/Composer Issues


2

Just looping back - I did get Drupal 8.4.x and CiviCRM 4.7.x up and running - here's my live play by play steps: https://d8webform.semper-it.com/node/4


2

Although as of today (2020-11-20) there's no official word, I can see work being done towards this, e.g. https://github.com/civicrm/composer-downloads-plugin/releases/tag/v3.0.0


2

You can use: (confirming this syntax) karins-MBP:d8civicrm.local sysadmin$ composer require pear/pear_exception:'1.0.1 as 1.0.0' ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Package operations: 0 installs, 0 updates, 0 removals Writing lock file Generating autoload files ...


2

It turns out this compilation error is related to composer versions: Using default composer version of 1.10 on Ubuntu 20.04 produces this fatal error. Manually upgrading to composer 2.0 resolves this issue.


1

As per comments there were some leftover installed vendor files and removing composer.lock and the entire vendor folder and also web/modules/contrib/civicrm and then trying again clears it.


1

Problem appears to have been a newbie-to-Composer issue. Every time I ran various composer commands, I'm told it overwrites the .json files I've been furiously editing for four hours, putting back all the code I'm trying to kill? Charming. Had no idea. Was also told that the way to do this is to fork the project and point my top-level composer.json at it ...


Only top voted, non community-wiki answers of a minimum length are eligible