4

It sounds like your custom fields are on the contact record. If you create custom fields on the contribution instead then you avoid the problem.


2

It has to do with an added custom field. See: Its a range and an option list. Workaround. Go to the custom field definition (it's somewhere on cases, for techies, you can find the id in the javascript error. Change the Field Input Type to Single Line Input Field Now Search by Range is visible. Uncheck it. Set the 'Field Input Type' back to the former value....


2

Ultimately, the answer was simply to enable "CiviCRM: access all custom data" for all users in Administer->Users & Permissions->Permissions->WordPress Access Control. I am unclear whether this presents a data risk. The wording of the permission makes it feel a bit like this, but I guess if a user only has limited access by context then ...


Only top voted, non community-wiki answers of a minimum length are eligible