Hot answers tagged

5

This one also throws me occasionally. You should reduce the dashboard cache timeout setting to '0' in /civicrm/admin/setting/misc?reset=1 Then it will load the reports dynamically each time you access the dashboard.


4

I think the best solution would be to upgrade to CiviCRM 4.7.11 which will include an improved dashboard that no longer depends on server-to-self http requests. This upgrade will be released in about 2 weeks. The new dashboard features are sponsored by WMF. Read more about the issue at https://issues.civicrm.org/jira/browse/CRM-17663


3

Check your civicrm.settings.php, and make sure that the CIVICRM_BASE_URL matches your site url. My site was redirecting http://domain.com to http://www.domain.com, but civicrm.settings.php had the version without the www, which was screwing things up.


3

If I recall correctly, this is down to some peculiarity of the dashlet permissions. If you go to the Access tab of the report in question, you'll see two ways to set the permissions (see screenshot below). However, I believe only the "permission" setting will control access to the dashlet. Try setting both the Role ("Board Member") and the permission (to ...


3

I'm glad you found the cause of your problem. It does sound like something went wrong back when you originally created those dashlets, and it's not clear what that was. But it would be good to proactively repair this during the upgrade. I've created a PR to do so: https://github.com/civicrm/civicrm-core/pull/9672


3

Graham, you can not really configure these dashlets, they are not based on existing CiviCRM reports but code specifically. We have just created a fair number of CiviCase reports (working on one as we speak :-), you would probably have to create/get someone to create a custom version of the dashlets or possibly even a custom report if it would make sense.


3

It's working fine on 5.25.0 for me. EDIT: You must go to Access tab > enable Available for Dashboard > select actions drop down > select Save. (Not view results). That appears to be the misstep. Clicking View Results does not save the report. There is valid reason for having the save v. view results functionality as there is the permission save report ...


2

Yes, dashlets are cached. However you shouldn't need to re-run individual reports to update the dashlets. Instead, use the link at the top-right of the dashboard page called "Refresh Dashboard Data".


2

You are experiencing CRM-16035 - Dashlet refresh can crash server. The default dashboard config is pretty close to maxing out the default Debian config for either Apache or PHP-FPM. Depending on your server setup (question says just Apache which typically suggests via mod_php) you probably need to increase either the number of connections Apache permits. ...


2

A workaround: You could add a (Drupal) block, and choose it only to display on a certain page; CiviCRM home. (And maybe also by selecting only to show with specific roles)


2

Not sure if this is solved, but we had the same issue running on a Debian server and the host was resolving the DNS name to the legacy site (we were testing). So to resolve the 404 errors on the dashlets, we had to enter a host entry in /etc/hosts to point the DNS name to the local IP address (instead of it resolving on the net to the existing legacy server ...


2

I was able to finally resolve this issue. I found this small portion at the very bottom of https://wiki.civicrm.org/confluence/display/CRMDOC/Installation+and+Configuration+Troubleshooting labelled Fire with NAT. Followed the instructions to edit the hosts file to point internal traffic going out to it's own domain to be redirected back to the internal ...


2

https://issues.civicrm.org/jira/browse/CRM-16035 has now been fixed. So your best solution now would be to upgrade to CiviCRM 4.7.11 which will include an improved dashboard that no longer depends on server-to-self http requests. This upgrade will be released in about 2 weeks. The new dashboard features are sponsored by WMF. Read more about the issue at ...


2

You would need to change the code. But there is another way to get the Activities on your dashboard. Go to Reports, select Contact Reports and then Activities. If you then set all filters as you wish and tick the 'Available for Dashboard' option, and save the report as "My Desired Activities" (or any other name :-)) you should have a new dashlet available ...


2

Your debug output indicates that your site is hosted at (obfuscated) http://example.org/~user/. To load the dashboard, your webserver has to be able to "talk to itself" via this URL. This is not always the case! Based on your description, here's what I think is happening: Your browser requests http://example.org/~user/wp-admin/admin.php?page=CiviCRM&q=...


2

If you're on Drupal, you can use the civicrm_views_dashlets module for a no-coding solution. Not only can use create a view that shows a single page (which is editable like any other page), but you can use Views to show more complex content. For instance, when I worked on a CiviCRM-based SaaS a few years back, we created our own "news" dashlet by ...


1

When that other question mentions news dashlet I think it means the one called Blog, but yours sounds more similar to the Getting Started one - CRM/Dashlet/Page/GettingStarted.php. Civix doesn't have a specific feature for dashlets, but you start with civix generate:page and copy/paste from the GettingStarted dashlet, although all you really need to do is ...


1

Check that you are using https://... or http://... consistently and not mixing them. (Preferably https!) I have seen that where you have a mismatch between the URL you are logging in with and the resource URL's (configured at Administer > System Settings > Resource URL's). For example, if your Resource URL's are https://... but you log in as http:// ...


1

You can make the dashlets wider on the dashboard. It's hard to give exact instructions because I don't know what CMS you're using - it's a good idea to post your CMS and CiviCRM version with a question for this reason - but if you're using Drupal 7, I like the Civi Bartik theme for my back end. It makes a number of sections wider, including the dashlets. ...


1

Also in the database in the 'url' column I see the url of the dashlet in the form: civicrm/report/instance/42?reset=1&section=2&snippet=5&context=dashlet and comparing entries with data in the name column I can see that the report instance number matches. So I replace the NULL entry with 'report/xx' where xx is the report instance number as ...


1

Probably not the solution you are looking for but it's worked for me in the past. -Configure your Dashboard and remove all the dashlets so your dashboard is blank. -Save -Clear Caches. -Re-enable the dashlets


1

We had a similar (but not identical) issue with one of our sites - dashlets would spin for ages before eventually timing out. Occasionally we would get some loads but it was sporadic. We followed the direction in https://issues.civicrm.org/jira/browse/CRM-16035 to increase the pm.max_children. I have no idea if this will fix your issue but, as it sounds ...


1

Try the following options and see if it solves the problem Add your IP and domain to /etc/hosts file Check if your firewall is blocking any AJAX calls Check if any .htaccess file in any of the directories (mainly wp-admin directory) is blocking the AJAX call


1

If I'm right it displays only active Cases with scheduled Activities. Indeed a confusing name. If you close all Activities the Case is not shown.


1

This problem has been assigned to a CiviCRM bug which requires funding to resolve. The suggested fix is an AJAx solution. See: https://issues.civicrm.org/jira/browse/CRM-17663


1

This is a bug related to recurring activities. Issue filed https://issues.civicrm.org/jira/browse/CRM-18165


1

I just encountered this and solved it. I've opened a ticket CRM-18264 to address this issue, and I've submitted a pull request for both 4.6LTS and 4.7. They've been merged, so you just need to upgrade to CiviCRM 4.6.15+ or CiviCRM 4.7.5+.


1

Dashlet problems can arise when you have the wrong settings in either Cleanup Caches and Update Paths (Administer - System Settings - Cleanup Caches and Update Paths) Resource URLs (Administer - System Settings - Resource URLs ) Differences can be as small as http vs https and with or without www.


1

In "own question - own answer" mode .. again. Well, it turned that server name resolves as www.hostname.tld while all paths we used were in just hostname.tld format.


1

If you turn on dashboard caching with a long duration it might mitigate the performance issues enough for you to use the Advanced Fundraising reports?


Only top voted, non community-wiki answers of a minimum length are eligible