15

For CiviCRM 4.6+ go to Administer menu > Customize Data and Screens > Date Preferences. From there, change the Start Offset of SearchDate. For CiviCRM versions before 4.6, this is part of the Advanced Date settings linked from Administer > Localization > Date Format.


6

Yes, Date fields in export do not respect Date formats set in Localization >> Date Formats. Can you try Format Date Column in Export extension? This extension allows to set Export Date format under Localization >> Date Formats and uses this to format the date fields while exporting.


6

For CiviCRM 4.6+ go to Administer menu > Customize Data and Screens > Date Preferences. From there, change the Start Offset of SearchDate. I found this answer in Member since date before 1995 and although it talks about Membership dates, it apparently applies to Relationship dates too.


6

Go to Administer, Localization, Date Formats at civicrm/admin/setting/date?reset=1 and change the Complete Date to the format you'd like. I think %m/%E/%Y is what you're looking for.


3

So I think I was jumping the gun with my excitement about this. I found the issue on Jira, which has been updated to say the custom filter creation has been bumped to 4.8. The work-in-progress code that Jon was working on is at https://github.com/civicrm/civicrm-core/pull/6307


2

Further to Jon's helpful answer, for CiviCRM 4.7.12 (and possibly earlier) the date preference setting that needs to be changed is 'activityDate', as the description makes clear.


2

To use the native datepicker of the mobile device, the field needs to have type="date". So your code to disable the datepicker popup and use the native device's instead might look like: (function($) { $.ui.datepicker.prototype.options.focus = "button"; $(document).on('crmLoad', function($region) { $('input.dateplugin', $region).each(function() { ...


2

Adding the following CSS disables the date picker widget and allows users to simply type the date into the field:- #ui-datepicker-div, .ui-datepicker .ui-widget { display: none !important; }


2

Also posting my answer to How do I override the default date range of JQuery date widget? here - for those following this Question: I think the answer may be that this is working in 4.7.7 - set your date range in the Custom Field - Edit screen [I want to go back 30 years]: Custom Date SE field: And this is indeed giving me a dropdown going back 30 years (...


2

I think the answer may be that this is working in 4.7.7 - set your date range in the Custom Field - Edit screen [I want to go back 30 years]: Custom Date SE field: And this is indeed giving me a dropdown going back 30 years (I can select 1986):


2

Have you tried adjusting the settings at Administer > Customize Data and Screens > Date Preferences. to achieve what you want?


2

Go to Administer/Localization/Date Formats


1

Answering my own question: My fix was to edit a file in "all", which isn't ideal since it'll get overwritten when updating CiviCRM, but I can always re-apply it. Edit file: sites/all/modules/civicrm/CRM/Report/Form/Contribute/History.php Change Line 61 from $yearsInPast = 4; to $yearsInPast = 20;


1

You could also set your date preferences in Administer >>Localization >>Date formats (possible you'd also need to look at Administer > Customize Data and Screens > Date Preferences depending on your needs.) If it's a custom date field, you could easily set the date input preference to Month and year and increase the date range as needed.


1

Date Preferences at civicrm/admin/setting/preferences/date?reset=1 can be edited so the 'offset' is greater than 20 (years) SO you can edit Date for activities (including contributions: receive, receipt, cancel. membership: join, start, renew. case: start, end.) and set it to have years going back further than 1996 (ie 20 years)


1

I wouldn't do this by editing core files. I would implement the buildForm and postProcess hooks in a module extension. https://wiki.civicrm.org/confluence/display/CRMDOC/Create+a+Module+Extension https://wiki.civicrm.org/confluence/display/CRMDOC/Hook+Reference But having said that I probably also wouldn't add it to a core form, I would make a settings ...


1

Caching methods can be enabled or disabled in your CiviCRM settings file (eg: civicrm.settings.php). The setting you're looking for is: CIVICRM_DB_CACHE_CLASS To disable caching, change the value to 'NoCache'. Other possible settings are documented above the setting in the file. There is a page about caching in the documentation here: https://wiki.civicrm....


1

I've just checked this on the demo site. It appears that you can type in any date up to the limit (in this case dates after and including 1 Jan 1926). However, the date picker widget only shows the last ten years. I'm not sure you would want the date picker widget to show all 90 years as that would make the drop down list very long. So I think this may be ...


1

It sounds like a bug, it should take the settings for the date/time, sounds like it does not.


1

In the CiviCRM engine the usuall date format is YYYYmmdd hhmm. You could try that date format. You could leave out the hhmm part. Explenation of the format - YYYY = year in four digits (2014) - mm (months in 2 digits, 01 for january) - dd (day of month in 2 digits e.g. 21)


Only top voted, non community-wiki answers of a minimum length are eligible