6

You can configure CiviCRM to use a customized "fatal error" screen by following the steps below. You may want to include specific site administrator contact information or other problem resolution instructions on the screen, as well as "theme" it for a more professional or consistent look. Save a copy of civicrm/templates/CRM/error.tpl Edit the text and ...


4

This particular phrase appears to be in these files: ./CRM/Utils/System/Drupal.php ./CRM/Utils/System/Drupal6.php Here are two ways you can search for specific phrases within the codebase: 1) GREP Using this command from the base civicrm directory: > grep -R "Sorry, can not load CMS user account." ./ 2) GITHUB And if you don't have a command line ...


4

you can override (not recommended): templates/CRM/common/fatal.tpl or set your custom error template here: http://d46.demo.civicrm.org/civicrm/admin/setting/debug?reset=1 You can also specify a different error handler in that setting


4

Well, I'm not sure this is a long-term solution, but it is a workaround.... In one of the Angular posts (Status page angular load error) I found this: another work-around should be going to "Administer => System Settings => Debugging" and disabling the "Asset Cache" That's brought my System Status page back, but I don't like the thought of not using a ...


3

You should double check your civicrm_settings.php file. Particularly the section on File System Paths. Make sure the setting $civicrm_root is the correct path to civicrm for the new server. Hope this helps...


3

I tried many things, including restoring files from two months ago, and then updating, joomla and civicrm, and then reconnecting to the current database, and also rebuilding from vanilla copies of joomla and civicrm. But this did not solve the problem. The problem disappeared after I edited and saved the 'registered users' access rights in a minor way. The ...


3

This was a core bug and was fixed at 5.1.0. You can either apply the patch from here or Upgrade CiviCRM to 5.2.2. HTH Pradeep


3

There have been many answers relating to this type of 'blank' page and most have been solved by ensuring the various paths set in Resources and Directories are correct. Many questions on this have been tagged with angular so hopefully you will find the ones i am thinking of in the list at https://civicrm.stackexchange.com/questions/tagged/angular


3

Another (simpler) option that comes from a slightly different angle -- set up a Page Redirect using Eileen's extension so the user doesn't see the error message at all. This extension redirects all traffic from disabled contribution pages to a default contribution page (which you specify). So if you have a disabled customized donate page that you used ...


2

Since you marked it as Reserved you cannot modify or delete it. (It can be gotten rid of by directly modifying the database, but I think that is the only way.) Your best bet is to ignore it, and create a new rule that you can use. Just don't mark it as Reserved until you are sure that it is defined as you wish. Note that you can edit the name and usage ...


2

This doesn't look like a Wordpress compatibility error. It is, as you guessed, related to deduplication. It sounds like you may not have a rule designated as your "Supervised" dedupe rule - or there's a problem with the rule you have designated as your "Supervised" rule. Check to make sure you have a rule, and if you do, try changing it to the default ...


2

I was able to narrow this down to the Member ID extension. Disabled that and the DB Error resolved it's self. ONE member is unable to renew at this time, but I can process manually


2

This is a common problem with CiviCRM on Pantheon and hasn't entirely been solved, but it has been mitigated. If you follow the instructions and add the patch described here, then there is about a 50% chance it will solve your problem. (In essence it simply requires that you apply this patch.)


2

This error indicates that the web server is trying to connect to another service in order to respond to your request but is unable to. A common scenario is web server software such as nginx, which does not incorporate a PHP interpreter, contacting a service such as php-fpm (typically running on the same server) in order to process PHP. php-fpm might be ...


2

This is a known issue with CiviCRM 5.1.1 that was patched in 5.1.2. The details of the issue are here: https://github.com/civicrm/civicrm-core/blob/5.1/release-notes/5.1.2.md#synopsis Download the new version from https://civicrm.org/download and update your site.


2

As of 4.7 there is no more 'Fatal Error Template' setting. See https://issues.civicrm.org/jira/browse/CRM-16478 You can instead use the standard approach to overriding template files as described here: http://wiki.civicrm.org/confluence/display/CRMDOC/Theming+CiviCRM The custom template directory can be set in: CiviCRM > Administer > System settings > ...


2

WP Engine is a quirky host--it makes lots of configuration decisions for you with the goal of optimizing for WordPress sites, but that often makes things more difficult for CiviCRM. This is in stark contrast to Linode, where you have full control over your hosting configuration. A 500 error could be any number of things; you'll need to find a log message ...


1

I'm getting the same error after upgrading to 4.7.25 from 4.7.16 on my WordPress installation. The disabling the Asset Cache workaround fixes it. I guess, for now, I'll just have to disable it whenever I need to check the system status.


1

Its a known bug, and there is a patch to fix it. You can follow the following steps to fix it: Open file: civicrm/CRM/Core/Payment/PayPalImpl.php Search for: $sub = empty( $params['is_recur'] ) ? 'xclick' : 'subscriptions'; Replace with: $sub = empty( $params['is_recur'] ) ? 'cgi-bin/webscr' : 'subscriptions'; It should be around line number 404 Hope ...


1

A solution is to restrict access to the WordPress page that you are inserting the directory short code into. A plugin such as 'Members' allows you to restrict access to pages & posts by user role, customize the message visitors see when they do not have permission and provide a login widget.


1

Sorry I forgot to put a response here... Just to let those know who may have this issue Adding "Options -MultiViews" to the .htaccess fixed it... Simple fix but was an environment based issue... There is info about this online but apparently I couldn't put 2 and 2 together!!!


1

welcome to the CiviVerse! Check for the presence of the .htaccess files. Depending on how you cloned the site perhaps these were lost.


1

I received a similar message when trying to create a 'Provides Membership to' relationship. If you go in the civicrm_membership table for that contact ID, you will see that the join_date, start_date and end_date fields are all NULL. Set them to the correct values and it should work. This does not answer how you got into the situation in the first place, but ...


1

Not a definitive answer yet but it seems to be related to the way they tried to implement comment fields. I disabled all their "Alphanumeric > text" fields and the errors go away. Still having to dig deeper as to what they did (all through the UI) and why it broke things so badly.


1

welcome to the Stack, You need to update your directories! Head on to "Administer" then "System Settings" and then directories. Point the locations to the right place and save. Don't forget to "clear cache and update paths" afterwards!


1

I just encountered this and solved it. I've opened a ticket CRM-18264 to address this issue, and I've submitted a pull request for both 4.6LTS and 4.7. They've been merged, so you just need to upgrade to CiviCRM 4.6.15+ or CiviCRM 4.7.5+.


1

For this case the originating contribution PageIDs were disabled. Once re-enabled the renewal button worked fine.


1

The qidis the mailing queue ID, which is unique to each combination of recpient and mailing. If you look in the database, you'll be able to work back to see which contact corresponds to the qid. If it's the same contact each time, you might consider excluding them or thinking about anything unique about them.


1

You are on the right track I think. The error is occurring when the values for jid, qid, and h get validated. jid is the job_id and I wouldn't expect that the 85152 is a correct value (assuming your current job_id is only up to 851 or so). Also the change in argument order, while it doesn't affect anything, there is no reason for them to get rearranged. ...


1

Here are a few other possibilities than Xavier's, which seem on point but not yet solving issue: Check the entries in Administer > System Settings > Directories to see if the sites/default/modules directory appears anywhere and adjust as appropriate if it does. Using phpMyAdmin or equivalent, check in the Drupal database in the registry table filename ...


Only top voted, non community-wiki answers of a minimum length are eligible