3

My mistake, I left a hack in civicrm.settings.php (and forgot it, it was months ago) which led to this weird behavior. Reverting the hack solves the problem : // can't remember why I did this 18 months ago, but this is obviously a bad idea... //require_once './sites/all/modules/civicrm/CRM/Core/ClassLoader.php'; require_once 'CRM/Core/ClassLoader.php'; ...


2

I had the same problem in civicrm 4.6 drupal 7.50. I made this patch to fix the issue, i hope that will be useful. https://github.com/rubofvil/civicrm-packages/commit/563a422384ae20cc0077225bebb748813fa6b22d.patch


2

Found the answer so I will post it here to help others. The server /tmp space filled up due to a rogue imagemagick process, so Civimail could not upload new images. This is a known issue with imagemagick - see for example this post. Deleting /tmp/magick-* files solved the problem.


2

Right-click on the "images" folder in the kcfinder browser. You can choose New Subfolder.


2

KCfinder is very sensible with the path to image storage. It configured path to the storage must match the path send by the JS component exactly! It doesn't work well with symbolic links on unix. On windows servers, there may be problems with capital letters and small letters too. I'm not shure, if this may be the problem in this case, but just double ...


2

It turned out that our was a permission issue. I'm on Pantheon so I want able to change the permissions on the directory I was using, so I changed directories for uploads and it worked


2

The problem was caused by the CiviMobile extension which injected script code before the original page content and before the OnLoad event for loading the JQuery library. After removing this plugin, the upload page comes up properly.


1

Per comments above, this bug was fixed by @herb in https://github.com/civicrm/civicrm-packages/pull/216


1

you need to create a settings.localtion.php file in your civicrm directory then have define('CIVICRM_CONFDIR', 'directory where civicrm.settings.php is');


1

Check the ownership of the folders where these images are uploaded to.


1

You may want to check Firewall or the settings in WPSecurity (plugin) if you have that installed. I ran into this problem and it was an option in WPSecurity for "Bad Query Strings" which blocked access to thumbnails in KCFinder. According to the plugin... Deny Bad Query Strings This feature will write rules in your .htaccess file to prevent ...


1

The settings_location.php file should not normally be required, but an example is described at: https://wiki.civicrm.org/confluence/pages/viewpage.action?pageId=83034188 The file civicrm.config.php should be able to handle bootstrap in most common configurations without settings_location.php. However, this depends on having somewhat plain/predictable ...


1

I don't think there's an intentional change in system requirements. However, looking at civicrm.config.php, I can see it's undergone recent changes. It looks like you're having trouble because your PHP configuration doesn't allow running the "exec" command. That's often done for security - but if you can change your configuration to allow it, I think you'...


1

There used to be a requirement that the URLs that Andrei referred to above could not contain symbolic links. I don't know if that is still the case, but make sure that all directories in that path are true directories and not symbolic links.


Only top voted, non community-wiki answers of a minimum length are eligible