Skip to main content
Share Your Experience: Take the 2024 Developer Survey
8 votes

Is it OK to switch to PHP 7.2 now that Drupal 7.6.1 supports it?

The latest versions of CiviCRM run fine with PHP 7.2. However, a) this has only been true a few months, b) Drupal 7 has only very recently become 7.2-compatible, c) most major Linux distributions don'...
Jon G - Megaphone Tech's user avatar
7 votes
Accepted

Unexpected T_CLONE, expecting T_STRING (PHP 7, Drupal 7, Ubuntu 16.04)

PHP 7 is not supported yet - see CRM-17789 Also: this and this Update (Aug 2017): The information above was correct when it was written. Things have moved on and PHP 7.0 is supported from 4.7.12 ...
Aidan's user avatar
  • 13.5k
5 votes

Will there be a LTS release of CiviCRM 4.6.x that supports PHP 7+

This kind of question is hard to answer for an open source project like CiviCRM :-) There is no 'owner' of the product that can tell you this. Nor is there a group of paid developers that will be able ...
ErikH - CiviCooP's user avatar
4 votes

What are the minimum and recommended changes to CiviCRM to support PHP 7?

None any more - as of 4.7.12, CiviCRM supports PHP7
michaelmcandrew's user avatar
4 votes

Will there be a LTS release of CiviCRM 4.6.x that supports PHP 7+

When PHP 5.6 reaches it end of life. It means basicly that no further updates are coming from the official php group. But it means you can still keep php 5.6 on your server it does not stop from ...
Jaap Jansma - CiviCooP's user avatar
3 votes

Missing attribute payment_processor_id of entity Contribution in API Explorer v3?

From api explorer the results are retrieved using rest api where check_permissions is always set to TRUE by default even though its been explicitly set via api params. If you have check_permissions ...
Pradeep Nayak's user avatar
3 votes

Will there be a LTS release of CiviCRM 4.6.x that supports PHP 7+

Skvare was considering supporting 4.6 on php 7. See this link
Aidan's user avatar
  • 13.5k
3 votes

Buildkit Site fails to load due to PHP ugrade from 5 to 7

It seems to me you need to install the php-xml package. sudo apt-get install php-xml should get you there on Ubuntu.
ak5's user avatar
  • 31
3 votes
Accepted

Buildkit Site fails to load due to PHP ugrade from 5 to 7

It's on your php.ini config file. where it it depends on your OS, in ubuntu/debian it's under /etc/php5 and you have cli and fpm, check that the cli version enables the extension simplexml FYI, ...
Xavier's user avatar
  • 10.2k
3 votes
Accepted

mailchimp extension error, php 7.1, civi 5.10.4, drupal 7.x

patch: index 5b82f65e..76c816dc 100644 --- a/uk.co.vedaconsulting.mailchimp-2.0.1/CRM/Mailchimp/Permission.php +++ b/uk.co.vedaconsulting.mailchimp-2.0.1/CRM/Mailchimp/Permission.php @@ -1,6 +1,6 @@ ...
ericG's user avatar
  • 600
2 votes

PEAR packages and PHP 7.4

I was updating from an early version of CiviCRM (4.7.30) to the latest one, together with an upgrade from Drupal 8.7 to 9.4. I had to do progressive updates i.e. to 5.26.2/8.8, then 5.51.3/8.8, then 5....
krystalcode's user avatar
2 votes
Accepted

Is PHP 7.4 fully supported?

Not yet officially. If you want to track progress you can subscribe to the ticket at https://lab.civicrm.org/dev/core/issues/1496 and its subtickets. If you find some issue feel free to report it in ...
Demerit's user avatar
  • 23.1k
2 votes
Accepted

Label Format does not fit in database - PHP 7.1 json_encode() and serialize_precision

I confirm that this is a bug in civicrm. I was able to replicate on my local running PHP 7.1. I've created a Gitlab issue at https://lab.civicrm.org/dev/core/issues/612
jitendra - fuzion's user avatar
2 votes

Call to undefined function dl() error w/Joomla 3.5.1 & PHP 7

I learned that php7 is not supported yet. https://wiki.civicrm.org/confluence/display/CRMDOC/CiviCRM+PHP+Requirements
Greg's user avatar
  • 51
2 votes

Need help upgrading 4.4.5 to 4.7.18 0n Ubuntu 16.04 server with PHP 7 on Drupal 7

Does your VPS let you choose the version of PHP? If so, downgrade the version of PHP, upgrade CiviCRM, reset the PHP version. Alternatively you could copy your installation to another server with ...
Aidan's user avatar
  • 13.5k
2 votes

Warning: count(): Parameter must be an array or an object that implements Countable

It sounds like you're running PHP 7.2 or greater with a version of CiviCRM that doesn't support PHP 7.2+. If you edit your question to include your CiviCRM version, that could help folks troubleshoot....
Jon G - Megaphone Tech's user avatar
1 vote
Accepted

Ajax error with Manage Groups after upgrading to PHP 7.3, MySQL 8.0 and 5.22.0

MySQL 8 isn't officially supported yet. This particular problem should be fixed in 5.23 though since it's the word "groups" that mysql 8 doesn't like - see https://lab.civicrm.org/dev/core/issues/1143 ...
Demerit's user avatar
  • 23.1k
1 vote

DB Error: constraint violation (WordPress)

Aaron welcome to stack exchange, Can you logout and login again? If its a new install than you contact id might have not set properly in session.
Pradeep Nayak's user avatar
1 vote

failed to open stream after PHP upgrade to 7.3

May be a stupid question but have you purged caches / cache folders entirely? e.g. Clear the templates_c folder?
EagleUK's user avatar
  • 343
1 vote

Email not working after upgrade to PHP 7.0

Check this answer on the SE question SMTP connection failing problem. Seems related with your problem due to the PHP update above version 5.5.
Francesc Bassas i Bullich's user avatar
1 vote

Email not working after upgrade to PHP 7.0

It's likely that you've added (or removed) the php-crypt library in your PHP upgrade process. This would cause your password to be encrypted in an incompatible method. Re-enter your credentials or ...
Jon G - Megaphone Tech's user avatar
1 vote

Fatal error when accessing Civicrm administrator page

You have two options for troubleshooting: Debug and backtrace info should also be in your CiviCRM logs, stored in the ConfigAndLog directory. You can enable debug and backtrace by adding these three ...
Jon G - Megaphone Tech's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible